Ipv4 to Ipv6

Answered Question
Nov 24th, 2009
User Badges:


I have a cisco router 2800 as my default gateway in my LAN. IPv4 is  the format of the addesing in the LAN and the WAN interface. But now, the WAN conectivity will be IPv6.


The actual diagram is the folowing:

LAN: 172.16.30.X/23 ---ipv4-LAN--> f0/0(Router)f0/1---ipv4-WAN-->
The router 2800 has a defaul router: 0.0.0.0 0.0.0.0 f0/1


The diagram will be:
LAN: 172.16.30.X/23 ---ipv4-LAN--> f0/0(Router)f0/1---IPV6-WAN-->


How enable the ipv6 routing in the 2800 Routers?

What I need?

Correct Answer by Jerry Ye about 7 years 6 months ago

You will need to check your 2800's software to see if the following command is available


ipv6 unicast-routing


This will turn on IPv6 routing, and you can assign IPv6 address and configure IPv6 default route on your router.


You also need IPv4 to IPv6 NAT to be configured.


Please see the following link on how to configure IPv6 in IOS 12.4


http://www.cisco.com/en/US/docs/ios/ipv6/configuration/guide/12_4/ipv6_12_4_book.html


Regards,

jerry

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jerry Ye Tue, 11/24/2009 - 12:37
User Badges:
  • Cisco Employee,

You will need to check your 2800's software to see if the following command is available


ipv6 unicast-routing


This will turn on IPv6 routing, and you can assign IPv6 address and configure IPv6 default route on your router.


You also need IPv4 to IPv6 NAT to be configured.


Please see the following link on how to configure IPv6 in IOS 12.4


http://www.cisco.com/en/US/docs/ios/ipv6/configuration/guide/12_4/ipv6_12_4_book.html


Regards,

jerry

ricardorojas123 Tue, 11/24/2009 - 12:46
User Badges:

Yes, the command is supoorted in the Cisco Roter 2800.


My configuration is the following:


ip dhcp excluded-address 172.16.30.1 172.16.30.10

ip dhcp pool lan

   network 172.16.30.0 255.255.255.0

   default-router 172.16.30.1


interface FastEthernet0/0
description ***LAN***
ip address 172.16.30.1 255.255.255.0

ip nat inside


!
interface FastEthernet0/1
description ***WAN***
ip address 200.111.X.X 255.255.X.x
ip nat outside

access-list 1 permit 172.16.30.0 0.0.0.255

ip nat inside source list 1 pool ranca overload

Actions

This Discussion