RV082 Drops Skype Calls

Unanswered Question
Nov 25th, 2009

Hi

We use Skype a lot to communicate with dispersed workers on site. This has been working well but in the past week our router has been constantly dropping skype calls after anywhere between 30 seconds and 4 minutes. Looking in the system log, the router is rejecting incoming packets to the skype clients configured TCP port when the call is dropped. Does anyone know what I can do to stop the router rejecting the packets - skype uses individual renadom ports for evry client so I cant just open up a port on the firewall and this has been working fine unti recently.

Thanks

Roger.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Carr Wed, 11/25/2009 - 07:58

Since skype is using random ports you can setup those range of ports that they use as a trigger ports.  That way if it uses a port in that range it will allow it through.  With those random ports it is tricky in setting up quality of service.  I hope this helps.

roger.barrett Fri, 03/26/2010 - 09:26

Hi

we're still suffering from dropped calls - if we connect directly to our adsl routers we can sustain calls for 2 hours but through the rv082 its minutes. I have forwarded the skype ports used by the client machines to the relevant machine but the calls still drop and I can see the packets being rejected in the firewall log. I also see other packets being rejected by the firewall where there are no rules to block them - for example occaisionally packets on the vpn tunnels are being blocked between machines on our WAN subnets.

Is this likely to be a problem with the SPI on our firewall? I dont want to turn this off and I'd really like to resolve this issue as its causing us problems and Im being asked to look at alternative routers.

Thanks

Roger.

renatotoi Tue, 05/18/2010 - 12:04

Are you using dual-wan ? If you are, did you try binding protocols http and https to one of the wans ?

Renato

roger.barrett Tue, 05/18/2010 - 12:38

Hi Renato

yes we had to do this from day 1 otherwise a lot of simple browsing wouldnt work either. I swapped to a Draytek Vigor 2910 dual wan a few weeks ago and the skype issue went away - the router does everything else the RV082 did and has a much smaller footprint. Its a shame the linksys firmware doesnt work properly but as the rv082 is getting on now I cant see cisco sorting out the firmware now so decided t give it up.

Roger.

renatotoi Tue, 05/18/2010 - 12:58

Yeah.

Never heard aboyt Draytek before. Thanks.

Wish I knew it before getting rv016.

It is only fair getting to know about a competitor in a Cisco forum :-)

-renato

brasakai Wed, 05/19/2010 - 13:42

Sorry for the late reply.  We will look into it.  One question did you call the Small Business Support Center for help?  If there is a bug in the code, obviously they will not be able to help you immediately, but they can escalate the bug to our group faster than if it is posted on the community site.  Unfortunately, we do have the staffing to check every post to the site.

brasakai Fri, 06/04/2010 - 08:27

We are able to run multiple SKYPE calls through the RV082.  Since we did not have your exact setup info, we may not be replicating the problem you were having.  In the unlikely scenario where you are still using the RV082 and still having the problem, please contact our support center so they can get all of the pertinent data for us better troubleshoot your problem.

roger.barrett Fri, 06/04/2010 - 10:36

Hi - it wasnt multiple skype calls that was the issue - it was single calls either in or out from our lan to the internet. I could see the packets being dropped by the firewall when the calls dropped (at random intervals) even if the specific ports being used by the skype clients were added to the firewall exceptions. We had dual wan set up in load balancing mode but all calls from the pc clients were sent via one wan port in the load balancing rules. I still have the router but its not currently being used as when we swapped to the draytek router the skype issue went away but if you can fix this issue I'd rather use the linksys router as the WAN VPn connections were more stable on the linksys router.

roger.barrett Wed, 08/25/2010 - 21:06

Hi Thomas

In a way, I'm glad someone else has confirmed this is happening - I was beginning to think I'd messed up the config and not realised. Yes this is the router I'm using - there are a few variants of the model to include wireless, VOIP etc. As you probably know the only way on any router to give Skype calls priority is to fix the port sthat the skype clients are using and then define those ports in the QOS settings. You can do this on the Draytek but I had no problems without any QOS on a 2 Mbit adsl connection.

The interface isnt quite as intuitive as the Linksys and I had to configure one of our VPN tunnels to ping to keep it alive but other than that I've had no issues since swapping from the RV082 - which is a shame as I tend to like Linksys stuff.

Roger

Thanks a ton for getting back to me on this. I just cant give up on the rv082 yet... To me I think (and im just getting into this) that skype is dropping calls because im using 2 dsl lines and it seems like while I can change the ports skype is using for incoming connections and then give those ports "high" priority on Wan1 sometimes skype traffic (outgoing maybe) is going out WAN2. I do not know a rock solid way to find port skype is using for outgoing (i think because its random) When I look at system log I see a bunch of "connection refused- Policy violation" from Ip's that are associated with skype... the port is usually 12340. So I have added that as a port for priority on WAN1 as well.

Are you using 2 WAN's?

Do you have your modems going into cisco/daytek bridged or routed with static Ip's?

Do you have anything other than your INCOMING skype ports with priority for skypes sake?

My biggest fear is that dual wan and skype just wont work with this router no matter what I do...

I have spoke with cisco for a combined 5 hours and I feel like Im  making progress but wont know until sales people stop yelling at me for dropped calls.

Anyway thanks a bundle for your time

Thomas Dionne

Franklin Financial Group

dual wan skype load balancing router cisco rv082

roger.barrett Fri, 08/27/2010 - 04:32

Hi Thomas

if youve got your router set up to load balance at a certain bandwidth and havent restricted certain LAN clients to only use one of the WANs then Skype (and a lot of other apps) will drop the connection frequently. This is because Skype is talking to one IP address one minute and then the load balancing on the router switches the outgoing traffic to the other WAN connection. The IP address of the traffic has then changed and Skype drops the call. (You will notice HTTPS connections drop as well - try logging into your banks website when the traffic on your router is busy and you wont stay logged in for very long).

To get around this I fixed all of the LAN clients to use 1 WAN connection and the office server and the inter-office VPN connections I had to use the oher WAN connection - in case of a failure, all traffic goes over the remining live WAN connection by default.

Even after I did this I found the single WAN being used by the desktop/laptop clients still rejected skype packets on an intermittent frequency- I could see in the system log that the packets were leaving and being received by the correct WAN port but the firewall still droppped them anyway. When I configured the Draytek router to do the same functions, Skype worked perfectly.

If you want to have a router that load balances on high bandwidth demands and can still keep things like skype active without breaking the connection, then I think your're going to be out of luck. If you've done all of this and the router still drops your skype calls then you have the same problem that I had and changing routers may well help you.

Rger.

Since I have to many folks to put on WAN1 I tried to just put skype on WAN1 and thats just a recipie for disaster (from what I know after 10 hours on phone with cisco and another 10 testing things)  The only thing that has worked is disconnecting wan2!  any other way i have "policy violations" popping up 80 times a day.  Skype and dual Wan does not work if you need pc's to use both WAN's....

ATTENTION FUTURE PEOPLE USING THIS ROUTER FOR THIS PURPOSE, GIVE UP!

If I am wrong please let me know... thomasd at franklin-finance dot com

thanks roger...

Logicbus_SoporteTI Fri, 09/10/2010 - 14:56

Hello, I have been experiencing the same problem with my RV082, it is dropping our HTTPS' connections. We are at a bank website and suddenly we are dropped out of the secured site. It's really anoying that the Load Balance and Protocol Binding configuration aren't working as this configuration were supposed to work.

Do you need a file generated from the RV082 so you can have our RV082 exact setup

info?

Or would it be possible for you to reproduce the problem just with the next information:

- I have assigned a fixed IP to my computer: 192.168.100.150

- interfaces in the RV082 are:

   WAN 1: Is 256kb upstream & 2048kb downstream

   WAN 2: Is 2048kb upstream & 10240Kb downstream

I have configured the Protocol Binding to All Traffic [TCP&UDP1~65535] for IP 192.168.100.150 to go through interface WAN2 and it is enabled (please see attached screenshot).

But as I have said before, the https' connections are dropping.

I hope you can help me solve this issue.

Best.

Actions

This Discussion