Show Version command displays old IOS on Cisco 4948?

Answered Question
Nov 25th, 2009
User Badges:

Recently upgraded our Cisco 4948 with no apparently problems.  The switch appears to be opperating fine.  However when you enter "show version" it still shows the old IOS.  When you enter "show config" or "show running-config" it shows the upgraded version.  How do we correct the "show version" command to display the current IOS?


Thanks,

Correct Answer by Jon Marshall about 7 years 7 months ago

cdalask wrote:


I noticed you entered the word bootflash:/ with a slash before the filename.  This could be where I'm missing the boat because it doesn't show "bootflash" when I use the auto complete feature.  I have been entering #boot system flash cat4500-ipbasek9-mz.122.53.SG1.bin and I haven't been entering a forward slash! I will give it another try once you confirm my reply.


Thanks,

~c

You shouldn't need the / but from memory i don't think it matters either way. Don't use the auto complete feature at the moment, just type it in manually and make sure you save it to memory. You just need to confirm it is in the running config with bootflash in the string before you reload the switch.


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Reza Sharifi Wed, 11/25/2009 - 08:51
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Since you loaded a new image on your box, you now have to images on flash. When you boot you router is will boot the first IOS image which is your old one.  You need to point your router to boot from the new IOS. the command is:

boot system flash

Then boot you router, it should now boot from the new image.

Now if every thing is working fine you can delete the old IOS.


HTH

Reza

cdalask Wed, 11/25/2009 - 10:31
User Badges:

Thanks for the quick reply.  I did run the boot system flash command and copied it to config.  I still see the following when I run the below commands:


sh bootvar = cat4500-ipbasek9-mz.122-53.SG1.bin,1;


sh config boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin



However when I run Show Version I receive the old IOS


sh ver System Image File is "bootflash:cat4500-ipbase-mz.122-31.SGA4.bin


Could it be that the sh ver command is listing the old IOS because I haven't yet deleted it from the bootflash directory?


Thanks ahead!

Jon Marshall Wed, 11/25/2009 - 10:36
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Can you post running config.


Also are you sure the switch is running the new IOS ?


Jon

Reza Sharifi Wed, 11/25/2009 - 10:47
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

I do not recommend you delete the old IOS yet.

You want to make sure you have the new IOS on your flash and every thing is working before you delete the old image, if not you can run to a problem of not having any good IOS installed and that can cause an outage.


HTH

Reza

cdalask Wed, 11/25/2009 - 11:55
User Badges:

Jon,


Below sh running-config, dir bootflash and sh version.  You will see the new IOS in sh run and the old in sh ver.  The sh run output is obviously edited down. Thanks for your help!


ABC-Switch#sh running-config                           
Building configuration...                       

Current configuration : 7114 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname ABC-Switch
!
boot-start-marker
boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin
boot-end-marker
!
enable secret 5 $1$CMK6$0qoYN2TJPe0wzBPUfFCLe0
!
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 172.x.x.x x.x.x.x
ip dhcp excluded-address 172.x.x.x x.x.x.x
ip dhcp excluded-address 192.x.x.x x.x.x.x
--More--

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ABC-Switch#dir bootflash:
Directory of bootflash:/

    1  -rwx    12204260  Sep 22 2008 13:52:18 +00:00  cat4500-ipbase-mz.122-31.S
GA4.bin
    3  -rwx    16170184  Nov 23 2009 13:40:07 +00:00  cat4500-ipbasek9-mz.122-53
.SG1.bin

60817408 bytes total (16272396 bytes free)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


ABC-Switch#sh version                    
Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500-IPBASE-M), Version
12.2(31)SGA4, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Thu 25-Oct-07 16:15 by hqluong
Image text-base: 0x10000000, data-base: 0x114AE964

ROM: 12.2(31r)SGA1
Dagobah Revision 226, Swamp Revision 5

CGS-Switch uptime is 1 hour, 33 minutes
System returned to ROM by power-on
System image file is "bootflash:cat4500-ipbase-mz.122-31.SGA4.bin"

cisco WS-C4948 (MPC8245) processor (revision 0) with 262144K bytes of memory.
Processor board ID FOX1228GMDE
MPC8245 CPU at 266Mhz, Fixed Module
Last reset from PowerUp
4 Virtual Ethernet interfaces
48 Gigabit Ethernet interfaces
511K bytes of non-volatile configuration memory.

Configuration register is 0x2101


Thanks,

Jon Marshall Wed, 11/25/2009 - 12:05
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Okay, you are actually still running the old IOS and it is because your config register is set to 0x2101 which tells the switch to load the first IOS it finds in flash.


So you need to change your config register to 0x2102 and then reload.


Edit - just for your info. "sh version" shows the actual IOS running on your switch/router. "sh run" simply shows the config the switch/router is working with but it won't tell you which IOS is actually in use.


Jon

cdalask Wed, 11/25/2009 - 14:46
User Badges:

I changed the config register to 0x2102 and rebooted.  It booted to rommon>   I managed to reload the original config and the switch is up but the config registry is back to 0x2101 and the sh ver still shows the old IOS.  I know I am doing something wrong...just haven't figured it out yet.  Any idea what rookie mistake I made?


Thanks...

Jerry Ye Wed, 11/25/2009 - 15:35
User Badges:
  • Cisco Employee,

Your boot statement did not point to the bootflash which contain the file cat4500-ipbasek9-mz.122-53.SG1.bin


Try this along with the config register of 0x2102



no boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin

boot system flash bootflash:cat4500-ipbasek9-mz.122-53.SG1.bin

wri mem


Use show boot to verify the boot statement and reload.


Regards,

jerry

cdalask Mon, 11/30/2009 - 07:45
User Badges:

Sorry it took so long to reply.  I have a couple more questons before I reload.  I still am not convinced I am entering the boot/no boot command correctly.  I have copied a couple of commands below.  When I enter the no boot system flash command my option is to enter the WORD at that point...see below:


~~~~~~~~~~~~~~~~~~~~~~~~~

ABC-Switch(config)#no boot
ABC-Switch(config)#no boot sys
ABC-Switch(config)#no boot system fl
ABC-Switch(config)#no boot system flash ?
  WORD  System image filename
 


~~~~~~~~~~~~~~~~~~~~~~~~~


So the correct command for me to remove the current boot statement would be "no boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin" ?

I want to be certain I don't have to also enter the word bootflash prior to the file name!


So I guess my question is do I enter "bootflash" in front of the file name when using the "no boot system flash" and the "boot system flash" commands?


Lastly, I don't have an option to enter the show boot command, the command line wants show bootflash:  Below is what I receive after doing the add remove steps.


~~~~~~~~~~~~~~~~~~~~~~~~~


ABC-Switch#sh bootfl
ABC-Switch#sh bootflash:
-#- ED ----type---- --crc--- -seek-- nlen -length- ---------date/time--------- n
ame
1   .. image        2C558EEC  BE3964   33 12204260 Sep 22 2008 13:52:18 +00:00 c
at4500-ipbase-mz.122-31.SGA4.bin
2   .D image        18E0CC7D 1B4F6AC   34 16170184 Nov 23 2009 13:31:09 +00:00 c
at4500-ipbasek9-mz.122-53.SG1.bin
3   .. image        18E0CC7D 2ABB3F4   34 16170184 Nov 23 2009 13:40:07 +00:00 c
at4500-ipbasek9-mz.122-53.SG1.bin

16272396 bytes available (44545012 bytes used)
ABC-Switch#

I really would like to see the actual file the system will boot from before reloading.  Number 1 above is obviously the old IOS.


Thanks,

Jon Marshall Mon, 11/30/2009 - 07:58
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

cdalask wrote:


Sorry it took so long to reply.  I have a couple more questons before I reload.  I still am not convinced I am entering the boot/no boot command correctly.  I have copied a couple of commands below.  When I enter the no boot system flash command my option is to enter the WORD at that point...see below:


~~~~~~~~~~~~~~~~~~~~~~~~~

ABC-Switch(config)#no boot
ABC-Switch(config)#no boot sys
ABC-Switch(config)#no boot system fl
ABC-Switch(config)#no boot system flash ?
  WORD  System image filename
 


~~~~~~~~~~~~~~~~~~~~~~~~~


So the correct command for me to remove the current boot statement would be "no boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin" ?

I want to be certain I don't have to also enter the word bootflash prior to the file name!


So I guess my question is do I enter "bootflash" in front of the file name when using the "no boot system flash" and the "boot system flash" commands?


Lastly, I don't have an option to enter the show boot command, the command line wants show bootflash:  Below is what I receive after doing the add remove steps.


~~~~~~~~~~~~~~~~~~~~~~~~~


ABC-Switch#sh bootfl
ABC-Switch#sh bootflash:
-#- ED ----type---- --crc--- -seek-- nlen -length- ---------date/time--------- n
ame
1   .. image        2C558EEC  BE3964   33 12204260 Sep 22 2008 13:52:18 +00:00 c
at4500-ipbase-mz.122-31.SGA4.bin
2   .D image        18E0CC7D 1B4F6AC   34 16170184 Nov 23 2009 13:31:09 +00:00 c
at4500-ipbasek9-mz.122-53.SG1.bin
3   .. image        18E0CC7D 2ABB3F4   34 16170184 Nov 23 2009 13:40:07 +00:00 c
at4500-ipbasek9-mz.122-53.SG1.bin

16272396 bytes available (44545012 bytes used)
ABC-Switch#

I really would like to see the actual file the system will boot from before reloading.  Number 1 above is obviously the old IOS.


Thanks,




You need to do the following -


4500(config)# no boot system flash cat4500-ipbasek9-mz.122-53SG1.bin

4500(config)# wr mem


then do a "sh run" and make sure there are no "boot system ...." commands in the running-config. If there are remove them.


Then


4500(config)# boot system flash bootflash:cat4500-ipbasek9-mz.122-53SG1.bin

4500(config)# wr mem


then do "sh run" and make sure you see the "boot system ..." command that you have just typed in.


Also make sure that you have typed the filename in correctly, double check to be sure.


Then reload the switch.


Jon

cdalask Mon, 11/30/2009 - 08:06
User Badges:

I'll give it a try.  I should also change the registry to 0x2102 before reloading...correct?


Thank you

Jerry Ye Mon, 11/30/2009 - 08:08
User Badges:
  • Cisco Employee,

Yes, the config reg should be at 0x2102.


Regards,

jerry

cdalask Mon, 11/30/2009 - 10:37
User Badges:

Jon,

Followed your instructions to the letter.  The Catalyst still boots to >rommon.  I am forced to enter "boot" at the rommon prompt in order to get the switch to boot from the old IOS.  I have the registry at 0x2102 now as well.  I can copy an paste any conf you might want to look at.  Your help is greatly appreciated.

~c

Jon Marshall Mon, 11/30/2009 - 10:42
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Can you post


1) "sh run" from switch

2) "sh ver" from switch

3) dir flash or dir bootflash from switch


What do you see on the console when you reboot ie. does it even try to load the new IOS ?


Jon

cdalask Mon, 11/30/2009 - 12:54
User Badges:

Jon,


When it does attempt to boot at the rommon prompt I can see it attempt several times before I have to type "boot" at >rommon.  Below are the commands you requested:


ABC-Switch#sh run                

Building configuration...                        

Current configuration : 7114 bytes                                 

!

version 12.2           

no service pad             

service timestamps debug uptime                              

service timestamps log uptime                            

no service password-encryption                             

service compress-config                      

!

hostname ABC-Switch                  

!

boot-start-marke              

boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin                                                   

boot-end-marker              

!

enable secret 5 $1$CMK6$0qoYN2TJPe0wzBPUfFCLe0                                             

!

no aaa new-model               

ip subnet-zero             

ip dhcp excluded-address x.x.x.x x.x.x.x                                                 

ip dhcp excluded-address x.x.x.x x.x.x.x                                                

ip dhcp excluded-address x.x.x.x x.x.x.x                                                   

ip dhcp excluded-address x.x.x.x x.x.x.x                                                     

!

ip dhcp pool DATA_NETWORK                        

   network x.x.x.x x.x.x.x                                   

   default-router x.x.x.x                             

   dns-server x.x.x.x                          

!

ip dhcp pool MGMT_NETWORK                        

   network x.x.x.x x.x.x.x                                    

  default-router x.x.x.x                              

   dns-server x.x.x.x                         

!

ip multicast-routing                   

vtp mode transparent              

!

power redundancy-mode redundant                              

no file verify auto                  

spanning-tree mode pvst                      

spanning-tree extend system-id                             

!

vlan internal allocation policy ascending                                        

!

vlan 10      

name DATA_VLAN              

!

vlan 20      

name MGMT_VLAN              

!

vlan 100       

name EXT_VLAN             

!

interface Loopback0                  

ip address x.x.x.x x.x.x.x                                  

ip pim sparse-dense-mode                        

!

interface GigabitEthernet1/1                           

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/2                           

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/3                           

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/4                           

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/5                           

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/6                           

description DATA VLAN                    

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/7                           

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/8                           

description DATA VLAN                     

switchport access vlan 10                        

switchport mode access                      

!

interface GigabitEthernet1/9                           

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/10                            

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/11                            

description DATA VL                  

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/12                            

description DATA VLAN                     

switchport access vlan 10                         

switchport mode access                      

!

interface GigabitEthernet1/13                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/14                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/15                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/16                            

description MGMT               

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/17                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/18                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

no keepalive            

!

interface GigabitEthernet1/19                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/20                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

keepalive 1000              

!

interface GigabitE               

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/22                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/23                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/24                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/25                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEtherne                      

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/27                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/28                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

spanning-tree portfast                      

!

interface GigabitEthernet1/29                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/30                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/31                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/32                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/33                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/34                            

description MGMT VLAN                     

switchport access vlan 20                         

switchport mode access                      

!

interface GigabitEthernet1/35                            

description EXT VLAN                    

switchport access vlan 100                          

switchport mode acc                 

!

interface GigabitEthernet1/36                            

description EXT VLAN                    

switchport access vlan 100                          

switchport mode access                      

!

interface GigabitEthernet1/37                            

description EXT VLAN                    

switchport access vlan 100                         

switchport mode access                      

!

interface GigabitEthernet1/38                            

description EXT VLAN                    

switchport access vlan 100                          

switchport mode access                      

!

interface GigabitEthernet1/39                            

description EXT VLAN                    

switchport access vlan 100                          

switchport mode access                      

!

interface GigabitEthernet1/40                            

description EXT VLAN                    

switchport access vlan 100                          

switchport mode a                

!G

interface GigabitEthernet1/41           

ABC-Switch#ption

description EXT VLAN   

ABC-Switch#    

switchport access vlan 100                    

ABC-S

switchport mode access

ABC-Switch#switchport

!

interface GigabitEthernet1/42/techsuppo                  

description EXT VLANive                 

switchport access vlan 100

ABC-Switch#gabitEthern 

switchport mode access-Switch#ig)#^Zds      

!

interface GigabitEthernet1/43 

descripti         

ABC-S

description EXT VLAN                

ABC

switchport access vlan 100            

ABC-Switch# 2

switchport mode access      

ABC-Switch#   

!

interface GigabitEthernet1/44             

ABC-Sw     

description EXT VLAN

descr     

ABC-Swi

switchport access vlan 100-Switch#ass             

switchport mode access#vlan 20ent           

!

interface GigabitEthernet1/45

ABC-Switch#mode access     

description EXT VLANwitch#ess-config    

switchport access vlan 100e GigabitEt               

switchport mode a48              

switch      

ABC-S

description EXT VLAN        

ABC-Switch#

switchport access vlan 100 access                   

switchport mode access          

ABC-Switch#

!G

interface Vlan1             

no ip address new-mo      

shutdown    

ABC

!w

interface Vlan10 descr     

ABC

description DATA_VLAN                 

ABC

ip address x.x.x.x x.x.x.x ABC-Switch#vlan 20                 

ip pim sparse-dense-modeS-Switch#mode a         

!

interface Vlan20

switch      

ip pim send-rp-announce Loopback0 scope 3

ip pim send-rp-discovery Loopback0 scope 3

!

!

!

!

control-plane

!

!

line con 0

logging synchronous

stopbits 1

line vty 0 4

password xxxxxxxx

logging synchronous

login

line vty 5 15

password xxxxxxxx

logging synchronous

login

!

end

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ABC-Switch#dir bootflash:

Directory of bootflash:/

    1  -rwx    12204260  Sep 22 2008 13:52:18 +00:00  cat4500-ipbase-mz.122-31.S

GA4.bin

    3  -rwx    16170184  Nov 23 2009 13:40:07 +00:00  cat4500-ipbasek9-mz.122-53

.SG1.bin

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ABC-Switch#sh version          

!

ROM: 12.2(31r)SGA1

Dagobah Revision 226, Swamp Revision 5

ABC-Switch uptime is 2 hours, 35 minutes

System returned to ROM by reload

System image file is "bootflash:cat4500-ipbase-mz.122-31.SGA4.bin"

cisco WS-C4948 (MPC8245) processor (revision 0) with 262144K bytes of memory.

Processor board ID FOX1228GMDE

MPC8245 CPU at 266Mhz, Fixed Module

Last reset from Reload

4 Virtual Ethernet interfaces

48 Gigabit Ethernet interfaces

511K bytes of non-volatile configuration memory.

Configuration register is 0x2102

Thanks again.

~c

Jon Marshall Mon, 11/30/2009 - 13:06
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

cdalask wrote:


Jon,


When it does attempt to boot at the rommon prompt I can see it attempt several times before I have to type "boot" at >rommon.  Below are the commands you requested:


ABC-Switch#sh run                

Building configuration...                        

Current configuration : 7114 bytes                                 

!

version 12.2           

no service pad             

service timestamps debug uptime                              

service timestamps log uptime                            

no service password-encryption                             

service compress-config                      

!

hostname ABC-Switch                  

!

boot-start-marke              

boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin                                                   

boot-end-marker              

!



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ABC-Switch#dir bootflash:

Directory of bootflash:/

    1  -rwx    12204260  Sep 22 2008 13:52:18 +00:00  cat4500-ipbase-mz.122-31.S

GA4.bin

    3  -rwx    16170184  Nov 23 2009 13:40:07 +00:00  cat4500-ipbasek9-mz.122-53

.SG1.bin

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


You still have the wrong boot statement in your config. Do this


4500(config)# no boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin

4500# wr mem


then do a "sh run". You should not see the boot system flash statement that is there at the moment.


Then


4500(config)# boot system flash bootflash:cat4500-ipbasek9-mz.122-53.SG1.bin   <--- note the additional "bootflash" in the statement

4500# wr mem


then do a "sh run" again and you should see the new boot system flash statement.


Then reload the switch.


Jon

Jerry Ye Mon, 11/30/2009 - 13:03
User Badges:
  • Cisco Employee,

You have to re-do your boot statement with the following command


conf t

no boot system flash cat4500-ipbasek9-mz.122-53.SG1.bin
boot system flash bootflash:ca
t4500-ipbasek9-mz.122-53.SG1.bin

exit
wri mem


Please post the output of show boot before you reboot your 4948.


Regards,

jerry

cdalask Mon, 11/30/2009 - 13:19
User Badges:

I noticed you entered the word bootflash:/ with a slash before the filename.  This could be where I'm missing the boat because it doesn't show "bootflash" when I use the auto complete feature.  I have been entering #boot system flash cat4500-ipbasek9-mz.122.53.SG1.bin and I haven't been entering a forward slash! I will give it another try once you confirm my reply.


Thanks,

~c

Correct Answer
Jon Marshall Mon, 11/30/2009 - 13:22
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

cdalask wrote:


I noticed you entered the word bootflash:/ with a slash before the filename.  This could be where I'm missing the boat because it doesn't show "bootflash" when I use the auto complete feature.  I have been entering #boot system flash cat4500-ipbasek9-mz.122.53.SG1.bin and I haven't been entering a forward slash! I will give it another try once you confirm my reply.


Thanks,

~c

You shouldn't need the / but from memory i don't think it matters either way. Don't use the auto complete feature at the moment, just type it in manually and make sure you save it to memory. You just need to confirm it is in the running config with bootflash in the string before you reload the switch.


Jon

cdalask Mon, 11/30/2009 - 14:06
User Badges:

Success! I believe my error was not entering the word bootflash: after boot system flash.  Thanks for your support and patience!


~c

Jon Marshall Mon, 11/30/2009 - 14:14
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Glad you got it working.


Jon

Jon Marshall Wed, 11/25/2009 - 12:40
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

glen.grant wrote:


  John is  correct because the config register is 0x2101 the boot statement you entered will do absolutely nothing.  0x201 means it will just load the first image it finds in flash which is your old image because it was not deleted .  As john indicates change the register to 0x2102 and reload and it  load the newwer image.


Glen


Think we've known each other long enough on these forums for you to be able to spell my name right


Jon

glen.grant Wed, 11/25/2009 - 17:00
User Badges:
  • Purple, 4500 points or more

Jon what do you mean the original post looks correct ?   :-)

rupam_chakra1983 Wed, 11/25/2009 - 23:33
User Badges:

The problem can be due to this

1. From the "rommon" mode try to change the configregister

you can use the command " confreg"

reset

and then check whether the config register get changed or not.


If once the config register get changed via this your problem will get resolved


Thanks

Rupam

glen.grant Wed, 11/25/2009 - 12:35
User Badges:
  • Purple, 4500 points or more

  Jon is  correct because the config register is 0x2101 the boot statement you entered will do absolutely nothing.  0x201 means it will just load the first image it finds in flash which is your old image because it was not deleted .  As Jon indicates change the register to 0x2102 and reload and it will  load the newwer image.

Actions

This Discussion