RV042 won't load balance

Unanswered Question
Nov 25th, 2009
User Badges:

Good morning everyone,


I've had the RV042 router for some time. I currently have it setup with two internet connections. One from Speakeasy.net and the other from comcast. My problem is that, even though I have "weighted round robin" load balancing turned on, the only connection that ever works for downloading or uploading stuff is the speakeasy connection. The only time the comcast connection turns on is when there's a problem with the speakeasy connection.


I tried configuring it to prefer the comcast connection by setting the maximum download speed at 50Mb/s and the speakeasy max at 15Mb/s and I get nothing. I have it set to load balancing mode and it is not simply set to the fail over mode. Is there a way to get both of my connections working in an alternating fashion? I would like the router to know that if it's downloading movies of a *sensitive type* on the speakeasy connection, to use my comcast connection to continue my work because it has no load on it at the time.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
alissitz Wed, 11/25/2009 - 13:13
User Badges:
  • Silver, 250 points or more

Hello,


It sounds a little like you have this set up for failover, although you mention you have this configured for load balancing.


Do you have any protocol bindings set up?


I would also ask you to please confirm which ports you are using for the primary and secondary.  What version of code are you running?


Kindest regards,


Andrew Lee Lissitz

myronman1 Wed, 11/25/2009 - 14:58
User Badges:

Hey Andrew,


I don't have any port bindings setup. Here are some pictures of my setup. Hopefully I have provided enough information for you to help me out:


system_summary.jpg


setup.jpg


system_management_dual_wan.jpg

alissitz Wed, 11/25/2009 - 19:04
User Badges:
  • Silver, 250 points or more

Hello,


Many thanks for the screen shots and updates.  A couple of thoughts.


The load balancing ought to load balance by sending more out of the one link than the other.


If I understand you correctly, it is not using the second connection except only when the primary is down. It appears you have this configured correctly.


For outgoing traffic I would expect to see some load balancing, although load balancing is not usually a perfect ratio ... but in your case you are not seeing anything.


For incoming traffic, this should depend based on the outgoing address.  For example, if the WAN 1 interface was used, then the packets would be using the NAT'ed address of WAN1 and as such these packets should return via this interface.


Do you have any 1-to-1 NAT configured?  I am wondering if this could skew the results by favoring one outgoing port and not the other. 


Can you please check again to verify that there is in fact no load balancing what-so-ever?  Many thanks in advance for your efforts.


For the failover however, you should probably use the other option which is to 'remove the connection' when down.  The setting you have now will not remove the connection.


As for preferring one interface over another for downloads and the like, you can try protocol bindings.  Example, lets say that your downloads occur on port 80.  If you do not use port 80 for your work, you can bind these to the alternate WAN connection.  Just a thought ... and this might allow you to 'direct' some traffic for recreational and the others for biz.


When using port binding, failover will still work.


I noticed a newer version of code, dated July 30 2009.  This has a different date but appears to be the same version #.  The link to the downloads is here:

http://tools.cisco.com/support/downloads/pub/Redirect.x?mdfid=282413304


Have a good night, Happy Thanksgiving too.


Andrew Lee Lissitz

David Carr Thu, 11/26/2009 - 08:12
User Badges:
  • Silver, 250 points or more

To properly test this, i would setup some protocol binding for some pc's on the network and send all their traffic out the wan that your having issues with and see if they get internet access.  If so then the load balancing is working.  That would be the best way to test this scenario.

Actions

This Discussion