HTTP Status 500 - Internal Server Error

Answered Question
Nov 25th, 2009
User Badges:

When I go to Device Update, ant try to have a look at RME packages, I got this error, only for

RME.

CW LMS 2.6 over W2003.

Correct Answer by Joe Clarke about 7 years 7 months ago

No, that procedure will not work for you.  Your problem is due to corrupt package maps most likely brought on by CSCsj58812.  See the Release-note in the bug for the workaround procedure.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Wed, 11/25/2009 - 10:10
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post the NMSROOT/lib/classpath/com/cisco/nm/xms/psu/conf/tag.properties, NMSROOT/www/classpath/com/cisco/nm/xms/psu/maps/rmePackageMap.map and rmeDeviceMap.map files.

mserranocisco Thu, 11/26/2009 - 00:05
User Badges:

Hi!

here you have...


I've found this procedure, but not tried:

1. Stop CiscoWorks daemon manager: net stop crmdmgtd
2. Go to \CSCOpx\MDC\Apache\conf\SSL and delete all the server.*

files.
3. Go to \CSCOpx\MDC\Apache folder and type: perl configssl.pl

-enable
4. Fill out the form again with all the requested information.
5. If you do not use SSL to access CiscoWorks type: perl configssl.pl -

disable
6. Restart CiscoWorks daemon manager: net start crmdmgtd
7. Wait about 15 minutes or so and login again.

Correct Answer
Joe Clarke Thu, 11/26/2009 - 00:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

No, that procedure will not work for you.  Your problem is due to corrupt package maps most likely brought on by CSCsj58812.  See the Release-note in the bug for the workaround procedure.

mserranocisco Thu, 11/26/2009 - 01:55
User Badges:

C:\Documents and Settings\Administrador>set NMSROOT=%CWMIBDIR%\..\..\..

C:\Documents and Settings\Administrador>%NMSROOT%\lib\jre\bin\java -classpath %N
MSROOT%\lib\jre\lib;%NMSROOT%\lib\classpath;%NMSROOT%\objects\log4j\1.1.3\log4j.
jar;%NMSROOT%\MDC\tomcat\shared\lib\MICE.jar;%NMSROOT%\MDC\tomcat\shared\lib\NAT
IVE.jar;%NMSROOT%\MDC\tomcat\shared\lib\jdom.jar;%NMSROOT%\www\classpath;%NMSROO
T%\lib\classpath\servlet.jar;%NMSROOT%\MDC\tomcat\webapps\cwhp\WEB-INF\classes c
om.cisco.nm.xms.psu.packagemgmt.map.CreateMaps %NMSROOT%\www\classpath\com\cisco
\nm\xms\psu\pkgs\rme
log4j:ERROR No appenders could be found for category (com.cisco.nm.xms.psu.util.
PackageUtils).
log4j:ERROR Please initialize the log4j system properly.

C:\Documents and Settings\Administrador>
C:\Documents and Settings\Administrador>%NMSROOT%\lib\jre\bin\java -classpath %N
MSROOT%\lib\jre\lib;%NMSROOT%\lib\classpath;%NMSROOT%\objects\log4j\1.1.3\log4j.
jar;%NMSROOT%\MDC\tomcat\shared\lib\MICE.jar;%NMSROOT%\MDC\tomcat\shared\lib\NAT
IVE.jar;%NMSROOT%\MDC\tomcat\shared\lib\jdom.jar;%NMSROOT%\www\classpath;%NMSROO
T%\lib\classpath\servlet.jar;%NMSROOT%\MDC\tomcat\webapps\cwhp\WEB-INF\classes c
om.cisco.nm.xms.psu.packagemgmt.map.CreateMaps %NMSROOT%\www\classpath\com\cisco
\nm\xms\psu\pkgs\cvw
log4j:ERROR No appenders could be found for category (com.cisco.nm.xms.psu.util.
PackageUtils).
log4j:ERROR Please initialize the log4j system properly.

mserranocisco Thu, 11/26/2009 - 02:26
User Badges:

I just wanted to add that CV is working fine, we only got the error for RME.

mserranocisco Thu, 11/26/2009 - 02:57
User Badges:

Hi Joe,

after deleting rme file and running command again, it works!

Thanks again.

Actions

This Discussion