VMware View ActiveX download with Clientless VPN

Unanswered Question
Nov 25th, 2009
User Badges:


I am in the procces of setting up a ClientLess VPN to access VmWare VDI Server. In fact it works fine if the end client already has the VMware View Client ActiveX already installed. Smart-tunnel for porcess (wswc.exe) is active.

But if a new client logs to the view portal, the VMware View ActiveX needs to be downloaded, but IE doesnot prompt to Accept and Install the ActiveX.

Anybody solved this issue or can help me with this activeX issue.

ActiveX Relay is enabled.

Thanks. Pascal

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jgibb@ctiusa.com Mon, 11/30/2009 - 14:32
User Badges:

Did you find a resolution to this issue? I am also seeing the same behaviour on an ASA running 8.0.4 and VMWare view client. Thanks.


thomsmith Thu, 01/21/2010 - 11:14
User Badges:

I tried the same thing.  Untimately determined I was running into CSCsx68765, VMWARE webapplications (view/vdm) do not work with smarttunnel.

Has anybody been successful in implementing the workaround?  After establishing the clientless SSL vpn connection and (...auto...) starting the smart tunnel, I launch the VMware View client and get an error message "The View Connection Server authentication failed.  A secure connection to the View connection server can not be established."

fbarnett@mfxroa... Wed, 05/18/2011 - 13:04
User Badges:

Same issue here. We migrated from Aventail to Cisco and this worked with Aventail. Cisco told me I was hitting the bug you mentioned. Our only workaround is to have the users install the client manually.


This Discussion

Related Content