BGP VPNv4 Peer Table

Unanswered Question
Nov 25th, 2009
User Badges:

Hey all,

  Is there a way that the BGP VPNv4 peer table can be monitored like the global BGP table (1.3.6.1.2.1.15)


[[email protected] ~]# snmpwalk -v 2c -c snmpro 192.168.255.129 -m all 1.3.6.1.2.1.15
BGP4-MIB::bgpVersion.0 = Hex-STRING: 10
BGP4-MIB::bgpLocalAs.0 = INTEGER: 64750
BGP4-MIB::bgpPeerIdentifier.192.168.255.130 = IpAddress: 192.168.255.130
BGP4-MIB::bgpPeerIdentifier.192.168.255.131 = IpAddress: 192.168.255.131
BGP4-MIB::bgpPeerIdentifier.192.168.255.132 = IpAddress: 192.168.255.132
BGP4-MIB::bgpPeerState.192.168.255.130 = INTEGER: established(6)
BGP4-MIB::bgpPeerState.192.168.255.131 = INTEGER: established(6)
BGP4-MIB::bgpPeerState.192.168.255.132 = INTEGER: established(6)


ROUTER#show ip bgp vpnv4 all summary

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.98.128.222   4 64774      75      77        8    0    0 00:08:08        1
192.168.255.130 4 64750     145     142        8    0    0 02:15:47        0
192.168.255.131 4 64750     139     142        8    0    0 02:15:50        0
192.168.255.132 4 64750     139     142        8    0    0 02:15:43        0


Notice that the 10.98.128.222 peering is not in the global BGP table that SNMP reads?


The closest that I can get is to put a threshold on the amount of prefix recieved via a peering:

CISCO-BGP4-MIB::cbgpPeerAcceptedPrefixes.10.98.128.222.ipv4.vpn = Counter32: 1


CISCO-BGP4-MIB has no table contructs that resemble the ones in BGP4-MIB


Cheers


Adam Clark

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 11/25/2009 - 22:10
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post the show run and show ver from this device.

clark.adam.p Wed, 11/25/2009 - 23:00
User Badges:

Here you go


ROUTER#show running-config
Building configuration...


*Mar  1 06:04:07.590: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 6042 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ROUTER
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf TP_CORE
rd 64750:400
route-target export 64750:400
route-target import 64750:400
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
  hidekeys
!        
!
!
!
!
!
!
interface Loopback0
ip address 192.168.255.130 255.255.255.255
ip ospf 1 area 0
!
interface Loopback100
no ip address
!
interface FastEthernet0/0
ip address 192.168.255.3 255.255.255.248
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding TP_CORE
ip address 10.98.128.225 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
!
router bgp 64750
no synchronization
bgp log-neighbor-changes
neighbor VPNv4PG peer-group
neighbor VPNv4PG remote-as 64750
neighbor VPNv4PG update-source Loopback0
neighbor VPNv4PG send-community both
neighbor 192.168.255.129 peer-group VPNv4PG
neighbor 192.168.255.131 peer-group VPNv4PG
neighbor 192.168.255.132 peer-group VPNv4PG
no auto-summary
!
address-family vpnv4
  neighbor VPNv4PG send-community extended
  neighbor VPNv4PG next-hop-self
  neighbor 192.168.255.129 activate
  neighbor 192.168.255.131 activate
  neighbor 192.168.255.132 activate
exit-address-family
!
address-family ipv4 vrf TP_CORE
  neighbor TPPG peer-group
  neighbor TPPG remote-as 64774
  neighbor TPPG send-community both
  neighbor TPPG route-map BGP-VRF-Peers in
  neighbor TPPG route-map TP_CORE_PEER_SECONDARY out
  neighbor 10.98.128.226 peer-group TPPG
  neighbor 10.98.128.226 activate
  no synchronization
exit-address-family
!
ip forward-protocol nd
!
ip bgp-community new-format
ip community-list standard AS64750-Local-Pref-300 permit 64750:30
ip community-list standard AS64750-Local-Pref-400 permit 64750:40
ip community-list standard AS64750-Local-Pref-500 permit 64750:50
ip community-list standard AS64750-Local-Pref-200 permit 64750:20
!
ip http server
no ip http secure-server
!
ip access-list standard snmp-access
!
snmp-server community snmpro RO snmp-access
snmp-server trap-source Loopback0
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps vrrp
snmp-server enable traps ds1
snmp-server enable traps tty
snmp-server enable traps eigrp
snmp-server enable traps xgcp
snmp-server enable traps flash insertion removal
snmp-server enable traps ds3
snmp-server enable traps envmon
snmp-server enable traps icsudsu
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server enable traps ds0-busyout
snmp-server enable traps ds1-loopback
snmp-server enable traps atm subif
snmp-server enable traps bgp
snmp-server enable traps bulkstat collection transfer
snmp-server enable traps cnpd
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps dial
snmp-server enable traps dsp card-status
snmp-server enable traps entity
snmp-server enable traps event-manager
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps hsrp
snmp-server enable traps ipmobile
snmp-server enable traps ipmulticast
snmp-server enable traps mpls ldp
snmp-server enable traps mpls traffic-eng
snmp-server enable traps mpls vpn
snmp-server enable traps msdp
snmp-server enable traps mvpn
snmp-server enable traps ospf state-change
snmp-server enable traps ospf errors
snmp-server enable traps ospf retransmit
snmp-server enable traps ospf lsa
snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
snmp-server enable traps ospf cisco-specific state-change shamlink interface-old
snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
snmp-server enable traps ospf cisco-specific errors
snmp-server enable traps ospf cisco-specific retransmit
snmp-server enable traps ospf cisco-specific lsa
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
snmp-server enable traps pppoe
snmp-server enable traps cpu threshold
snmp-server enable traps rsvp
snmp-server enable traps rtr
snmp-server enable traps syslog
snmp-server enable traps l2tun session
snmp-server enable traps vsimaster
snmp-server enable traps vtp
snmp-server enable traps isakmp policy add
snmp-server enable traps isakmp policy delete
snmp-server enable traps isakmp tunnel start
snmp-server enable traps isakmp tunnel stop
snmp-server enable traps ipsec cryptomap add
snmp-server enable traps ipsec cryptomap delete
snmp-server enable traps ipsec cryptomap attach
snmp-server enable traps ipsec cryptomap detach
snmp-server enable traps ipsec tunnel start
snmp-server enable traps ipsec tunnel stop
snmp-server enable traps ipsec too-many-sas
snmp-server enable traps rf
snmp-server enable traps voice poor-qov
snmp-server enable traps voice fallback
snmp-server enable traps dnis
snmp-server host 10.17.10.20 snmpro
!
route-map TP_CORE_PEER_SECONDARY permit 10
set metric 200
!
route-map BGP-VRF-Peers permit 10
match community AS64750-Local-Pref-200
continue
set local-preference 200
!
route-map BGP-VRF-Peers permit 20
match community AS64750-Local-Pref-300
continue
set local-preference 300
!
route-map BGP-VRF-Peers permit 30
match community AS64750-Local-Pref-400
continue
set local-preference 400
!
route-map BGP-VRF-Peers permit 40
match community AS64750-Local-Pref-500
continue
set local-preference 500
!
route-map BGP-VRF-Peers permit 65535
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!        
!
end


ROUTER#show version
Cisco IOS Software, 3700 Software (C3725-ADVIPSERVICESK9-M), Version 12.4(23), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Sun 09-Nov-08 01:12 by prod_rel_team


ROM: ROMMON Emulation Microcode
ROM: 3700 Software (C3725-ADVIPSERVICESK9-M), Version 12.4(23), RELEASE SOFTWARE (fc1)


ANZDCMWPER2 uptime is 6 hours, 4 minutes
System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19
System image file is "tftp://255.255.255.255/unknown"



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to
[email protected].


Cisco 3725 (R7000) processor (revision 0.1) with 249856K/12288K bytes of memory.
Processor board ID XXXXXXXXXXX
R7000 CPU at 240MHz, Implementation 39, Rev 2.1, 256KB L2, 512KB L3 Cache
4 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity enabled.
55K bytes of NVRAM.


Configuration register is 0x2102

Joe Clarke Thu, 11/26/2009 - 00:10
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You need an image with the fix for CSCso90107.  The fix for this bug implemented BGP VPNv4 peer support in the BGP4-MIB and CISCO-BGP4-MIB.  To get such an image, you would need to move to 12.4(15)T9 or higher for your platform.

Actions

This Discussion