IPSec VPN Client -> ASA -> Win2K3 DHCP Server connectivity issues

Unanswered Question
Nov 26th, 2009

I've currently got a remote access VPN configured on my ASA that is set give clients an IP address from the internal DHCP server on the inside interface of the ASA. The clients authenticate and get an IP but are unable to connect to any devices on the internal network, even with ping.

I'm running ASA5505 on v8.2(1). There are no other (layer 3) devices between the ASA and the DHCP server. The DHCP server is on the corporate LAN. There is a working VPN config (called RA-VPN) that works with using an IP Address Pool on the ASA. The RA-VPN-temp config is to use the DHCP server. The config is sanitised, but here it is:

:
ASA Version 8.2(1)
!
hostname FW
domain-name site.company.local
enable password * encrypted
passwd * encrypted
names
name 1.2.3.4 host_External
name 10.10.10.0 net_LAN
name 10.10.10.7 srv_DHCP
name 172.16.10.0 net_COMPANY-VPN-Clients
name 10.10.0.0 net_WAN
!
interface Vlan1
nameif inside
security-level 100
ip address 10.10.10.20 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address host_External 255.255.255.248
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa821-k8.bin
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
domain-name site.company.local
same-security-traffic permit intra-interface
access-list RA-VPN_splitTunnelACL standard permit net_WAN 255.255.0.0
access-list ACL_NoNAT extended permit ip any net_COMPANY-VPN-Clients 255.255.255.0
access-list inside_access_in extended permit ip net_LAN 255.255.255.0 any
pager lines 24
logging enable
logging buffer-size 51200
logging asdm-buffer-size 512
logging console debugging
logging buffered debugging
logging trap debugging
logging asdm debugging
mtu inside 1500
mtu outside 1500
mtu management 1500
ip local pool VPNUSERS 172.16.10.1-172.16.10.254 mask 255.255.255.0
ip verify reverse-path interface inside
ip verify reverse-path interface outside
ip verify reverse-path interface management
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list ACL_NoNAT
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 84.12.4.241 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http server idle-timeout 15
http 0.0.0.0 0.0.0.0 management
http 0.0.0.0 0.0.0.0 inside
http 0.0.0.0 0.0.0.0 outside
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 5
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 10
authentication pre-share
encryption des
hash sha
group 2
lifetime 86400
crypto isakmp policy 15
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 15
console timeout 15
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection scanning-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol IPSec webvpn
group-policy GrpPolVPN internal
group-policy GrpPolVPN attributes
dns-server value 10.10.10.7 10.10.10.25
vpn-idle-timeout 1800
split-tunnel-policy tunnelspecified
split-tunnel-network-list value RA-VPN_splitTunnelACL
default-domain value site.company.local
split-dns value site.company.local
username Admin password * encrypted privilege 15
tunnel-group RA-VPN type remote-access
tunnel-group RA-VPN general-attributes
address-pool VPNUSERS
default-group-policy GrpPolVPN
tunnel-group RA-VPN ipsec-attributes
pre-shared-key *
isakmp ikev1-user-authentication none
tunnel-group RA-VPN-temp type remote-access
tunnel-group RA-VPN-temp general-attributes
default-group-policy GrpPolVPN
dhcp-server srv_DHCP
tunnel-group RA-VPN-temp ipsec-attributes
pre-shared-key *
isakmp ikev1-user-authentication none
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:84e2bc6c9b48765bf01c883379f6445b
: end

Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion

Related Content