Req. overlap ip with fastether 1/0/22 with bgp routing.

Answered Question
Nov 26th, 2009

Dear Experts,

At present we have cisco 3750 switch, in this switch we are conigured BGP routing and bgp are established with our ISP, but problem is our ip 180.130.220.0/22 (255.255.252.0). when i assigned in fastEthernet 1/0/22 ip address 180.130.220.1 255.255.255.252 then i am not able to ping my wan ip

from router and also not able to ping from outside to this ip but when i configured in this fastethernet 1/0/22 180.130.220.1 255.255.252.0 then after i am able to ping from outside and also i am able to ping to my WAN ip from router. when  only 255.255.252.0 subnet assigned after only  i am able to ping my WAN otherwise never ping with other subnet.

when i configred subnet in this fastEthernet 255.255.255.252 / 255.255.255.0 / 255.255.255.192 i am not able to ping my neighbor WAN  only this Subnet when i configuied all ip 255.255.252.0 then after i am able to ping so that's why i am not able to assign in this series IP to other interface if assign it is overlap with fas1/0/22.

so pl give me solution, how can i solve this issue.

Thanks in ADV,

Vaib...

I have this problem too.
0 votes
Correct Answer by Nagendra Kumar ... about 7 years 1 week ago

Hi Vaib,

Am I right assuming that you need to divide 180.130.220.0/22 into multiple small subnet and make them reachable from external world?.

If so, you can divide the same based on your requirement. Configure the network comand under BGP in a way that it matches the subnet mask correctly as below,

Interface

ip address 180.130.220.1 255.255.255.252

router bgp

network 180.130.220.0 mask 255.255.255.252

Now, aggregate the network and advertise the same outside to your ISP through BGP as below,

router bgp

aggregate-address 180.130.220.0 255.255.252.0 summary-only

This will advertise only 180.130.220.0/22 outside.

To verify the same,

First make sure you can see the prefix in your own BGP table using the below command,

show ip bgp 180.130.220.0

If the above doesnt work, Please post the config.

HTH,

Nagendra

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Reza Sharifi Thu, 11/26/2009 - 07:57

When you configure /30 like above, did you configure both sides of the connection?

180.130.220.1 255.255.255.252 router-A

180.130.220.2 255.255.255.252 router-B

HTH

Reza

csawest.dc Thu, 11/26/2009 - 08:13

Dear Reza,

These all ip 180.130.220.1/22 my own ip not provide from my ISP i purchased from APNIC .

only add in my network in bgp rouging and their (my ISP router this ip in their bgp routing)

my bgp routing templates in my 3750 switch not router.

router bgp 45321

no syncronization

bgp-log neighbor changes

network 180.130.220.0 255.255.252.0

neighbor 220.225.68.151 remote-as 10101

neighbor 220.225.68.151 update-source fastEthenet 1/0/21

neighbor 220.225.68.151 next-hop-self

redistribute static

redistribute conected

no auto-sumary

then when i configured in fastEthernet 1/0/22 interface ip address 180.130.220.1 255.255.255.252 / or 255.255.255.0 / or 255.255.255.192 subnet i am not able to ping my neighbor WAN and also from outside to this ip but when i configure subnet 255.255.252.0 then i am able to ping my neighbor WAN and also from outside this ip. otherwise never.

so pl give me solution.

HOW CAN I CONFIGURED IP OTHER INTEFACE CAUSE THAT TIME IS OVERLAP WITH THIS FAS1/0/22.

Thanks in  ADV,

Vaib...

Giuseppe Larosa Thu, 11/26/2009 - 08:00

Hello Vaibhav,

these are public ip addresses so first of all caution because using a broader mask you may be taking IP addresses of somebody else!

then,

if you need to have the same IP subnet in two ports you should:

place the IP address on a logical interface for example Vlan10

you should configure the two ports as L2 ports in vlan 10

int type x/y

switchport

switchport mode access

switchport access vlan 10

!

if you want to use a different IP subnet you may need to subnet your public address block

Hope to help

Giuseppe

Nagendra Kumar ... Thu, 11/26/2009 - 08:05

Hi,

Can you let us know how you have configured the prefix under BGP?.

I hope, you have configured it as below,

router bgp

network 180.130.220.0 mask 255.255.252.0

If you have it as above, bgp will advertise to othet neighbors only if the subnet and mask matches exactly. This tells you why you were able to ping when you have assigned fastEthernet 1/0/22 with ip address as 180.130.220.1 255.255.252.0

When you configure f1/0/22 with "ip address 180.130.220.1 255.255.255.252", you need to modify the same under BGP as "network 180.130.220.0 mask 255.255.255.252".

Let us know if the above doesnt solve your issue.

HTH,

Nagendra

csawest.dc Thu, 11/26/2009 - 08:19

dear nagendra,

but i need to use all ip's in my network but when i configured in bgp network 180.130.220.0 255.255.255.252 it is use only two or can i able to use all 180.130.220.0/22 all ip in my network ??? after configured in bgp  ( network 180.130.220.0 255.255.255.252) ????

NOW I HAVE CONFIGURED IN BGP NETWORK 180.130.220.1 MASK 255.255.255.252 AND THEN CONFIGURED ON INTERFACE IP ADRESS 180.130.220.1 255.255.255.252 THEN I AM NOT ABLE TO PING THIS IP FROM OUTSIDE.

help me pl

Regards,

Vaib...

Correct Answer
Nagendra Kumar ... Thu, 11/26/2009 - 09:19

Hi Vaib,

Am I right assuming that you need to divide 180.130.220.0/22 into multiple small subnet and make them reachable from external world?.

If so, you can divide the same based on your requirement. Configure the network comand under BGP in a way that it matches the subnet mask correctly as below,

Interface

ip address 180.130.220.1 255.255.255.252

router bgp

network 180.130.220.0 mask 255.255.255.252

Now, aggregate the network and advertise the same outside to your ISP through BGP as below,

router bgp

aggregate-address 180.130.220.0 255.255.252.0 summary-only

This will advertise only 180.130.220.0/22 outside.

To verify the same,

First make sure you can see the prefix in your own BGP table using the below command,

show ip bgp 180.130.220.0

If the above doesnt work, Please post the config.

HTH,

Nagendra

csawest.dc Fri, 11/27/2009 - 07:02

Dear Nagendra,

Thank you very much and thanks for gr8 support to solved my issue.

when i configured aggregate-address 180.130.220.0 mask 255.255.252.0 summery-only in bgp , network 180.130.220.0 mask 255.255.255.252  and configure on loopback 1 ip address 180.130.220.1 255.255.255.252 then i am able to ping my loopback 1 ip.

THANKS TO ALL EXPERTS TO HELP ME AND GIVE ME GREAT SUPPORT.

CHEERS!!!

Vaib...

Actions

This Discussion