Cisco blade switch 3120 connecting to 3750 link not coming up.

Unanswered Question
Nov 26th, 2009

Hi Experts,

I have a issue that when I forced the duplex settings to 100/full the link goes down. No leds on the ports.

Were as the link works fine with Auto mode.


1)  Cisco 3120-Speed 100 duplex full----cross over cable---3750- Speed 100 duplex full the ports goes down.

2)  Cisco 3120-Speed 100 duplex full----Straight Cable------3750- Speed 100 duplex full  the ports goes down.

3) Cisco 3120-Speed Auto duplex auto----cross over cable---3750- Speed auto duplex auto  the ports comes up everything works fine..

We have tried disabling auto MDX feature as well but no luck.  Can any one help me with any other idea???? Or is it a bug ???

Software versions:

3750   IOS Version 12.2(25)SEE3

3120 IOS Version 12.2(50)SE3

Any help would be greatly appricaited.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Reza Sharifi Thu, 11/26/2009 - 10:03

Hi Sum,

Is you blade switch 3120G for HP blade center? If yes that device comes with 4 10/100/1000 copper ports and 4 Gig SFPs.

Can you provide more info?


Leo Laohoo Thu, 11/26/2009 - 13:36

It doesn't matter whether you use straight-through or cross-over cable because both 3120 blade and 3750 are MDI/MDIX capable.  Ensure "no mdix auto" is not in the configuration somewhere.

One thing that interest me is the IOS version of the 3750, 12.2(25)SEE3.  It's fairly an old IOS.  Do you consider upgrading the 3750 to 12.2(46)?  I have 3020 in my network and they are running the same IOS as you but they are all connected to networks running the 12.2(46) IOS.  Speed and Duplex settings are all auto-negotiate.

sumaiyausa Fri, 11/27/2009 - 06:18


As I told earlier it was fine with the auto mode both ends. I want to manually configure Speed to 100 and duplex to FULL which is not working and facing the issue.

1) Checked the auto mdx is enabled by default tried disabling at one end and enabling at both the ends but no luck.

Are we hitting any bug on this????

Thanks in advance.

glen.grant Fri, 11/27/2009 - 07:03

On both connecting interfaces you must have " no mdix-auto" on the interfaces if you hardcode .   Also if you don't use auto mdix you must use a crossover cable you cannot use a straight thru .  It's not a bug , working as designed.   Auto mdix  for using  either a straight or xover cable can only have the interfaces set as auto otherwise it will bring down the interface as you have seen .  Your other option is to use mdix auto  on both  interfaces and set the speed as "auto 100" and it will negotiate 100/full on its own .

gnijs Sat, 11/28/2009 - 12:52

The tricky part of auto-MDIX is that is gets disabled automatically from the moment you configure fixed speed or duplex.

Sometimes your link is up, and it is running at a-100 a-FD. You try to configure the interface as fixed and loose connection. This means you were using a 'wrong' cable, but auto-mdix fixed it for you. From the moment you configure a speed or duplex fixed, auto-mdix gets disabled and interface goes down.

However, i see that you have tried to fix speed and duplex on both sides and using a cross cable, it should work (your bullet [1]). Try changing your crossed cable by another one in this situation.

abmehta Sat, 11/28/2009 - 13:06

Adding to the above more in specifics,

"3750 switches have a feature called automatic medium-dependent interfacecrossover (Auto-MDIX) which is enabled by default. With MDIX enabled - the
interface automatically detects the required cable connection type (straight through or crossover) and configures the connection appropriately. Without
MDIX - you should only use the right kind of cable i.e. cross-over or straight thru but with Auto-MDIX enabled, you can use either type of cable
to connect to other devices, and the interface automatically corrects for any incorrect cabling."

Could you try a cross-over cable between the switches & see if that works when you hardcode the settings to 100/full on both ends?


This Discussion