Aironet access-point 1231G reboots itself frequently...

Unanswered Question

Hi there,

We have one 1231G access-point which reboots itself after every certain time, its uptime has never crossed some 30 - 35 mins, usually it remains to 10 -15 mins. Some days ago, I saw a similar problem being discussed on thsi plateform but after the NetPro being changed, I could not find the progress on that thread. The guys in that thread suggested to physically separate the wireless controllers and then re-attach it back. Instead of doing this I tried physical reboot/power-cycle of thsi access-point. That access-point behaved normally for some days but after some that it aain posed the same problem. Kindly help me with probable solutions to it.

Thanks and regards,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Leo Laohoo Thu, 11/26/2009 - 13:38

Can you provide more information?

What firmware is your WLC running?
Can you find any information in the crash boot section of the WLC?
How many 1230s are in your network and how many are showing this symptom?
How is the AP powered, power brick or PoE?

Scott Fella Sun, 11/29/2009 - 09:22


After the AP reboots, console into the AP and run a show stacks in the EXEC mode.  This should tell you the reason for the reboot or system crash.  Then if you see a problem, you can open a TAC case or lookup the error.


Hi Scott,

The show stack command shows like:

Minimum process stacks:
Free/Size   Name
4572/5500   soap_flash init
3084/5500   Soap Flash Save Variables
5116/5500   Clock Update Proc
5240/5500   dot11 platform init
10364/11000  Soap Upgrade fetch Config File
8696/12000  Init
32276/33000  TCP Command

Interrupt level stacks:
Level    Called Unused/Size  Name
  4         594   8296/9000  dot11 radio interrupt
  6         253   8960/9000  NS16550 VECTOR

This looks good to me, although let me know your thoughts on it.

One thing I have observed that the it showed a high CPU spike when it reboots and stops responding on the network. sho proc cpu his command, just after the reboot shows a spike of between 85 to 100% CPU utilisation. Any thoughts!


Scott Fella Mon, 11/30/2009 - 06:52

That looks fine.  Did you upgrade the access points when this started happening?

dennischolmes Mon, 11/30/2009 - 08:06

I have a very strong suspicion this is caused by power. Are you using a PoE brick or a power

ed switch? If it is the brick then I suspect it is dying of old age. If it is a switch make sure it is putting out the proper amount of power. CDP will sometimes cause an issue similar to this where Cisco pre-standard power is offered instead of 802.3af.

Leo Laohoo Mon, 11/30/2009 - 14:03

Do you have the command "power inline negotiation injector " in your AP?
What model of the switch do you have?
Enable CDP on both the AP and the interface of the switch.

Leo Laohoo Tue, 12/01/2009 - 13:22

If you you don't get any result from the "sh cdp neighbor" then CDP is disabled somewhere;

In your AP, type the command "power inline neg injector iinstalled".  You'll get a response of "A power-injector must be installed on port: ()(MAC=)".

Copy the MAC address and type the command "power inline negotiation injector ".  See if this works.

If you are dealing with a 2900/3500XL, 2950/3550 or 2970, this command is necessary.

Hope this helps.

Peter Nugent Tue, 12/01/2009 - 14:52

I had an issue recently with an 1131, the access point powered on ok but would not enable the radios.

It turned out to be that CDP in the 2950 can cause the ap to think it has no power, I disbled CDP on the port the ap it connected to and all was well, it may be worth a try!


CDP is enabled and I can see the neighboring cisco switch in sho cdp ne command. I have tried disabling CDP as well, that did not work. The access-point still shows uptime in minutes in sho ver. When I tried putting the power inline .... command, teh access-point did not accept it at all. It did not give any option even with 'power' word in config mode. It did not support this comamnd at all.

There is one more access-point connetced to thsi switch at another port and that access-point is working like a charm, though the access-point's model is same. The IOs version was same for both teh access-points previosuly until we changed the IOS in the bad AP (with no luck).

Thanks for your replies..


This Discussion

Related Content