Presenting CallerID for Incoming Calls

Unanswered Question
Nov 27th, 2009
User Badges:

How do I enable caller id presentation on inbound calls. I am using a H.323 gateway connected via E1 card to a PSTN network. All incoming calls currently show "Unknown Number" for all calls.

Is this configured on the voice-port.

Any help would be greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bigcappa1 Fri, 11/27/2009 - 02:05
User Badges:
  • Silver, 250 points or more

Peter,

The most likely cause is that you a recieving the caller ID but the callmanager does not know how to present it so will display it as an Unknown number

As you have an H323 gateway  you have two options, you can either apply this on the Callmanager or on the gateway using a translation rule.

Assuming you also wish to prefix a 9 so that the user can call back then you can use a simple translations to do the job. You have two options I prefer the second but its personal choice


The second option is dependant on the country dial pattern. This is based on the uk where local calls had 6 digits (some areas have 7) and then 10, 11 and 12 digits for national and international etc


Option 1 is more straightforward
voice translation-rule 1
rule 1 /^0./ /90/
rule 2 /^1/ /901/
rule 3 /^2/ /902/
rule 4 /^3/ /903/
rule 5 /^4/ /904/
rule 6 /^5/ /905/
rule 7 /^6/ /906/
rule 8 /^7/ /907/
rule 9 /^8/ /908/
rule 10 /^9/ /909/
rule 11 /^00/ /900/


Option 2 is a little more complex


voice translation-rule 1
rule 1 /\(^......$\)/ /9\1/
rule 2 /\(^..........$\)/ /9\1/
rule 3 /\(^...........$\)/ /9\1/
rule 4 /\(^............$\)/ /9\1/



They are both added in the same way


voice translation-profile Prefix_9
translate calling 1


voice-port 0/0/0:15
translation-profile incoming 1


You could also apply to the incoming dial-peers


or you could apply the incoming on the callmanager in the Service Paramterers got to /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}


Clusterwide Paramters (Device – Phone)

Nation number prefix              90

International number prefix    900


Finally double check that you are actually getting caller ID coming in, normall logging will help but run either a debug isdn q931 or a debug voice ccapi inout. If Caller ID is enabled then you should see the incmoing number usually missing the leading zero, this may be the reason CM cant recognise it

Hope this helps


Thanks

Paul

Actions

This Discussion

Related Content