SPA500S Expansion Module, ready?

Unanswered Question
Nov 27th, 2009

I see that CCA 2.2 says it supports the SPA500S, but it's not seeing them. Was CCA ready before software, or do I need to download and install phone loads from somewhere? Is the IOS on the UC540 ready for SPA500S or will there be an update soon?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven DiStefano Sat, 11/28/2009 - 01:47

CCA 2.2 is ready to provision SPA500S sidecars, yes.  You do need to take the 8.0.0 bundle zip to get the UC540 code and phone loads, correct.

This code was posted in the last few days.

relionllc Sat, 11/28/2009 - 09:48

Thanks, Steve. I'm still a bit lost though. I checked here and cisco.com and can't find a 8.0.0 bundle. I have the 7.1.3 that posted almost 2 weeks ago, but that's the same IOS and appears to be all the same loads etc. that are loaded now. CCA 2.2 is loaded up but I still see no sidecars in there. Where exactly do I find the 8.0?

relionllc Tue, 12/29/2009 - 10:05

Thanks,all. That pack installed and sidecars worked fine. New problem, this system is using Global Crossing and they apparently have a problem with their Sonus hardware where it won't accept DTMF tones from the UC500 with that new 15.0(1) code. They recommended rolling back to previous code, so I did- back to the factory 12.4(24)SB and now the DTMF and everything else seems to be working fine, but the sidecars won't work anymore. I was told the sidecar functionality wouldn't be lost as it was a phone load, not the IOS. Obviously that was wrong. So, is there a way to get SPA500S to work with the 12.4, or is there another IOS that does support the sidecars but also works with Sonus? I'm opening a case with S-TAC in a few minutes to see if they can help, but it was S-TAC that said the previous IOS would work, too. Thanks.

Steven DiStefano Wed, 12/30/2009 - 06:07

Sorry for the delayed response.  Most of Cisco is closed till after the New Year (mee too).

I have some thoughts on this that maybe can help though and you can run this by S-TAC.

CME 8.0  comes bundled with IOS 15.0.1(XA).

In CME 8.0 you will fiind the following phones supported.

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6788/vcallcon/ps4625/data_sheet_c78-567246.html

However, there are 2 things to understand here:

- SPA500 series phones are for Small Business only as they run SCPC (a tokenized version of SCCP) so they dont appear in the list as they cannot be used in CME on ISRs or BE, so they dont appear inside the CME bundle.  This is why we dont use that alone.

-The SPA500 phones are supported by CCA 2.2.x and how that works is the phone loads are bundled in the version 8.0 UC500 Bundle ZIP file.

https://www.myciscocommunity.com/docs/DOC-10361

So if running the new UC500 bundle, you will get support for them, because we added the phone loads to our bundle for UC500

https://upload.cisco.com/cgi-bin/swc/fileexg/main.cgi?CONTYPES=UC500.

So what you are facing is running a previous version (7.0.x) of CME and getting support for these SPA500 phones and sidecars.

I think you only need the phone loads.

When we released  CCA 2.2, we realized that we could not assign more than Monitor buttons on the 500S.  We fixed this in CCA 2.2.1:

www.cisco.com/go/configassist

CCA 2.2.1 also brings the capability to 'drag and drop' a phone load file for the SPA500 series phones from your PC desktop to the UC500 icon in the topology view, and it should execute the 'create cnf' build the telephony service commands, the load statements, the TFTP statements, put the phone loads in the correct place in flash, etc.... (an otherwise complex ordeal).    I just tried it and it works on my home system.   I opened the 8.0.0 bundle zip, and inside it is a phone loads tar ball.   Opened that and inside that were two files (one for SPA5x5 phones and one for SPA525G phones).

SO I think CCA 2.1.1 will support the installation of these phone loads for the earlier release, since CME doenst prevent it, and CCA supports it.

Can you give this a try and let us know how you make out?

Steve DiStefano

Systems Engineer

U.S. Field Channel Sales Team

relionllc Wed, 12/30/2009 - 08:48

Thanks, Steve. If I'm following what you're saying, then that's what we originally had in mind. 8.0 was installed, phone loads and all, with everything working. When I rolled back the IOS, I didn't use CCA, just plain TFTP and a reload. That would retain all the settings, phone loads, flash, etc. The SPA508s still work afterward, it's just the support for the sidecar vanished. Specifically, the router doesn't know what to do with the "type 508G addon 1 500S" line under the ephone so it removes it, the "addon" option is completely unavailable. In fact, because of that, when the system came back up, the phones with addons wouldn't come up until I added the "type 508G" line again.

I did go into CCA just in case to see if I could re-add the phone loads again, and it said everything was already there and there's nothing for it to do.

Did I follow you right?

-Danny

Steven DiStefano Wed, 12/30/2009 - 10:49

Hi Danny,

Yes, you and I are thinking the same.    I didnt think of the Addon command though.   That would have to be supported in the IOS CLI to accept it as a parameter value, so perhaps what we are discussing is only true for the Phones themselves, and not the sidecars.

You may be stuck until you can go forward to the supporting IOS.

I understand that 15.0(1)XA1 was coming soon.  Perhaps that will solve the DTMF issue and allow you to move ahead with the sidecars.

Steve

Actions

This Discussion