CUCM Send "+" Calling ID to H323 VG

Unanswered Question
Nov 28th, 2009

Hi All

  My cucm version is 7.0.1, and i have a H.323 VG IOS is 12.4(20T). In lab environment, my ipphone Ext is 6601 and phone number mask is +867558207XXXX.

  I create a route pattern 9.0! use for international call, check use calling party External phone number mask in this pattern.

  make a phone call hit that 9.0! pattern, offnet from the H.323 VG, dail No. is 90044XXXXXXXXXX, like UK number. expectation the UK phone will display

  incoming number is +8675582076601, but is display 8675582076601, lost the "+".

  If i wanna to display the incoming number expectant, i must use voice translation rule to match 867558207.... and change to +867558207....

  cause debug cch323 h225 just see the calling number is 8675582076601:

  Nov 28 07:31:26.372: //29/00B699C50500/H323/setup_ind: callingNumber[8675582076601] calledNumber[900441802226702]

  I change the VG type to MGCP, same pattern, same number mask, destination phone UK display +86..........

  Just don't know why H.323 VG no receive the "+", maybe some parameter is not set.

  ask for help with that case, i don't wanna use the translation profile to do that, i think is normal function, Thx for help.

                              Rock from China.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paul Reck Sun, 11/29/2009 - 22:54

Hi there,

On a H323 gateway it's expected behaviour, you can used a voice translation profile/rule to apply the following to a called number

voice translation-rule 1
rule 1 // /+86/ type national national
rule 2 // /+/ type international international


check the Incoming Calling Party Settings on your H323 gateway configuration on CUCM and apply the prefix.

Incoming Calling Party National Number Prefix 
Incoming Calling Party International Number Prefix


rock981119 Wed, 12/02/2009 - 03:32

Thx Paul, in this time i use the voice translation rule to handle that issue. but i think H.323 gateway should suppurt calling number include

"+", don't wanna use translation..

tomaszpawlus Sun, 11/28/2010 - 19:07


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-fareast-language:EN-US;}

This is an expected behaviour of H.323 trunk which doesn’t carry "+" sign as opposed to MGCP...




This Discussion

Related Content