CME 8.0 (15.0(1)XA) vs SIP trunk DTMF issues

Unanswered Question
Nov 28th, 2009

Hello,

I've upgraded my 2821 to 15.0(1)XA to try out CME 8.0. I have a SIP trunk coming in from an ITSP and everything works fine using 12.4(22)YB4. When I upgrade to 15.0(1)XA, DTMF stops working on 90% of my calls (I am forcing RTP-NTE). I have not changed the config between 12.4(22)YB4 and 15.0(1)XA at all.

Tech support tells me that they are receiving RFC2833 packets but they're too short - according to them, the 3 first packets have 0ms duration, the middle packet has 400ms duration and the last 3 have 800ms. They have suggested that I send inband DTMF instead, but I am not really inclined to do that because it worked before. I've tried specifying the payload setting (101) and other settings on my dial-peers to no avail. I have been forced to return to CME 7.1 because of this.

All my phones are SCCP and this problem is reproduced on a broad range of phones including analog phones off a EVM board (SCCP-controlled).

Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Nicholas Matthews Sat, 11/28/2009 - 13:34

You may want to try this command:

voice service voip

dtmf-interworking rtp-nte

It changes the interarrival properties of the 2833 packets, and we see it particularly with Verizon trunks, though it has been useful in other scenarios as well.

-nick

J. S. Black Sat, 12/12/2009 - 19:50

Hi Nick,

I just tested dtmf-interworking with 15.0(1)XA, no change.

Any debugs I should be looking at?

Paolo Bevilacqua Sat, 11/28/2009 - 23:47

The rigth approach would be to have cisco fix what is broken, unfortunately the burden of proof is on you and it can take a lot of time and effort.


The alternative is to go back to working IOS and upgrade when new software is less buggy.

Nicholas Matthews Mon, 12/14/2009 - 06:33

I would start by getting a packet capture.  Then, you can look if you receive the packets.  Something like 'rtp.payload_type == 101' may be a good wireshark filter.

For debugs, you're looking at using 'debug ccsip messages' and 'debug voip rtp session named'.

You're probably best off opening a tac case with this information because it sounds like something that isn't as straightforward.  Double check your dial peers - maybe they were read in differently with the new IOS and haven't been applied the same in the two versions.

-nick

Actions

Login or Register to take actions

This Discussion

Posted November 28, 2009 at 5:50 AM
Stats:
Replies:4 Avg. Rating:
Views:528 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,031
2 15,047
3 10,323
4 8,014
5 4,856
Rank Username Points
126
105
98
57
56