voip call disconnect when remote end picking the call

Unanswered Question
Nov 29th, 2009
User Badges:

hai all


my connection is like EPBX ------ R1 ______________ R2 ------EPBX

Connection

epbx ro R1/R2(2811) is an t1/e1

R1 to R2  a leased line



Problem: when we are trying to call from phone connected @ PBX A to PBX B get ring , when we picks the phone the call goes disconnected ....


please help me to resolve this issue.... please find the router configuration bleow and debug isdn as attached



Router Configuration


sh runn

hostname XXX
!

card type e1 0 0
card type e1 0 1

!
no aaa new-model
no network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/1/0
!
ip source-route
!
!

!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-qsig
!
voice service pots
supplementary-service qsig call-forward
!
voice service voip
qsig decode
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3

voice register global
!
voice-card 0
!
!
crypto pki trustpoint TP-self-signed-4028325014
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4028325014
revocation-check none
rsakeypair TP-self-signed-4028325014
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key ramajeyavpn address 10.10.10.2
!
crypto ipsec security-association lifetime seconds 86400
!
crypto ipsec transform-set ramajeya esp-3des esp-md5-hmac
!
crypto map ramajeyamap 10 ipsec-isakmp
set peer 10.10.10.2
set transform-set ramajeya
match address VPNACL
!
!
!
controller E1 0/0/0
channel-group 0 timeslots 1-16
!
controller E1 0/1/0
pri-group timeslots 1-31
!

!
interface FastEthernet0/0
description $ES_LAN$
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
ids-service-module monitoring inline access-list 101

interface Serial0/0/0:0
ip address 10.10.10.1 255.255.255.0
encapsulation ppp
crypto map ramajeyamap
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn overlap-receiving
isdn incoming-voice voice
isdn contiguous-bchan
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 192.168.0.0 255.255.255.0 10.10.10.2
ip route 192.168.2.254 255.255.255.255 IDS-Sensor0/1
ip http server
ip http secure-server
!
!
!
ip access-list extended VPNACL
permit ip 192.168.2.0 0.0.0.255 192.168.0.0 0.0.0.255
!
access-list 101 permit tcp any eq www any
!!

voice-port 0/1/0:15
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
dial-peer voice 100 voip
destination-pattern 1..
session target ipv4:10.10.10.2
supplementary-service pass-through
!
dial-peer voice 500 pots
destination-pattern 5..
supplementary-service pass-through
supplementary-service qsig call-forward
direct-inward-dial
port 0/1/0:15
forward-digits all
!
dial-peer voice 200 voip
destination-pattern 2..
session target ipv4:10.10.10.2
!
dial-peer voice 300 voip
destination-pattern 3..
session target ipv4:10.10.10.2
!
dial-peer voice 400 voip
destination-pattern 4..
session target ipv4:10.10.10.2
--More--         !
!
!
!
line con 0
line aux 0
password cisco
login
line 258
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
speed 115200
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
end

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marwan ALshawi Sun, 12/27/2009 - 00:06
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

i think al most this is codec issue

can you please try the follwoing


add an additional incoming dial peer in each of your routers with the following settings

dial-peer voice 90 voip

codec g711 ( use ulaw or alaw based on what is the codec used in ur PBX)

incoming called number 1..


as the voip dial peer by default uses the codec as g729

when you make the above dial-peer as the default incoming dial peer and enforce the codec will make sure no Xcoding required


and then try to make calls


good luck

if helpful Rate

Actions

This Discussion