Slow internet on Mac using RV082

Answered Question
Nov 30th, 2009

I've been having trouble with the internet connection speed on my Mac. I originally noticed the problem when my mail kept timing out whenever I sent an attachment, I went to different forums trying to find the solution but nothing really worked, so I found work arounds for the email and lived with it. Recently the company I work for moved offices and I was no longer behind the RV082 and my internet ran better dispite the slower connection. Once we finished moving, I needed to use the Dual Wan Load Balance feature of th RV082 so I set it up in the new office and my internet was slow again. Unfortunatly in the new office there are several more Macs than just mine so I really need to get it working. Currently we have 2 seperate networks for PC and Mac and I really need to get them on 1. Is there a setting I may have overlooked or is it not going to work with Mac. I'm wondering if it a problem with just my router cause I can't find anythign about it online.

I have this problem too.
0 votes
Correct Answer by Alejandro Gallego about 7 years 1 week ago

It sounds to me that you may be running Leopard or above. One thing to take a look at is IPv6. To keep things simple, disable IPv6 on your Mac (just one) and see if that makes a difference. With 10.5 and later, the move to IPv6 is stepping up, unforntunately some devices just don't play nice. Also do a little Google search on "How to speed up Firefox on Mac" and you will find some articles with steps on how to disable IPv6 on the browser.

Let us know if you still have issues.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (3 ratings)
Loading.
Correct Answer
Alejandro Gallego Tue, 12/01/2009 - 22:42

It sounds to me that you may be running Leopard or above. One thing to take a look at is IPv6. To keep things simple, disable IPv6 on your Mac (just one) and see if that makes a difference. With 10.5 and later, the move to IPv6 is stepping up, unforntunately some devices just don't play nice. Also do a little Google search on "How to speed up Firefox on Mac" and you will find some articles with steps on how to disable IPv6 on the browser.

Let us know if you still have issues.

cerebralentropy Wed, 12/02/2009 - 11:49

That helped a lot, especially after disabling IPv6 on Firefox. Unfortunately Safari still seems slow and disabling IPv6 for the OS is supposed to disable it for Safari, but I guess this may be a question for the Apple forums.

I'm also concerned, isn't IPv6 a good thing? Do I have to live without it from now on if I continue using the RV082 or is that something that may be fixed in a future firmware update?

Thank You for the help so far.

Alejandro Gallego Wed, 12/02/2009 - 12:01

IPv6 is a very good thing. The problem is that not all ISPs actually route IPv6 DNS queries, which can cause slow downs in resolving names. If your ISP does support IPv6 and the RV is just being a pain, this will certainly be addressed in future FW updates. I use a MacBook Pro (2009) and OS 10.6; while running behind any of our routers (RV0XX included) I have not noticed a significant slow down. I have seen and heard of your exact problem but it has not been confined to the RVs. It is a very good thing that you posted, as these forums are monitored and they do provide assistance to our developers.

Glad to know that it resolved your problem. Let us know if you ever have more questions.

avendio_bb Wed, 12/29/2010 - 04:00

Same problem here with RV042 and several Macs, latest firmware. Very slow internet connection sometimes with certain websites. On Windows 7 seems to work everything fine.

netpathinc Thu, 12/29/2011 - 18:23

Same problem here on RV082 running firmware version 2.0.2.01. (Not V3 hardware).  All Macs exhibit slow browser response and traceroute timeouts on some network addresses while working fine on others.  We're running the latest Lion release, v10.7.2.

The RV082 System Log shows "Connection Refused - Policy violation" errors.

An address that responds very slowly on Safari on OSX will work fine on the same machine under IE on a WindowsXP Fusion VM.  I tried changing DNS to Google public DNS (8.8.8.8 and 8.8.4.4); flusing OSX DNS cache (>dscacheutil -flushcache); resetting PRAM/NVRAM (Command-Option-P-R reboot); disabling RV082 firewall DoS.  No joy.

Thanks for any help or suggestions.

If we can't resolve this quickly it will be time to dump the RV082 and look for an alternative.

- Sheldon

We are using an RV220W and have no problems with Apple devices such as, iPhones, iPads, and Macbook Pro's (different generations, but all running Lion).

We had ipv6 turned off in the router up until about a week ago with no slow downs.  Even after turning ipv6 on in the router (a workaround to get upnp to work) we still are not experiencing any slowdowns.

None of the devices have been configured to turn ipv6 on (or off for that matter).  They are using the default Apple network settings.  We just plug in the ethernet cable or use wireless with no changes in the System Preferences.

Perhaps we aren't visting the same sites.  Can you give me some examples so we can determine if we experience slow downs as well?

We do reserve IPs in the router by MAC address (in the "Static DHCP" tab in the router).  Maybe that's the key to us not experiencing slowdowns???

netpathinc Thu, 12/29/2011 - 19:41

My problems started when I updated the firmware in the RV082 to resolve some uPnP problems we were having. Before the update we were running a really old version.

> Can you give me some examples so we can determine if we experience slow downs as well?

I'm looking for a case for a new MacBook Air at the moment using a google Image search.  Here are a few links from the image search that don't work in OSX but that work fine in a Windows-VM on the same Mac:

   http://obamapacman.com/2011/05/macbook-air-twelvesouth-bookbook-leather-polio-book-case/

   http://workinprogress.calderoriginals.com/2008/03/calder-airlift-for-macbook-air-first.html

   http://www.ipad2iphone5.com/made-%E2%80%8B%E2%80%8Bof-carbon-fiber-macbook-air-case

I did have a few reserved IPs in the "Static DHCP" tab, as well, before reseting the router back to factory defaults to see if it would make a difference.  It didn't. 

Thanks! Sheldon

All of those links load very quickly on both one of our Windows machines (Windows 7 Ultimate) and a Macbook Pro (running Lion).

Our ISP (Timewarner Road Runner) doesn't support native ipv6 yet.  We don't use a tunnel broker either.  Therefore when I visit http://test-ipv6.com/ we recieve a 7/10 for both ipv4 and ipv6.  Maybe we don't experience slowdowns because we don't have ipv6 working on the WAN side?  Do you guys?

cerebralentropy Fri, 12/30/2011 - 07:27

Since this discussion has been restarted I figure I should make an update on the ipv6 solution. It worked, or seemed to work for a bit. I don't remember when we started having issues again since it was almost 2 year ago. Since we had mostly Macs at that point in the office, I started using a Time Capsule that my boss had bought to back up computers to and just forgot about the RV082.

Now we've outgrown the Time Capsule and need to go back to something a little more professional so I'm hoping this gets figured out. I also have older hardware, not V3, so that may have something to do with it. I'll have to go dig the router out of storage and see if I still have problem now that I'm running Lion.

troutsflyfishing Fri, 12/30/2011 - 12:08

Thanks Sheldon.  I am the only one running a Mac in the office, but I turned off IPV6 on it anyway.  I've also heard that since Snow Leopard the OS has adopted aggressive DNS caching...so I flushed cache as well.

Last night I had all machines except the db server shut down (they are all Windows 7).  Everyone booted this morning, at which point all got IPv6 disabled.

So far today we've had no issues.  Still, keeping my fingers crossed.

netpathinc Sat, 12/31/2011 - 16:33

I tried to revert the firmware back to version 1.3.9.8 but it won't work.

I removed the RV082 from service today and replaced it temporarily with a WRT160Nv2.  Everything is working again on all PCs/Macs and I can't believe how much faster it is!  There is something seriously wrong with the verson 2.x RV082 firmware. Cisco are you listening?

- Thanks, Sheldon

I setup a tunnel at tunnelbroker.net (Hurricane Electric) and configured our RV220W to use it.  Now when we visit http://test-ipv6.com/ we recieve a 10/10 for ipv4 and 9/10 (because our ISP doesn't natively support ipv6) for ipv6.

After setting up and configuring the ipv6 tunnel upnp stopped working after reboots again.  In order to get it working again I had to disable and re-enable upnp in the web GUI again after each reboot.  It was frustrating.  However I found that increasing the hop count (Advertisement Time To Live) to 255 (max value) fixed upnp.  I tried increasing it by a few seconds (like from the default value of 4 to 20) and upnp only sporadically worked after reboots.

I'm not sure what the downside may be for increasing this value.

At any rate, WAN, LAN, and WLAN speeds have not been adversely affected by enabling ipv6.  We achive max WAN speed (15 - 30 Mbps, 15Mbps guaranteed by Time Warner).  WLAN speeds are usually around 12 - 15 MB/s and LAN speeds are limited only by hard drive speed.  I just tested copying a file to an older Windows 7 Ultimate laptop from a quad-core Windows 7 tower.  LAN speeds were 30-35 MB/s.  The same test to a Macbook Pro from the same tower yielded 45-50 MB/s.

These are the same speeds as with turning ipv6 off in the router and machines.

netpathinc Mon, 01/02/2012 - 06:07

Hi Curtis

I notice you're running an RV220W. The problems I've seen reported seem to be with the RV042 and RV082. We were running the older RV082 hardware at its latest firmware release, version 2.0.2.01. This router does not have a dual-stack and is ipv4 only.

One interesting note. Since switching out the RV082 and replacing it temporarily with a WRT160Nv2, the "Back to My Mac" feature is now working correctly. With the RV082 it always reported uPnP problems. Clue?

I'm looking for a replacement router now. Any suggestions would we welcome.

- Thanks, Sheldon

cerebralentropy Wed, 01/25/2012 - 08:56

Does anyone have any experience with the new RV082 or RV042. Do they have the same issue? I'm looking into buying a new router and I miss the dual wan option.

troutsflyfishing Wed, 01/25/2012 - 11:01

We wound up switching to OpenDNS for both wan connections, then flushing DNS caches on every workstation.  Also cycled every other IP device - switches, phones, cc terminal, printers, everything.

Been running for the last 3 1/2 weeks without a single hiccup at any device or the router.

makotocole5 Mon, 01/30/2012 - 14:19

I am experincing the same problem as the original poster.

I have:  RV082 V2 (latest firmware: 2.0.2.01).

My Mac machines are all experincing very slow internet.  A lot of the times it just times out completely and the page wont load.  My windows machines have no problems at all, perform very well.  I think this is related towards DNS.  I have tried using my ISP's DNS servers and Google DNS Servers 8.8.8.8, 8.8.4.4

All my clients are configured through DHCP.  I have tried with static addresses on the mac, but still have the same problem.

I need this router because of the Dual Wan Feature, and the PPTP server VPN feature.  I thought my unit was defective so I bought a second unit.  Same issues on both units.  I have two ISP's (Cable and DSL).  Happens on both ISP's.

Cisco, can you release a new firmware or offer some more troubleshooting advice please? 

netpathinc Mon, 01/30/2012 - 18:16

Hi Makoto

Unfortunately, I've made no progress with our RV082 problems.  I'm still running a WRT160Nv2 as a "temporary" replacement for the RV082 which is poison for Macs with the current firmware.  I think we're going to drop Cisco and look for another small business solution.  We're running 5 Macs and 3 PCs and, like you, the RV082 crippled the Macs but seemed to work OK with the windows machines.

Thanks for your post.

- Sheldon

makotocole5 Tue, 01/31/2012 - 11:50

Hi Sheldon,

After a full day of trying different firmwares, reseting the router to factory defaults, and switching them out between the two units that I have, I have finally decided to scrap the routers as well.  Too bad too, because they can be great units (when they work).

I am currently using a $60 D-Link Router which I have flashed with a DD-WRT Firmware.  I am now at least able to have my users connect to the network through PPTP VPN.  I have lost the Dual Wan feature though.  I am looking into getting a replacement.

I wonder if the RV082 Hardware version 3 also has this issue?

Instead of take the risk, I might go with another vendor.  If you happen to remember this post, could you let me know with what you decide to go with?  Thanks!

netpathinc Wed, 02/15/2012 - 18:59

Hi Makoto

I installed an RV220W-A V01 router running latest v1.0.3.5 firmware and a SLM2024T V02 switch running latest 1.1.2.0 firmware.  So far - so good.  I'm not pleased about having to buy new hardware but it did give me a chance to upgrade to dual-stack ipv4/ipv6 gigabit. :-)  We're upgrading the WAN to fiber in 2 weeks. 

Unfortunately, this is not the answer for mac users needing a dual-WAN VPN solution.

Best regards,

Sheldon

makotocole5 Thu, 02/16/2012 - 10:21

That is good that things eventually worked out for you.  I also think the 100Mbps is a limitation that I should eventually address on our network.

In the end, the small D-Link router running DD-WRT did not have enough memory to make the PPTP speeds on par with the RV082.  So I am using the DD-WRT as my main router and DHCP server, and have used my second WAN to filter my VPN traffic through with the RV082 on a seperate subnet.  Not the answer I was looking for, but it does allow business to continue as usual (for now).

Thanks for letting me know your hardware decisions. I'll look into them for my office needs.  Aloha

dondersconsulting Sun, 07/01/2012 - 12:35

I can confirm from an office with 75% macs and another with 100% PCs that this is not a mac-only problem.  The second was not even using router DNS, so while it is DNS-related, using external DNS did not fix for me.  I upgraded both offices to v3 hardware and no problems since.  Also v3 has new GUI that is 10 times better.  Lately been having problems at home, too  Decided to downgrade my v1 hardware units to v 1.3.98 firmware and seems to be good so far but will need a week or two to really test.  not sure the other v2 hardware unit I have will allow the FW downgrade, checking on that.

pickens46929 Sun, 12/09/2012 - 21:45

Purchased an RV082 within the past couple of months to address an issue with redundancy for my ISP connection as well as add VPN capabilities. I too have been hit with a slow internet issue and not just on Mac's either.

There seems to be an issue once we get several people connected. If I am the first one in on Monday, it seems to work fine. However, by 10am or so when most people are using the internet, it slows down more than our older router did.

I've got v3 hardware so I was hoping to avoid this issue.

dondersconsulting Mon, 12/10/2012 - 06:36

how many of your computers are using wireless, and what model is your access point?

how many total users, wired and wireless?

pickens46929 Mon, 12/10/2012 - 08:20

Total devices is about 18 if you include absolutely everything such as printers, tablets, phones, etc.

Half of these are wireless via a Cisco Linksys AP. Not sure what model.

Does not make any difference whether it's wired or wireless. Speedtest.net and Speakeasy both show degraded performance.

Latest version of firmware is installed.

IPv6 is turned off as is uPNP.

Discovery-Bonjour is ENABLED

Firewall is ON

SPI is ON

DoS protection is ON

Block WAN Request is ON

Multicast is DISABLED

Latest symptom is that the DHCP Status is no longer updating Client Names but rather showing "new-host1", "new-host2". Even for things that I know advertise their client names such as iPhones, Apple Macs or newer Windows PCs in the office.

Right now I show 10 devices on the network. All 100Mbps, all auto-neg. 4 via wired and 6 via wireless. 2 via hard IPs and 8 via DHCP.

I have 2 showing "new-host1" and "new-host2" respectively. Both of which are Apple's. One iPad and one laptop. The other iPad and Mac laptop both correctly show their names.

dondersconsulting Tue, 12/11/2012 - 08:10

any chance one of your users has torrent or p2p software running?  (just a shot in the dark)

seriously, you may just have a bad unit.  The problem with this RV0xx series is that when they go bad, they don't just die (well, maybe sometimes).  I've had several go bad on me over the years, and they all appeared to work fine, but somewhere in the background they had crossed a threshold that affected speed and reliability. This would understandably make quality control difficult, so it's possible you just have a lemon.

I've got one in service right now that is borderline, my final test will be to copy its config to a matching unit and see if that one has any issues.  (annoying)   Lucky for me I have spares...

Actions

This Discussion

Related Content