CCA 2.2 does not seem to recognize smartport info

Unanswered Question
Nov 30th, 2009
User Badges:
  • Bronze, 100 points or more

I am not sure how CCA interacts with the smartport information but for whatever reason, all of the smartport info on the UC520 is reported and missing in cca 2.2.


When I logon the router I see the following:


interface FastEthernet0/1/0
switchport voice vlan 100
macro description cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/1
switchport trunk allowed vlan 1,2,100,1002-1005
switchport mode trunk
macro description cisco-wireless | cisco-wireless
spanning-tree portfast
!
interface FastEthernet0/1/2
switchport voice vlan 100
macro description cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/3
description Switched PDU
switchport voice vlan 100
power inline never
macro description cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/4
switchport voice vlan 1
macro description cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/5
switchport mode trunk
macro description cisco-wireless | cisco-wireless
spanning-tree portfast
!
interface FastEthernet0/1/6
switchport mode trunk
macro description cisco-wireless | cisco-wireless
spanning-tree portfast
!
interface FastEthernet0/1/7
switchport mode trunk
macro description cisco-wireless | cisco-wireless
spanning-tree portfast
!
interface FastEthernet0/1/8
switchport mode trunk
macro description cisco-switch | cisco-switch


But in CCA 2.2 I get this:


smartports-ppl.bmp


Are the smartport roles tied to the vlan.dat file?


Am I missing something?


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven DiStefano Mon, 11/30/2009 - 12:17
User Badges:
  • Blue, 1500 points or more

I opened the CCA console (F2, F3) and clicked Smartports in CCA 2.2 GUI.

It looks like he does some parsing of a few commands, one of which is show vlan-switch

What does yours look like?   Mine is below....

UC540#show vlan-switch


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1/0, Fa0/1/1, Fa0/1/2
                                                Fa0/1/3, Fa0/1/4, Fa0/1/5
                                                Fa0/1/6, Fa0/1/7
100  Cisco-Voice                      active    Fa0/1/0, Fa0/1/1, Fa0/1/2
                                                Fa0/1/3, Fa0/1/4, Fa0/1/5
                                                Fa0/1/6, Fa0/1/7
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup


VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
100  enet  100100     1500  -      -      -        -    -        0      0  
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0  
1005 trnet 101005     1500  -      -      1        ibm  -        0      0  
UC540#

eoncablewire Tue, 12/01/2009 - 08:26
User Badges:
  • Bronze, 100 points or more

Here are my results:


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1/0, Fa0/1/2, Fa0/1/3
                                                Fa0/1/4
2    VLAN0002                         active
100  VLAN0100                         active    Fa0/1/0, Fa0/1/2, Fa0/1/3
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0

eoncablewire Tue, 12/01/2009 - 08:29
User Badges:
  • Bronze, 100 points or more

I just noticed a difference on the smartport info. On a defaulted router the profile macro type is listed once. On this router, if you read the cli ouput, you will notice that the macro type is listed twice.


Is this normal behaviour?


I have only ever altered the smartports using CCA, never cli.


Thanks

Steven DiStefano Tue, 12/01/2009 - 08:29
User Badges:
  • Blue, 1500 points or more

hmmmmmmmm....shouldnt that name of VLAN 100 be Cisco-Voice?

And why arent all the ports listed?

not sure, but its different.....

eoncablewire Tue, 12/01/2009 - 08:33
User Badges:
  • Bronze, 100 points or more

Well I dont think its important but I am not fully aware of how the system or CCA uses the vlan.dat file.


It is my current understanding that the vlan # is important and that the 'Cisco-Voice' is just a description but I dont know. I am curious to know I setup a vlan on 3 different devices in the same network with the same vlan number but different labels if it would still work.

eoncablewire Tue, 12/01/2009 - 08:41
User Badges:
  • Bronze, 100 points or more

I now have a SECOND site with the same problem:


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1/0, Fa0/1/1, Fa0/1/2, Fa0/1/3, Fa0/1/4, Fa0/1/5
2    wavespec                         active
3    guest                            active
100  Cisco-Voice                      active    Fa0/1/0, Fa0/1/1, Fa0/1/2, Fa0/1/3, Fa0/1/4, Fa0/1/5
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0


interface FastEthernet0/1/0
switchport voice vlan 100
macro description cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/1
switchport voice vlan 100
macro description cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/2
switchport voice vlan 100
macro description cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/3
switchport voice vlan 100
macro description cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/4
switchport voice vlan 100
macro description cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/5
switchport voice vlan 100
macro description cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone | cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/6
switchport mode trunk
macro description cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless
spanning-tree portfast
!
interface FastEthernet0/1/7
switchport mode trunk
macro description cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless
spanning-tree portfast
!
interface FastEthernet0/1/8
switchport mode trunk
macro description cisco-switch | cisco-switch | cisco-switch | cisco-switch | cisco-switch | cisco-switch | cisco-switch | cisco-switch | cisco-switch | cisco-switch | cisco-switch | cisco-switch


I just logged onto the site for the first time using CCA 2.2 and I see smartport errors.

Steven Smith Tue, 12/01/2009 - 13:00
User Badges:
  • Gold, 750 points or more

Can you post the CCA logs from both of these sites?

Steven Smith Thu, 12/03/2009 - 10:29
User Badges:
  • Gold, 750 points or more

From the logs I see...


++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: WS-CE520-24PC-K9

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: WS-CE520-24LC-K9

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: WS-CE520-24PC-K9

++: DEBUG:  : [vlan-sync]This object is of type :- WLCInterfaceSyncContent

++: DEBUG:  : [vlan-sync]this object hashmap values are : - {2=foye, 100=cisco-voice}

++: DEBUG:  : [vlan-sync]other object hashmap values are :- {2=VLAN0002, 100=VLAN0100, 1=default}

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: pplus-wlc526

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: UC520

++: DEBUG:  : [vlan-sync]This object is of type :- WLCInterfaceSyncContent

++: DEBUG:  : [vlan-sync]this object hashmap values are : - {2=foye, 100=cisco-voice}

++: DEBUG:  : [vlan-sync]other object hashmap values are :- {2=foye, 100=Cisco-Voice, 1=default}

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: pplus-wlc526

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: UC520

++: DEBUG:  : [vlan-sync]This object is of type :- WLCInterfaceSyncContent

++: DEBUG:  : [vlan-sync]this object hashmap values are : - {2=foye, 100=cisco-voice}

++: DEBUG:  : [vlan-sync]other object hashmap values are :- {2=foye, 100=Cisco-Voice, 1=default}

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: pplus-wlc526

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: UC520

++: DEBUG:  : [vlan-sync]This object is of type :- WLCInterfaceSyncContent

++: DEBUG:  : [vlan-sync]this object hashmap values are : - {2=foye, 100=cisco-voice}

++: DEBUG:  : [vlan-sync]other object hashmap values are :- {2=foye, 100=Cisco-Voice, 1=default}

++: DEBUG:  : [vlan-sync]DatasetManager, particiapting NE with conflict: pplus-wlc526


So, it looks like vlan 1 is missing, and VLAN 100 should have the name of Cisco-Voice.  Also, it appears that one of the devices has VLAN0002 and VLAN0100 instead of foye and Cisco-Voice.

eoncablewire Thu, 12/03/2009 - 11:14
User Badges:
  • Bronze, 100 points or more

I have to tell you that due to the problems I have experienced with CCA in the past two days, I am terrified of letting CCA fix the vlan problem in a production environment.


I suppose I could go into the UC520 and delete the vlans and add them back with the proper description.


How would I do that on the CE520 switches and the Wireless controller?


I had been told by TAC in the past that the descriptions didnt matter, but it seems they do. I was under the impression that the number was important but not the description.


Could this be another CCA enforcement anomolly (it enforces rules that the ios/cme/cue or other software doesnt have)?


Thanks

Steven Smith Thu, 12/03/2009 - 16:23
User Badges:
  • Gold, 750 points or more

This is something that is CCA specific.  I would have to look at the devices to see how they configure name.  You can select for CCA to resolve the problem itself.  The deleting of VLAN's and readding isn't necessary.  A simple click of resolve should fix the problem.

Actions

This Discussion