Help with Voice Gateway Outgoing Calls

Unanswered Question
Nov 30th, 2009

Please Help.  I have an analog line plugged into a fxo port for our backup just in our VOIP environment.  I can make incoming calls to the analog line and it correctly forwards to the internal extension assign on the connection plar.  But when i try and make a call from the router.  I receive a disconnect.  csim start has been pretty helpful in testing my other 28 sites.

error:

csim start 94231294
csim: called number = 94231294, loop count = 1 ping count = 0

csim err csimDisconnected recvd DISC cid(54)
csim: loop = 1, failed = 1 
csim: call attempted = 1, setup failed = 1, tone failed = 0

Here's my configs:

!
voice-port 1/0/0
no comfort-noise
connection plar 1760
!
voice-port 1/0/1
no comfort-noise
connection plar 1760
!
mgcp call-agent 10.1.200.11 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
dial-peer voice 100 pots
destination-pattern 9T
port 1/0/0
!        
dial-peer voice 101 pots
preference 1
destination-pattern 9T
port 1/0/1
!        
dial-peer voice 911100 pots
destination-pattern 911
port 1/0/0
prefix 911
!        
dial-peer voice 911101 pots
preference 1
destination-pattern 911
port 1/0/1
prefix 911
!        
dial-peer voice 2000 voip
destination-pattern [1-8]...
session target ipv4:10.1.200.11
no vad  
!        
dial-peer voice 2001 voip
preference 1
destination-pattern [1-8]...
session target ipv4:10.1.200.10
no vad  
!        
dial-peer voice 9000 voip
destination-pattern 9T
session target ipv4:10.1.200.11
!        
dial-peer voice 9001 voip
preference 1
destination-pattern 9T
session target ipv4:10.1.200.10
no vad  
!        
dial-peer voice 7100 pots
destination-pattern 9[2-9]......
port 1/0/0
!        
dial-peer voice 7101 pots
preference 1
destination-pattern 9[2-9]......
port 1/0/1
!        
dial-peer voice 10100 pots
destination-pattern 91[2-9].........
port 1/0/0
!        
dial-peer voice 10101 pots
preference 1
destination-pattern 91[2-9].........
port 1/0/1
!        
!        
call-manager-fallback
max-conferences 4
ip source-address 192.168.73.1 port 2000
max-ephones 48
max-dn 96

Any help would be greatly appreciated.  Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Md. Mijanur Rahman Mon, 11/30/2009 - 20:17

Did u tried calling with IP Phones or with testing with csim only? Did u configured proper route patterns at CUCM?

I can see it's your MGCP gateway but didn't configured the voice-ports and dial-peers correctly according to MGCP configurations, you can have a look here for MGCP configurations:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008017825e.shtml

HTH

umamon Thu, 12/10/2009 - 10:20

Yes I only tried testing using CSIM... I very new to the voice side.  I will read over the document you sent in the link.  And let you know.  Thanks!

asandborgh Mon, 11/30/2009 - 20:26

too many unknowns for a definitive answer here

-

You are running CCM?  What version (just for kicks and giggles)?

you have bits of MGCP and H323 - what do you want to run here?

You are catching the incoming calls with H323 dial-peers

Have you connected a buttset or normal analog phone to the FXO to check dial out?  Some CO trunks do not provide dial-tone ( a human oriented signalling method) - you can still diall out as long as there is battery

Can you do a debug voice dialpeer to see which dialpeer you are matching outbound?

Also try a debug vpm signaling to see what is actually happening

Dial-peers 9000 and 9001 are also competeing with 100 and 101 - what are you trying to accomplish?

When you attempt to make a call "from the router" is only via CSIM?

umamon Thu, 12/10/2009 - 10:27

Hello,

Sorry for little information.  I am very new to the voice side of the router configs.  I really don't have a lot of answers for you because I didn't configure the voice stuff, so I don't what the purposes of some of the features that is in the config.  I only tested using CSIM.  I will do some of the debug option you listed.  Thanks!

Actions

This Discussion