OSPF issue

Unanswered Question
Nov 30th, 2009
User Badges:

G'day to all

guys i am trying to resolve an issue on couple of our distribution routers...I have 2 router connected through ATM links and the physical layer/PVC is up....the routers exchange routing through OSPF and it was working fine... recently we had an outage on our transmission network which has affected this link, the physical layer is up but the issue that i am facing is the OSPF neighbor for these 2 routers ... Router A is seeing the neighbour Router B in INIT state while Router B is not seeing Router A in ospf neighbour database.....

It seems the hello packets from Router B are being recognized by A while A does not seem to send hellos to B ...

Any assistance/suggestions to get the adjacency working would be appreciated....


Router A (router id 10.131.251.10)

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.131.251.58     1   INIT/  -        00:00:32    10.131.255.66   ATM4/0.1


Router B does not have A in its neighbour table......

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Mon, 11/30/2009 - 19:22
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

From router A, can you ping the IP address of router B interface and vice versa from B to A?

Can you post your OSPF configs from both sides and the interfaces that connect theses 2 routers together?


Reza

amar_5664 Mon, 11/30/2009 - 20:10
User Badges:

Mate below is the config details.....


Router A

interface ATM4/0
description xxxxx
no ip address
load-interval 30
no atm ilmi-keepalive
!        
interface ATM4/0.1 point-to-point
description xxxxx
ip address 10.131.255.65 255.255.255.252
pvc YS 1/99
  encapsulation aal5mux ip
!       
!        
router ospf 100
log-adjacency-changes
network 10.128.0.0 0.15.255.255 area 0


Interface                  IP-Address      OK? Method Status                Prot
ocol
ATM4/0                     unassigned      YES NVRAM  up                    up 
   
ATM4/0.1                   10.131.255.65   YES NVRAM  up                    up


ATM4/0.1 is up, line protocol is up
  Internet Address 10.131.255.65/30, Area 0
  Process ID 100, Router ID 10.131.251.10, Network Type POINT_TO_POINT, Cost: 2
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:00
  Index 4/4, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 4, maximum is 51
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

-------------------------------------------------------------------------------------------------
Router B

interface ATM2/0
description xxxxxxx
no ip address
load-interval 30
no atm ilmi-keepalive
!        
interface ATM2/0.1 point-to-point
description xxxxx
bandwidth 34368
ip address 10.131.255.66 255.255.255.252
pvc SW 1/99
  encapsulation aal5mux ip


router ospf 100
log-adjacency-changes
redistribute static subnets
passive-interface Dialer0
passive-interface Dialer1
passive-interface Dialer3
passive-interface Dialer4
network 10.128.0.0 0.15.255.255 area 0


Interface                  IP-Address      OK? Method Status                Prot
ocol
   
ATM2/0                     unassigned      YES NVRAM  up                    up 
   
ATM2/0.1                   10.131.255.66   YES NVRAM  up                    up


ATM2/0.1 is up, line protocol is up
  Internet Address 10.131.255.66/30, Area 0
  Process ID 100, Router ID 10.131.251.58, Network Type POINT_TO_POINT, Cost: 2
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 8, maximum is 51
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

Jon Marshall Tue, 12/01/2009 - 05:49
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

amar_5664 wrote:


Mate below is the config details.....


Router A

interface ATM4/0
description xxxxx
no ip address
load-interval 30
no atm ilmi-keepalive
!        
interface ATM4/0.1 point-to-point
description xxxxx
ip address 10.131.255.65 255.255.255.252
pvc YS 1/99
  encapsulation aal5mux ip
!       
!        
router ospf 100
log-adjacency-changes
network 10.128.0.0 0.15.255.255 area 0


Interface                  IP-Address      OK? Method Status                Prot
ocol
ATM4/0                     unassigned      YES NVRAM  up                    up 
   
ATM4/0.1                   10.131.255.65   YES NVRAM  up                    up


ATM4/0.1 is up, line protocol is up
  Internet Address 10.131.255.65/30, Area 0
  Process ID 100, Router ID 10.131.251.10, Network Type POINT_TO_POINT, Cost: 2
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:00
  Index 4/4, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 4, maximum is 51
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

-------------------------------------------------------------------------------------------------
Router B

interface ATM2/0
description xxxxxxx
no ip address
load-interval 30
no atm ilmi-keepalive
!        
interface ATM2/0.1 point-to-point
description xxxxx
bandwidth 34368
ip address 10.131.255.66 255.255.255.252
pvc SW 1/99
  encapsulation aal5mux ip


router ospf 100
log-adjacency-changes
redistribute static subnets
passive-interface Dialer0
passive-interface Dialer1
passive-interface Dialer3
passive-interface Dialer4
network 10.128.0.0 0.15.255.255 area 0


Interface                  IP-Address      OK? Method Status                Prot
ocol
   
ATM2/0                     unassigned      YES NVRAM  up                    up 
   
ATM2/0.1                   10.131.255.66   YES NVRAM  up                    up


ATM2/0.1 is up, line protocol is up
  Internet Address 10.131.255.66/30, Area 0
  Process ID 100, Router ID 10.131.251.58, Network Type POINT_TO_POINT, Cost: 2
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 8, maximum is 51
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)


As Reza suggested, can you ping router B address from router A and vice-versa ?


Jon

amar_5664 Tue, 12/01/2009 - 16:14
User Badges:

Hi Jon,


Yes it is pingable, but this morning i am dropping some packets and have input errors on interface will have transmission guys to troubleshoot transmission line. Have similar issue on 2 more routers in other region as well though the interfaces are not pingable so presume something wrong on SDH network. Thank you guys btw will post if find any issue...

amar_5664 Wed, 12/02/2009 - 13:50
User Badges:

Reza and Jon thanks for your input, the issue is resolved....unfortunately there was a faulty card of o

ne of the SDH equipments.....

Actions

This Discussion