Problems using modems on a V224 Analogue Gateway

Answered Question
Dec 1st, 2009

Hi All

        As part of a large migration from TDM to IPT we have installed 3 x V224 Analogue Gateways for use with Modems on Laptops etc. to dial up to customer equipment via the PSTN (TDM).

  The engineers who are initiating the modem connections are complaining that the negotiated speed is very low and is often dropping the connection or hanging the session.

  I have checked both the V224 and VWIC gateways and bot are set to enable Modem Passthrough, not too sure what else I should be checking.

  Any assistance on what to check would be much appreciated.

  Thanks Greg

I have this problem too.
0 votes
Correct Answer by asandborgh about 7 years 1 week ago

The VWICs, are they MFTs?  PRIs?  If so, are you

getting your clock form the carrier?  Clock slips will cause the type

of behavior you are seeing.  Do a show controller....

If you find nothing there, something in the back of my mind is telling me you might want to make sure you also have fax passthrough - that in certain cases that handles modem traffic as well

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Greg Cording Tue, 12/01/2009 - 10:27

Hi

   Thanks for the reply, using MGCP on both V224 and PSTN Gateways.

  Cheers Greg

Correct Answer
asandborgh Tue, 12/01/2009 - 10:39

The VWICs, are they MFTs?  PRIs?  If so, are you

getting your clock form the carrier?  Clock slips will cause the type

of behavior you are seeing.  Do a show controller....

If you find nothing there, something in the back of my mind is telling me you might want to make sure you also have fax passthrough - that in certain cases that handles modem traffic as well

asandborgh Tue, 12/01/2009 - 11:00

Greg,

Take a look here:

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t11/feature/guide/ft_ghost.html#wp1072731

controller E1 0/1

 pri-group timeslots 1-31 service mgcp

!

interface Serial0/0:15

 no ip address

 isdn switch-type primary-net5

 isdn incoming-voice modem

 isdn bind-l3 backhaul set1

 no cdp enable

!

mgcp modem passthrough voip mode nse

mgcp modem passthrough voip codec g711alaw

mgcp codec g729r8 packetization-period 10

mgcp vad

mgcp quarantine mode process

mgcp package-capability dtmf-package

mgcp package-capability mf-package

mgcp package-capability rtp-package

mgcp package-capability nas-package

mgcp package-capability as-package

mgcp package-capability script-package

mgcp default-package ms-package

no mgcp timer receive-rtcp

no mgcp piggyback message

mgcp fax t38 inhibit

mgcp profile default

mgcp profile PRI

 call-agent 10.10.0.0 service-type mgcp version 0.1

Make sure your settings match at both ends - and perosnnaly I would get rid of the VAD line.  Make sure the G711 line is in there, and is properly set (alaw vs ulaw) depending on your location

HTH,

Art

Actions

This Discussion