Two outside IP's to two inside IP's

Unanswered Question
Dec 1st, 2009

Hello,

I am new in Cisco configuration. I have Cisco 871 router. Now I have one outside IP and one inside IP. The ISP gave one more outside IP. I want to do that second outside IP mapped to unused ethernet port.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Roman Rodichev Tue, 12/01/2009 - 23:43

Are both outside IPs routed to the outside interface? Are you trying to map the 2nd IP to another inside IP? Just configure "ip nat inside source static <2nd_outside_IP>". Sorry if this doesn't answer your question.

Regards,

Roman

Ganesh Hariharan Tue, 12/01/2009 - 23:56

you mean both the outside ip are in different subnet or in the same subnet.If different subnet just enter into serial or ethernet interface and type ip address "ip address" mask.

Regards

Ganesh.H

jokubaszilenas Thu, 12/03/2009 - 04:05

i have no luck with NAT.

Both outside IP's are in one subnet. Can you tell all steps how to do it?

Jon Marshall Thu, 12/03/2009 - 16:43

jokubaszilenas wrote:

i have no luck with NAT.

Both outside IP's are in one subnet. Can you tell all steps how to do it?

An example might help.

inside interface of router =  fa0/0  192.168.5.1

outside interface of router = fa0/1

new public ip address = 195.17.17.10

lets say you want to present an internal 192.168.5.10 address as the new public IP address -

config would be as follows

int fa0/0

ip nat inside

ip fa0/1

ip nat outside

ip nat inside source static 192.168.5.10 195.17.17.10

Jon

jokubaszilenas Fri, 12/04/2009 - 01:24

I changed my configuration with this and no luck:

interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly

interface FastEthernet2
switchport access vlan 2

ip nat inside source static 192.168.2.1 *.*.134.20

my router configuration is:

Building configuration...

!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
switchport access vlan 2
!
interface FastEthernet3
!
interface FastEthernet4
description $FW_OUTSIDE$$ETH-WAN$$ES_WAN$
ip address *.*.134.14 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet4 overload
ip nat inside source static 192.168.2.1 213.197.134.20
end

Marwan ALshawi Tue, 12/29/2009 - 20:57

can ping somthing in the internet

using ping x.x.x.x source vlan 2

then do show ip nat translation and see if the translation happning or not

if not post the debug ip nat detail   here

Actions

This Discussion

Related Content