Ad Hoc conferences fail out gateway to PSTN

Unanswered Question
Dec 2nd, 2009

Ad Hoc Conferences are failing when calling out the MGCP gateway (3845, 12.4-15T8) to the PSTN.  Internal calls can be conferenced with no problem.  On outside calls, A user can call out to two different people, but when that user hits the conference button there is no voice stream even though the conference is technically up and the phone shows the conference up.  It is configured to use a hardware resource on the gateway, which is up and registered to the CUCM (ver 6.1.4).  I looked at the traces and the CUCM hunts though a bunch of software resources and a few hardware resources (see below), non of which are the resource on the gateway. 
  The PRIs are in a Device Pool that has the MRGL, MRG, CFBxxxxx resource in it.  I reset the conference resource but no change.

  Why is it not hunting to this resource, or why is that resource not available in the list when the MRM is looking for a conference resource?  And what can I do to get it to use the hardware CFB resource on the gateway?  Thanks.

Hunting for a resource

CCM|MRM::getUcbDeviceGivenMrgl GETTING UCB FROM DEFAULT LIST|
CCM|MRM::getUcbDeviceGivenMrgl CFB_3 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_5 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_7 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_8 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_9 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_10 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_11 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_12 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_13 Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFB_4 Group=2 Counter=0, Capability=1|
CCM|MRM::getUcbDeviceGivenMrgl CFB_2 Group=2 Counter=0, Capability=1|
CCM|MRM::getUcbDeviceGivenMrgl CFB_14 Group=2 Counter=0, Capability=1|<
CCM|MRM::getUcbDeviceGivenMrgl CFBxxxxxxxxxxxx Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFBxxxxxxxxxxxx Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFBxxxxxxxxxxxx Group=2 Counter=0, Capability=1
CCM|MRM::getUcbDeviceGivenMrgl CFBxxxxxxxxxxxx Group=2 Counter=0, Capability=1
CCM|MediaResourceManager::waiting_MrmAllocateUcbResourceReq - CREATED CHILD USING MRGL AND DEFAULT LIST

It seems to settle on a software resource which is registered to another server, CFB_14.  It's the only software resource that's registered.  All the others are not registered.

CCM|MediaResourceCdpc(190640)::waiting_MrmAllocateUcbResourceReq UcbDevice=CFB_14
CCM|MediaResourceCdpc(190640)::sendUcbAllocateRequestToDevice UcbResource=CFB_14
CCM|MediaResourceCdpc(190640)::resource_rsvp_AllocateUcbResourceRes device=CFB_14
CCM|MediaResourceCdpc(190640)::getUcbDeviceCapability - CI = 58513758, Device Name = CFB_14, Device Capability=1
CCM|MediaResourceManager::waiting_MrmAllocateUcbResourceRes
CCM|MRM::updateUcbCounter CFB_14
CCM|MRM::updateUcbCounter allocateCounter=1
CCM|MRM::waiting_MrmAllocateUcbResourceRes - return to CC bridge = b00206103006 CFB_14
CCM|MediaResourceManager::waiting_MrmChildStopInd
CCM|MediaResourceCdpc(190640)::shutting_down_MrmChildStopConf

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Wed, 12/02/2009 - 11:06

Sounds like a codec issue.

Run a quick test with the conference call.

When in the conference call with the participants, can the they talk to each other?

Also check on the IP phone hit the ? twice to see the audio stats.   Do you show sending and receiving of an audio codec?  If you see none on one side, possible the gateway is not in a location or region defined to be used with the phones.

Are you using CUCM for conferencing or IOS hardware?

d.anthony.hadley_2 Wed, 12/02/2009 - 12:11

I'm using IOS hardware.  The participants are not able to hear each other.  There is no voice stream either way, but the conference appears to be up.  The PRI and the gateway are in the same device pool so they all use the same MRGL, MRG and CFB resource.  But according to the traces it goes to a default list (see below) for resources, even though it sees the MRGs in the MRGL.  I'll have to have them look at the codec on the phone tomorrow.

  At this point, I'm resetting the resource, MRG and MRGL.  Any thing else to look for?

MRM::convertScmStringToStdString moh_ann_mrg:CFB_MRG_1

MRM::getUcbDeviceGivenMrgl GETTING UCB FROM DEFAULT LIST

And there is also this in the trace, does this mean the conference started?:

Conference: mPrimaryControllerNonConferee PatternPartition = 5555555:DID_L1_Pt|
CCM|Conference(start): iter PatternPartition = 5555555:DID_L1_Pt

Actions

This Discussion

Related Content