RV082 Firmware Upgrade Breaks WAN

Unanswered Question
Dec 2nd, 2009

I have upgrade the firmware on several RV082 (and RV042) model routers, and all of them have had subsequent WAN connectivity loss. The WAN works for a while, then stops working until the router is restarted, then fails shortly thereafter. I would assume it was some configuration corruption on incompatibility with the upgrade, but the symptom has been universal. EVERY 2.x upgrade I've made to a RV082 or RV042 router has exhibited this symptom. Reverting to the 1.3.98-tm firmware fixes the issue. Has anyone else had this trouble? Any solution?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
allansaenz Sun, 12/06/2009 - 11:36

I am having the same problem on the rv016, it works for maybe 30 minutes and then starts having problems, I cant access the router and it dosent do dhcp.

then after a while stops completly.

I upgrade to the latest 3.0.0.19-tm  (Feb 16 2009 12:32:28) and If downgrade I still have the same problem.

I need a solution for this, i dont know if the problem also start when there is more than 10mbps downloads.

What is the capacity of this router we have 4 6 mbps dsl, but I dont know if its going to handle a lot of traffic.

Thanks

allansaenz Thu, 12/17/2009 - 20:29

Any information about this.

I cant get more than 10 mbps,

Please help

Alejandro Gallego Fri, 12/18/2009 - 00:27

We may have two different problems here.

For both can you check to see if your clients are running IPv6, and also if possible move the WAN connection to the other port; does the problem remain?

allansaenz Fri, 12/18/2009 - 07:39

Clients are not using IPV6, I have 4 wans.

I tried switching and still the same problem.

Is there something else I can try?

Thanks again

Te-Kai Liu Fri, 12/18/2009 - 08:27

One thing you could try is to reset the router to factory defaults and reconfigure the router from scratch. If you do not want to take this path, you could call into the Small Business Support Center and provide the router configuration file and the network topology. It will help us to root cause the issue and prvoide a fix. 

prausch Fri, 12/18/2009 - 08:30

I have done this (reconfigure from scratch) on multiple occasions with the same results (loss of connectivity for all clients after a short period of time). I had not considered the IPv6 issue before, which sounds more promising, if there is a control on the RV082 to prevent the problem.

renatotoi Tue, 05/18/2010 - 09:26

My rv016 with firmware 3.0.0.19-tmkeeps resetting itself when i connect 3 wans. With only 2 wans, it did not reset for 19 days.

It is supposed to support 7 wans, but I will keep 2 for the moment.

Have you tried yours with only 2 wans ?

Renato

prausch Fri, 12/18/2009 - 08:26

Yes, all of these occasions have Mac clients which has IPv6 enabled as the default setting. Turning it off for all the clients involved would be difficult. I have seen that IPv6 can cause issues. Is there a way to disable IPv6 in the new firmware?

prausch Thu, 07/28/2011 - 09:23

Update - I have now seen this behavior with over a dozen RV042/RV082 devices. Solutions are:

Downgrading the RV082 to the 1.3.9.8 firmware

Downgrading the RV042 to the 1.3.12.6 firmware

Replacing the unit with the version 3 hardware (RV042v3, RV082v3). I have done this in three cases.

In all cases, these actions fix the WAN access issues for LAN computers.

Some additional details:

Nearly all of my LAN clients in these situations are Mac OS X computers.

Not all RV042 routers with 1.3.13+ firmware, or RV082 routers with the 2.0+ firmware have this issue, but more than 75% seem to develop the problem, and the problem happens soon after the upgrade to the firmware, or if the device shipped with the newer firmware.

All devices that have the problem have one or more VPN Gateway-Gateway tunnels defined and active, but have a variety of other settings.

The symptom of the problem is that LAN computers have no problems with LAN IP communications, including access to the router administration web pages, but have intermittent or no connectivity to the WAN. The symptom is first observed as DNS timeouts, then can progress to total loss of WAN connectivity, but this more severe situation is not as common. Sometimes renewing the DHCP lease reactivates connectivity, sometimes restarting the router is required.

I have tried reloading firmware, factory defaulting devices, and not setting any settings except WAN IP information. The symptom was still present unless one of the above three solution actions was taken.

The v3 hardware and software is vastly improved, and I recommend this solution for anyone experiencing this problem, and possibly as a general recommendation. Performance of faster WAN connections is improved with the new hardware. Users that require the improvements in the firmware versions that exhibit this symptom should upgrade to the v3 hardware.

FredrikNO Tue, 11/01/2011 - 02:53

How du you downgrade the firmware from the 2.x.x back to the good old 1.3.9.8 ?

I thought it was prevented from downgrading....

Thx

Fredrik

prausch Tue, 11/01/2011 - 08:26

If your router originally supported the 1.3.9.8 firmware, you can use the firmware upgrade procedure to install any version of firmware. The settings will be reset to factory defaults on a downgrade, and I don't think settings exported from 2.x are compatible with 1.x, so you will have to manually re-configure the WAN, Forwarding, and any VPN tunnels, among other settings..

FredrikNO Tue, 11/01/2011 - 08:37

OK..

We have two RV082. One of them is V2 and where shipped with 2.x.x firmware. Is it possible to put 1.3.9.8 into that one as well?

Fredrik

prausch Tue, 11/01/2011 - 08:49

The V2 only supports the 2.x firmware, and will prevent downgrade. I recommend replacing it with a V3 device. Everything is better.

Actions

This Discussion