EBGP neigbor issue

Answered Question

Hi !


I'm currently working on my BSCI certification Exam, I had setup the attach lab for my understanding about BGP. I don't know why the my router in different AS cannot enter in establish states. The same setup exist between PXR1 and PXR2 router both are member in same AS those are able to go in established states. I try to changed BBR2 to the AS 65001 and change neighbor statement in the PXR1 router, after that those router are going into establish states.... I had used extended ping to reach each router loopback interface with source address the loopback interface to check if my problem is an router issue, each router can ping each of there supposed neigbor router. But only router are in the same AS will be enter in the establish states.


I would like to know why thoses routers cannot be going in establish states (all of then are kept in idle states)

Attachment: 
Correct Answer by Giuseppe Larosa about 7 years 3 months ago

Hello Christian,


eBGP sessions have a default TTL of 1


neighbor 192.168.200.4 remote-as 64998
neighbor 192.168.200.4 update-source Loopback0


you need to add


neigh 192.168.200.4 ebgp-multihop 2


iBGP sessions default to TTL 255 in BGP messages and don't need the above command


do the same on both ends


Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
Correct Answer
Giuseppe Larosa Thu, 12/03/2009 - 06:51
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Christian,


eBGP sessions have a default TTL of 1


neighbor 192.168.200.4 remote-as 64998
neighbor 192.168.200.4 update-source Loopback0


you need to add


neigh 192.168.200.4 ebgp-multihop 2


iBGP sessions default to TTL 255 in BGP messages and don't need the above command


do the same on both ends


Hope to help

Giuseppe

Laurent Aubert Thu, 12/03/2009 - 07:04
User Badges:
  • Cisco Employee,

Hi,


By default, the router assume the eBGP peer is directly connected so the TTL is set to 1. To change this behavior, you need to add the following configuration:


neighbor x.x.x.x ebgp-multihop


http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#wp1037550


or even better  if your version support it:


neighbor x.x.x.x disable-connected-check


http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_n1g.html#wp1079915


HTH


Laurent.

Actions

This Discussion