RCMS Service Not Available?

Unanswered Question
Dec 3rd, 2009

Attempting to send an email blast...

RCMS service is unavailable. Please try later or contact administrator.

None of the email seems to be working.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
MICHAEL CARTER Tue, 06/15/2010 - 01:09

Dear Justin,

I have the the same message being displayed and wondered if you resolved this problem?

Yours sincerely,

Michael.

Tracy Larson Tue, 08/31/2010 - 05:08

http://uccert.wikidot.com/bugs

Symptom: After upgrading to 2.1 email notifications are not working anymore, and they are stuck in the email notification queue. Also, SMTP config is not accessible anymore from the web admin. When going to System Configuration --> E-Mail Service Administration --> SMTP Server Configuration, getting error: "Sorry, could not process your request, please try again later!"
Conditions: Cisco Unified MeetingPlace Express 2.1.1.2, after upgrading from v2.x SMTP server configuration has authentication enabled
Workaround: 1) Check this file, you should see that is in clear text: /opt/cisco/meetingplace_express/var/mail/conf/rcms-conf.xml 2) Edit the file, delete the password (leave it blank ) 3) Restart MPX services: 'mpx_sys restart' 4) From the web admin --> E-Mail Service Administration --> SMTP Server Configuration add back the password. 5) Verify that now the file rcms-conf.xml has the password encrypted. Notification should now work.
Further Problem Description: Prior to MPE v2.1, the SMTP server password in the rcms-conf.xml was in clear text. With 2.1 is now encoded. We have seen occurrences were the password was clear still after the upgrade, which cause to generate this exception in userweb.out logs, prevent to access SMTP page and breaks email notification: [--userweb--][http-8080-Processor23] 2009-02-03 08:08:30,573 [ERROR,RCMSConfigSMTPAction 37] Global exception occured in action com.cisco.meetingplace.admin.web.actions.email.RCMSConfigSMTPAction: java.lang.IllegalArgumentException: The char '0xf' in 'return code: 500 HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception java.lang.IllegalArgumentException: The char '0xf' in 'java.lang.IllegalArgumentException: The char '0xf' in '' is not a valid XML character.' is not a valid XML character.

About all I could find but I have no clue if you did an upgrade or what your chain of events were that made this stop working.

Joshua Learn Tue, 08/31/2010 - 09:06

Thank you for the response.  We did not recently upgrade to version 2.1 but I'll give those files a look anyhow.  We did however recently bring up a new mail server and decomission the old one.  The new mail server is online and we are using the same DNS name sucessly to relay mail from other systems.

The error we are receiving is "RCMS service is unavailable.  Please try later or contact administrator."

Tracy Larson Tue, 08/31/2010 - 10:28

Are you showing any emails in queue at all that just arent delivered from the MPE server? Or you cannot send email period? Check the queue inside MPE, if you have emails stuck in queue odds are that your ./opt directory is full and you will have to clean stuff up to free space. We ran into this a couple of times. If this is the case I will try to find the TAC case and the script that the guy from TAC ran on the server to clean things up as its not as easy as just searching for large files no longer in use.

Joshua Learn Tue, 08/31/2010 - 11:04

Yes, there are emails stuck in the queue and no new emails are going out. It also appears that the /opt directory is 100% full. I would appreciate it if you could share the script.

kibugibenson Fri, 02/11/2011 - 07:17

Hi,

I am having the same issue. Though in my case is not about space as there is still a lot of space available. I am not able to send emails at all, they just queue up.

Any thoughts?

Regards,

Benson

Alok Tilavat Mon, 02/21/2011 - 09:54

Looks like your RCMS configuration is corrupt. I woud suggest upgrading to 2.1.1.2 with hotfix 38.

That should resolve this issue and proactively prevent a multitude of other severe issues.

Actions

This Discussion