IOS SSL VPN Assistance...

Unanswered Question
Dec 3rd, 2009
User Badges:

Hi,

     I am attempting to setup an SSL VPN connection between a router and a PC.  The connection occurs perfectly but local user authentication is failing, I have a local user defined.  The router configuration is below, does anyone see any problems that would cause the login attempt to fail?


version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
aaa new-model
!
!
aaa authentication login SSLVPN local
!
!
aaa session-id common
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-998521732
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-998521732
revocation-check none
rsakeypair TP-self-signed-998521732
!
!
crypto pki certificate chain TP-self-signed-998521732
certificate self-signed 01
  30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 39393835 32313733 32301E17 0D303230 33303130 32313632
  325A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3939 38353231
  37333230 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  DE3DABC6 1DA80C70 4D48AFE9 E44EB73B E3C3D60D 5991C5F3 38895707 F9B857DC
  E11EA09A A2C10512 D5E27842 2A9C655A 121D45C3 D9B33C3A 29AD6CA0 89C37C20
  476653BA E7272549 70B1CDC6 EB7E4FB3 F5BD6479 31DB0F41 EACB48C8 A60D86A6
  177911D5 1CF19D75 0EB2EAAF 7EDB3A94 1CA0413F 0C0BAEE6 344A6759 C0D191F9
  02030100 01A37130 6F300F06 03551D13 0101FF04 05300301 01FF301C 0603551D
  11041530 13821149 4E455F52 365F5650 4E76355F 4C616233 301F0603 551D2304
  18301680 14655538 B120668D 5E08E0D7 4F17A950 4A17C741 95301D06 03551D0E
  04160414 655538B1 20668D5E 08E0D74F 17A9504A 17C74195 300D0609 2A864886
  F70D0101 04050003 8181002B A4D413BF 113F2B3F 57414407 ADE46E4A 7E3BD12B
  03ECB988 AE46FFE8 234C912A C084FF94 E62702D1 892F68EC E0506C05 3F99C39F
  E04DE273 7EB25B99 6B36F4CC A63A0797 8F66CAEB 76C903FE 10B44351 3DDF7070
  45C067BD 946D175C 1F76BB7C FF402C26 08FB004B 3DCAE8F9 63939402 F3B8B682
  54C8D0BA E9ED2A6D 53420A
        quit
!
!
username [email protected] password 0 CISCO
archive
log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 150.1.6.6 255.255.255.0
!
interface Loopback6
ip address 6.6.6.6 255.255.255.0
!
interface FastEthernet0/0
ip address 136.1.126.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 136.1.0.0
network 150.1.0.0
no auto-summary
!
ip local pool SVC_POOL 20.0.0.1 20.0.0.254
ip forward-protocol nd
!
!
ip http server
ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty 0 4
password cisco
!
!
!
webvpn gateway SSLVPN_GATEWAY
ip interface Loopback0 port 443
ssl encryption rc4-md5
ssl trustpoint TP-self-signed-998521732
logging enable
inservice
!
webvpn install svc flash:/webvpn/svc.pkg
!
webvpn context SSLVPN
title "SSL VPN at R6"
ssl encryption rc4-md5
ssl authenticate verify all
!
!
policy group DEFAULT_POLICY
   functions svc-required
   svc address-pool "SVC_POOL"
   svc keep-client-installed
   svc split include 6.6.6.0 255.255.255.0
default-group-policy DEFAULT_POLICY
aaa authentication list SSLVPN
aaa authentication domain SSLVPN
gateway SSLVPN_GATEWAY domain SSLVPN
inservice
!
end






Thanks!!!!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lrm001c474 Thu, 12/03/2009 - 12:19
User Badges:

Never mind, I found that I am missing an @ in the "aaa authentication domain SSLVPN" command.


Thanks anyways.

Actions

This Discussion