cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1537
Views
0
Helpful
7
Replies

MPLS TE tunnels doesn't come up after BGP arrived at the scene

Francis Garcia
Level 1
Level 1

Hi folks,

I was running a little lab where I had an mpls te tunnel running fine from one router located at the border of the network to the other, I was using ISIS as the IGP. Everything was fine untill I added BGP to the lab and suddenly the tunnel turn down. I want to know if I got to add an additional configuration to my PE routers to succesfully bring up my tunnel like before. My tunnel's explicits path were LSR-PE2 and LSR PE1. My topology looks like this.

                                 LSR

         eBGP         /               \          eBGP

ASx ------------ PE1 ----------------- PE2--------------ASy

                               iBGP

Thanks,

Francis.

7 Replies 7

Roman Rodichev
Level 7
Level 7

Please provide config of your PE1 and PE2

Regards,

Roman

ieMentor

Here I leave the configurations and I correct myself about the network topology, I added a pic about the exact topology too. The tunnel is built PE1-R1-R3.

PE1 - R0
!
clns routing
mpls label protocol ldp
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.201.0.0 255.255.255.255
ip router isis
!
interface Tunnel0
ip unnumbered Loopback0
tunnel destination 10.201.0.3
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 5 5
tunnel mpls traffic-eng bandwidth  1000
tunnel mpls traffic-eng path-option 10 explicit name te
no routing dynamic
!
interface FastEthernet0/0
bandwidth 100000
ip address 10.200.0.1 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 75000
ip rsvp resource-provider none
!
interface FastEthernet1/0
bandwidth 100000
ip address 10.200.0.5 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 85000
ip rsvp resource-provider none
!
interface FastEthernet2/0
ip address 190.80.239.1 255.255.255.252
duplex auto
speed auto
!
router isis
net 49.0123.0000.0000.0000.00
is-type level-1
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
!
router bgp 6400
no synchronization
bgp log-neighbor-changes
network 190.80.239.0 mask 255.255.255.252
neighbor 10.201.0.4 remote-as 6400
neighbor 10.201.0.4 password cisco
neighbor 10.201.0.4 update-source Loopback0
neighbor 190.80.239.2 remote-as 1630
neighbor 190.80.239.2 password cisco
no auto-summary
!
ip explicit-path name te enable
next-address 10.201.0.1
next-address 10.201.0.3
!
mpls ldp router-id Loopback0
********************************************
LSR- R1

!
clns routing
mpls label protocol ldp
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.201.0.1 255.255.255.255
ip router isis
!
interface FastEthernet0/0
bandwidth 100000
ip address 10.200.0.6 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
mpls mtu 1508
mpls traffic-eng tunnels
ip rsvp bandwidth 75000
ip rsvp resource-provider none
!
interface Serial1/0
bandwidth 1500
ip address 10.200.0.9 255.255.255.252
ip router isis
encapsulation ppp
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth 1200
ip rsvp resource-provider none
!
interface Ethernet2/0
bandwidth 10000
ip address 10.200.0.13 255.255.255.252
ip router isis
full-duplex
mpls label protocol ldp
mpls ip
mpls mtu 1508
mpls traffic-eng tunnels
ip rsvp bandwidth 7500
ip rsvp resource-provider none
!
router isis
net 49.0123.0000.0000.0001.00
is-type level-1
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
!
mpls ldp router-id Loopback0

************************************
LSR-R3

ip cef
no ip domain lookup
!
mpls label protocol ldp
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.201.0.3 255.255.255.255
ip router isis
!
interface Tunnel0
ip unnumbered Loopback0
tunnel destination 10.201.0.0
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 5 5
tunnel mpls traffic-eng bandwidth  1000
tunnel mpls traffic-eng path-option 10 explicit name te
no routing dynamic
!
interface FastEthernet0/0
bandwidth 100000
ip address 10.200.0.2 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 75000
ip rsvp resource-provider none
!
interface Serial1/0
bandwidth 1500
ip address 10.200.0.10 255.255.255.252
ip router isis
encapsulation ppp
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
isis metric 1677214
ip rsvp bandwidth 1200
!
interface Ethernet2/0
bandwidth 10000
ip address 10.200.0.14 255.255.255.252
ip router isis
full-duplex
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 7500
ip rsvp resource-provider none
!
interface FastEthernet3/0
bandwidth 100000
ip address 10.200.0.17 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
isis metric 1677214
ip rsvp bandwidth 75000
!
router isis
net 49.0123.0000.0000.0003.00
is-type level-1
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
!
ip explicit-path name te enable
next-address 10.200.0.13
next-address 10.201.0.0
!
mpls ldp router-id Loopback0
*********************************
PE2- R4

ip cef
no ip domain lookup
!
!
clns routing
mpls label protocol ldp
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.201.0.4 255.255.255.255
ip router isis
!
interface FastEthernet0/0
bandwidth 10000
ip address 10.200.0.18 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 75000
!
interface FastEthernet1/0
ip address 190.80.239.5 255.255.255.252
duplex auto
speed auto
!
router isis
net 49.0123.0000.0000.0004.00
is-type level-1
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
!
router bgp 6400
no synchronization
bgp log-neighbor-changes
network 190.80.239.4 mask 255.255.255.252
neighbor 10.201.0.0 remote-as 6400
neighbor 10.201.0.0 password cisco
neighbor 10.201.0.0 update-source Loopback0
neighbor 190.80.239.6 remote-as 36256
neighbor 190.80.239.6 password cisco
no auto-summary
!
mpls ldp router-id Loopback0

Hello Francis,

what happens if you use a dynamic path instead of the explicit path?

you can check with sh mpls traffic-eng tunnel 0 to see the reason why RSVP TE failed.

I remember setting up explicit paths using IP address on physical RSVP enabled interfaces, not the loopback interfaces IP addresses

Hope to help

Giuseppe

Hi Guislar,

I had tested using dynamic path and it's still the same.

About setting up explicit paths using IP loopbacks interfaces instead of physical RSVP enabled interfaces. I'm actually reading the book called "Traffic Engineering with MPLS" and in the book I did read that you can build TE tunnels using the TE Router-Id accros the explicith path instead of using the IP address on physical RSVP enabled interfaces, and It says that you can specify the interface in case that you have a multiple links connecting two routers and you want that you traffic use a link insted of other (I don't know if It is a mistake in the book). But anyways, I'll do it like that because I didn't test using the ip of the physical interfaces, but I as I said I was ok just untill BGP came to the scene.

Thanks

Francis

Hi Francis,

You are right- you can specify IP addresses of Loopback interfaces in Explicit-paths as long as they are reachable; this makes it easier to specify a path.

Anyways, you are trying to create an MPLS TE tunnel from a PE-router with tail-end router as a P-router. You need to make sure two things are done-

1) LDP is enabled on MPLS TE tunnel i.e. "mpls ip" command under Tunnel interface on PE-router.

2) following config on P-router-

    mpls ldp discovery targeted-hello accept from ACCEPT_FROM_SOURCE

    !

    ip access-list extended ACCEPT_FROM_SOURCE

     permit ip host

    !

    This will make sure the P router accepts the tunnel connection from PE router.

Let us know how you went after this.

HTH.

Regards,

Amit.

Hello,

BGP/MP-BGP should be configured before MPLS and MPLS-TE. This is to ensure that full NLRI is met and therefore your LSP's can be built and then manipulated with TE.

I believe in a modular approach when configuring such features or else you will be going back to your configs and adding configurations that you fell may solve your issue, but if not consistantly across the network devices can and will cause other issues that will be harder to troubleshoot.

I suggest you take off TE and MPLS LDP peering, configure BGP/MP-BGP and then put MPLS and TE back on.

HTH

Joe.

Hi,

Any update on this?

I also noticed that you're not setting the bgp router-id, you should definately do that. But like I said in my last post, take off MPLS and TE, put BGP on, verify thats working and routes passing, then put MPLS and TE back on.

Regards,

Joe.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: