SIP Caller-ID question

Unanswered Question
Dec 4th, 2009

My sip provider told me that they have verified my PSTN number number and would allow me to send that as my caller-id on the SIP trunk.

They said;

You may now pass the above caller ID using either of the following methods:

  • P-ASSERTED-IDENTITY
  • P-PREFERRED-IDENTITY
  • REMOTE-PARTY-ID

However, if I go into CCA > Configure > Telephony > Dial Plan > Outgoing > Caller-Id TAB

and set the 'alternate' number that they verified to be 'caller ID main PSTN number', it doesnt work.

Does the Cisco UC500 use one of the above methods?

If not, is there a way to force it to use one of those methods?

I havent tried to over-ride each and every internal number using the alternate, I suppose I could try that.

Thoughts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Maulik Shah Sat, 12/05/2009 - 16:31

The UC500 by default uses the FROM header for caller ID in the SIP INVITE. I will post a new template for you which has Remote Party ID enabled in the other thread we have.

Shaun Bender Wed, 07/28/2010 - 14:40

Is it possible to change the "From" header based on a per user or per DID basis?

bjames@snetworks.com Tue, 07/26/2011 - 19:04

Can i get this as I am seeing the users phone name when dialing out via SIP, the phone number is set right, but the name is the persons phone name.

I need to change this ASAP.

Thanks,

Bob James

Darren DeCroock Wed, 07/27/2011 - 06:47

Bob,

Try adding the following to your config though CLI:

conf t

  sip-ua

    calling-info pstn-to-sip from name set CISCO

Thank you,

Darren

bjames@snetworks.com Wed, 07/27/2011 - 06:59

Darren,

Thanks but in my case it's not a transfer from the PSTN; it's just a straight call going out SIP. The number is re-masked correctly, but the Text in the CallerID is the actual label on the phone.

Bob James

Darren DeCroock Wed, 07/27/2011 - 07:01

Bob,

I tested this on my lab unit, with just a straight call going out my SIP trunk..  CallerID name is changed to the setting you input with the command above.

Thank you,

Darren

Actions

Login or Register to take actions

This Discussion

Posted December 4, 2009 at 3:57 PM
Stats:
Replies:6 Avg. Rating:
Views:1951 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard