Can't Enable Port on 2940..why?

Unanswered Question
Dec 4th, 2009
User Badges:

Cisco Catalyst 2940-8TF, there are two fiber option 1. mtrj interface 2.sfp interface.

I have nothing plugged into the sfp gig port. The mtrj port always says disabled, but I can't seem to enable it. Why?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
sridsdale Sat, 12/05/2009 - 01:35
User Badges:

Have you told the switch that it is to use RJ45 and not the SFP slot for the interface?


I'm not familiar with the model in question but usually when you have multiple media types for one interface use need to set the media type, in this case:


int gig 0/1

      media-type rj45

glen.grant Sat, 12/05/2009 - 09:32
User Badges:
  • Purple, 4500 points or more

I agree it's usually a media type command , you have to choose one or the other , both cannot be live.

mlund Fri, 12/11/2009 - 01:39
User Badges:
  • Silver, 250 points or more

Hi


Have You tried to reload the switch.


What I can remember, if there is an sfp installed when switch boots up, it will use sfp port and disable mtrj.

The mtrj will be disabled even if You remove the sfp. If this is Your case, You have to reboot the switch


/Mikael

vaddison Wed, 04/21/2010 - 09:27
User Badges:

I had the opposite problem.  I used the MTRJ port and then tried to use the SFP which showed disabled.  Rebooting the switch worked.  Thanks for the tip.  Strange that you can't use the media-type command!

Leo Laohoo Fri, 12/11/2009 - 14:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Hi David,


I've got this model and I don't recall seeing a "media type" command for the SFP/MTRJ port.


During the bootup, can you check if the POST is successful or fail?


Also try the command "sh post".


If worst-comes-to-worst, just RMA the darn thing.

Actions

This Discussion