PPoE and MTU troubleshooting

Unanswered Question
Dec 5th, 2009

We are using a 836 router for connecting to the Internet via PPoE.


I recently introduced in our LAN a Vista workstation. The user of this workstation cannot download large files e.g. from Yoursendit service.


I switched the cisco router to the lousy free router that the ISP provider bundles with the connection and everything works like a charm!


After googling a lot for troubleshooting this, I believe my issue is related somehow this framentation of files. I have tried the following:


- Setting mtu size on the outside interface to 1492

- Setting ip tcp adjust to 1452 and 1350

- Setting Vista mtu size to 1492, 1452 and 1350

- Disabling Vista PMTDU discovery by including a registry DWORD EnablePMTUDiscovery

- Praying to Gods...


My issue must be related with some difference to default IP configuration which Vista introduced, because XP workstations are not experiencing the problem.


Any ideas on how to further troubleshoot this problem??

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ronit Bhattacharjee Sat, 12/05/2009 - 09:00

Hi,


Have you tried setting everything back to default and reducing the ip tcp-mss adjust on the "inside" interface? I use a cisco router myself and Windows 7 and I don't see any issues myself.

Giuseppe Larosa Sat, 12/05/2009 - 23:53

Hello,

read the following document about MTU issues


http://www.cisco.com/en/US/tech/tk827/tk369/technologies_white_paper09186a00800d6979.shtml



reducing the MTU on the outside interface if it is the internet facing interface has no effects.


We have seen in some remote sites when using IPSec+GRE over DSL that it is better to reduce the mtu of the lan interface.

In our case to values like 1300 bytes.


Hope to help

Giuseppe

messaritis Fri, 12/11/2009 - 07:27

Thanks for this reply.


I went throught the doc, but it assumes that GRE is enabled which is not the case in my configuration. I am just using static routing stating a default gateway.


Is there any other suggestion on how to pinpoint exactly the problem? For example, packet sniffing would help?


Thnks

Paolo Bevilacqua Fri, 12/11/2009 - 09:12

I would try:


interface Ethernet0

no ip virtual-reassembly

ip tcp adjust-mss 1452


interface Dialer0

default mtu

ip mtu 1492

no ip virtual-reassembly

no ip inspect


You can then optimize a lot ACL and other things, but that is unrelated.


Let us know.

messaritis Tue, 01/05/2010 - 07:23

Hi All and thanks for the help


I managed to solve the problem and I am sharing my solution to potentially help others


I troubleshooted on a packet level by activating a packet sniffing program and I discovered that the problem was that incoming packets were not getting received by the host. Thus I removed from my router all ispection and access list policy and problem was fixed.


John

Paolo Bevilacqua Tue, 01/05/2010 - 07:39

Thank you for sharing. Also fair would be to recognize the advice I gave you above:


no ip inspect

Actions

This Discussion