Setting up WAN routing for two external ip blocks

Unanswered Question
Dec 7th, 2009
User Badges:

I'm trying to install a new internet connection from a different ISP.  In the process we are also getting a new external IP subnet.  I would like to be able to route traffic on the new subnet via the new connection and anything on the old IP subnet through the old connection.  I tried setting up a route-map to catch traffic on the the F0/0 interface from the new subnet IP range and send it out F0/1.  I can see traffic matches for the access-list, but traffic doesn't appear to be routed correctly (can't ping anything outside).  The default route points out the Multilink1 interface. I need to be able to route both of our external subnet ranges so we can transition over our devices from one WAN connection to the other.


Am I missing something?  Is there a better way to accomplish this?


Here are the basics of my config:


interface multilink1

desc 2xT1 WAN link (old ISP 1)

ip address 65.xxx.85.74 255.255.255.252


interface f0/0

desc LAN interface

ip address 65.xxx.251.162 255.255.255.224

ip address 12.yyy.245.1 255.255.255.224 secondary   (new subnet)


interface f0/1

desc 20MB metro-ethernet (new ISP 2)

ip address 12.zzz.104.206 255.255.255.252


ip route 0.0.0.0 0.0.0.0 65.xxx.85.73


access-list 150 remark Match all traffic from new subnet

access-list 150 permit ip 12.yyy.245.0 0.0.0.31 any


route-map 20MB-opteman permit 150

match ip address 150

set interface FastEthernet0/1  (also tried "set ip next-hop 12.116.105.205")


interface FastEthernet0/0

ip policy route-map 20MB-opteman

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 12/07/2009 - 11:57
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

jplowick3 wrote:


I'm trying to install a new internet connection from a different ISP.  In the process we are also getting a new external IP subnet.  I would like to be able to route traffic on the new subnet via the new connection and anything on the old IP subnet through the old connection.  I tried setting up a route-map to catch traffic on the the F0/0 interface from the new subnet IP range and send it out F0/1.  I can see traffic matches for the access-list, but traffic doesn't appear to be routed correctly (can't ping anything outside).  The default route points out the Multilink1 interface. I need to be able to route both of our external subnet ranges so we can transition over our devices from one WAN connection to the other.


Am I missing something?  Is there a better way to accomplish this?


Here are the basics of my config:


interface multilink1

desc 2xT1 WAN link (old ISP 1)

ip address 65.xxx.85.74 255.255.255.252


interface f0/0

desc LAN interface

ip address 65.xxx.251.162 255.255.255.224

ip address 12.yyy.245.1 255.255.255.224 secondary   (new subnet)


interface f0/1

desc 20MB metro-ethernet (new ISP 2)

ip address 12.zzz.104.206 255.255.255.252


ip route 0.0.0.0 0.0.0.0 65.xxx.85.73


access-list 150 remark Match all traffic from new subnet

access-list 150 permit ip 12.yyy.245.0 0.0.0.31 any


route-map 20MB-opteman permit 150

match ip address 150

set interface FastEthernet0/1  (also tried "set ip next-hop 12.116.105.205")


interface FastEthernet0/0

ip policy route-map 20MB-opteman


What happens if you do a traceroute ? - do you see the packets going out the correct interface ?


Can you post full config of router ?


Jon

jplowick3 Mon, 12/07/2009 - 13:32
User Badges:

Nevermind.  I was able to figure it out.  I think it was just a typo in my route-map command.


Thanks though!

Actions

This Discussion