Call Terminates at Accept Step

Unanswered Question
Dec 7th, 2009
User Badges:

Hi,


Ive got a UCCX 7 box working with a CUCM6.0 in a lab environment to test new scripts for our production infrastructure. When im debugging the script the call is terminating on the Accept step. If i leave it the call will ring out but as soon as a step over to accept the call is gone. The CTI ports on the CUCM are configured ok but they show IP address of the CUCM as apposed to the UCCX like in our live environment. This cannot be the issue though because the call is sent to the trigger and delivered to UCCX to start the debug. Ive tried lots of things already like reinstalling, DNA etc but im a little lost now.


Does anyone have any ideas?


Regards


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ryan Mullins Mon, 12/07/2009 - 08:45
User Badges:

I have seen this on initially configured UCCX boxes, where the IP Address of the ports is wrong in CCM, but the CTI Route Points register with the proper IP Address of the UCCX server.  Usually restarting the engine on UCCX fixes this.  Your ports should show up as the IP Address of the UCCX server, not the CCM.


This would cause the behavior you describe.  The trigger is fired as it's registered with the correct IP Address, but answering the call fails, because CCM is using the wrong IP Address for the port when trying to connect the call and it's failing at that point.

gbljoba Mon, 12/07/2009 - 09:15
User Badges:

But if there were a CTI issue then CUCM would not pass the call to

UCCX and initiate the debug of the script right?


Looking at past problems i think it could be a codec issue. I will capture the MIVR log and post here.


/Jon

Ryan Mullins Mon, 12/07/2009 - 11:06
User Badges:

I've seen this on new installs of 7.x UCCX.  The first time the ports don't register with the correct IP Address, instead they show up as the IP Address of the CCM.  However, creating a CTI Route Point Trigger registers with the correct IP Address.  It's simple to see if this is what you're seeing.  Take a look at your CTI Ports and CTI Route Points and see if they all show with the same IP Address.


If they don't, then simply restart the UCCX Engine so that your ports all re-register and check them again.

gbljoba Tue, 12/08/2009 - 02:18
User Badges:

Hi Ryan,


Ive tried that and its still the same. I figure that the CTI ports must be ok to send the call to UCCX to trigger the script or maybe its having problems when its connecting the RTP stream....


In any case, ive attached my MIVR log for that period if anyone can decifer it.


Best wishes


Jon

gbljoba Tue, 12/08/2009 - 03:53
User Badges:

GOT IT!


Ive changed the codec in system perameters on UCCX to G729 as a noticed my CIPC was using it and it works!


Regards


Jon

gbljoba Tue, 12/08/2009 - 04:07
User Badges:

Hi Ryan,


No, the CTI ports are still pointing to the CUCM. Im just building a test v 7 box to see if this is any different. Ive deleted them, recreated them, sync'd them restarted the service but they still stay the same. From the call manager side im not too fussed now it is working. For now i need a working UCCX to build and test scripts for the exam and our production environment.


Thanks very much for your help.


Jon

Actions

This Discussion