bad CME upgrade. need help reflashing.

Unanswered Question
Dec 7th, 2009

i have read through some of the conversations i've uncovered about reflashing and it sounds pretty simple and straight forward. i'm hoping this will allow me to recover from a failed CME upgrade. since the upgrade, i can ping the UC, but cannot connect to it via CMA. the network topology said if found a NEW UC520 but won't allow me to connect to it. i can ping the IP, which appears to be a default IP, but no web management from the CME side. the strange part is the CUE still allows access to the web config to setup the CUE, but it says it cannot connect to the CME when you try to set it up. formatting the flash with FAT and moving the T2 file to the root of the flash drive will allow me to access and configure the UC, right?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Platts Mon, 12/07/2009 - 20:20

You want to be sure that your IOS image is located at the root of your flash memory. However, you should plug a console cable into the console port of your UC500 port, and be sure to do a no shutdown on your WAN and LAN interfaces. Be sure that your BVI interfaces or VLAN interfaces are configured correctly. Verify your configuration by doing a show run while connected to the UC500 unit with a console cable.

Here is an example LAN configuration for a UC520 or UC540 with Bridge Virtual Interfaces:

bridge irb
!
!
! This is the loopback interface used for Cisco Unity Express. This interface needs to not be
! not shutdown and configured appropriately for CUE.
!
!
interface Loopback0
description $FW_INSIDE$
ip address 10.1.10.2 255.255.255.252
ip access-group 101 in
ip nat inside
!
! This is the WAN interface on UC520 and UC540 units. It needs to be configured appropriately
! for your WAN connection. If static IP addresses are used, you need to specify the correct
! WAN IP address here.
!
interface FastEthernet0/0
description $FW_OUTSIDE$
ip address dhcp
ip access-group 104 in
ip nat outside
ip inspect SDM_LOW out
ip virtual-reassembly
duplex auto
speed auto
!
! This is the interface for your CUE module. It needs to have ip unnumbered Loopback0, which
! tells this interface to use the same IP address as that of the Loopback0 interface. It also needs
! to have the service-module ip address set to the IP address of the CUE module, which needs to
! be in the same subnet as the Loopback0 interface. The service-module ip default-gateway
! needs to be set to the IP address of the Loopback0 interface.
!
interface Integrated-Service-Engine0/0
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
! Below are example switchport configurations. Be sure that any switchports you are
! using are not shut down.
!
interface FastEthernet0/1/0
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/1
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/2
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/3
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/4
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/5
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/6
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/7
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/8
macro apply cisco-switch $native_vlan 1
!
! The interface Dot11Radio0/5/0 should only appear in your config if you have a UC520 or UC540
! unit with a built-in wireless point. Otherwise, it should not be in your UC520 configuration.
!
interface Dot11Radio0/5/0
no ip address
!
ssid uc520-data
!
ssid uc520-voice
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
! The interface Dot11Radio0/5/0.1 should only appear in your config if you have a UC520 or UC540
! unit with a built-in wireless point.
!
interface Dot11Radio0/5/0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
! The interface Dot11Radio0/5/0.100 should only appear in your config if you have a UC520 or UC540
! unit with a built-in wireless point, and you are using the built-in access point with SPA525G, 7921G,
! or 7925G phones. Otherwise, it should not be in your UC520 configuration.
!
interface Dot11Radio0/5/0.100
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 subscriber-loop-control
bridge-group 100 spanning-disabled
bridge-group 100 block-unknown-source
no bridge-group 100 source-learning
no bridge-group 100 unicast-flooding
!
! When BVIs are used, the BVI interface number, also known as the bridge group number, needs to be
! the same as the VLAN number.
!
! If you are using Bridge Virtual Interfaces, you must be sure that bridge-group 1, bridge-group 1 spanning-disabled
! and no ip address are specified for the Vlan1 interface. Be sure that this interface is not shut down.
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
! If you are using Bridge Virtual Interfaces, you must be sure that bridge-group 100, bridge-group 100 spanning-disabled
! and no ip address are specified for the Vlan100 interface. Be sure that this interface is not shut down.
!
interface Vlan100
no ip address
bridge-group 100
bridge-group 100 spanning-disabled
!
! Configure BVI1, which is the interface for VLAN 1 and Bridge Group 1
! Be sure that this interface is not shut down.
!
interface BVI1
description $FW_INSIDE$
ip address 192.168.10.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
!
! Configure BVI100, which is the interface for VLAN 100 and Bridge Group 100
! Be sure that this interface is not shut down.
!
interface BVI100
description $FW_INSIDE$
ip address 10.1.1.1 255.255.255.0
ip access-group 103 in
ip nat inside
ip virtual-reassembly
!
! Be sure that the route to your CUE module is in your configuration.
!
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
! If Bridge Virtual Interfaces are used, be sure that you have bridge 1 route ip,
! bridge 100 route ip, and similar lines for your other VLANs.
!
bridge 1 route ip
bridge 100 route ip
!

If you have a UC520 or UC540 with a wireless access point, you need to be sure that you have Bridge Virtual Interfaces configured for your VLANs on your UC520 or UC540 unit.

Here is an example LAN configuration for a UC520 without Bridge Virtual Interfaces (only on UC520 units that do not have a wireless access point):

!
!
! This is the loopback interface used for Cisco Unity Express. This interface needs to not be
! not shutdown and configured appropriately for CUE.
!
!
interface Loopback0
description $FW_INSIDE$
ip address 10.1.10.2 255.255.255.252
ip access-group 101 in
ip nat inside
!
! This is the WAN interface on UC520 and UC540 units. It needs to be configured appropriately
! for your WAN connection. If static IP addresses are used, you need to specify the correct
! WAN IP address here.
!
interface FastEthernet0/0
description $FW_OUTSIDE$
ip address dhcp
ip access-group 104 in
ip nat outside
ip inspect SDM_LOW out
ip virtual-reassembly
duplex auto
speed auto
!
! This is the interface for your CUE module. It needs to have ip unnumbered Loopback0, which
! tells this interface to use the same IP address as that of the Loopback0 interface. It also needs
! to have the service-module ip address set to the IP address of the CUE module, which needs to
! be in the same subnet as the Loopback0 interface. The service-module ip default-gateway
! needs to be set to the IP address of the Loopback0 interface.
!
interface Integrated-Service-Engine0/0
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
! Below are example switchport configurations. Be sure that any switchports you are
! using are not shut down.
!
interface FastEthernet0/1/0
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/1
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/2
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/3
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/4
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/5
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/6
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/7
macro apply cisco-phone $access_vlan 1 $voice_vlan 100
!
interface FastEthernet0/1/8
macro apply cisco-switch $native_vlan 1
!
! The Vlan1 interface, or the interface for VLAN 1, needs to be configured with the
! correct IP address and subnet mask.
!
interface Vlan1
description $FW_INSIDE$
ip address 192.168.10.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
!
! The Vlan100 interface, or the interface for VLAN 100, needs to be configured with the
! correct IP address and subnet mask. This VLAN is used for the phones.
!
interface Vlan100
description $FW_INSIDE$
ip address 10.1.1.1 255.255.255.0
ip access-group 103 in
ip nat inside
ip virtual-reassembly
!
!
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
!


Be sure to check the following on your UC520 or UC540 configuration:

  • Bridge Virtual Interfaces correctly configured if they are configured on your UC520 or UC540 unit
  • VLAN interfaces correctly configured on your UC520 or UC540 unit. This part of the configuration will be different if you are using bridge virtual interfaces.
  • CUE loopback interface correctly configured on your UC520 or UC540 unit
  • Integrated-Service-Engine0/0 interface, which is used by the CUE module, is correctly configured
  • WAN interface correctly configured
  • bridge route ip in your configuration for each VLAN, where is replaced with the bridge group number or VLAN number
  • All necessary interfaces are not shut down
  • Route to CUE module present
mlwartman Tue, 12/08/2009 - 08:41

here's what i have. i'm connected to the UC via terminal, show flash#

UC520#show flash
-#- --length-- -----date/time------ path
1          720 Dec 07 2009 19:48:28 vlan.dat
2     37988016 Dec 07 2009 19:58:24 uc500-advipservicesk9-mz.150-1.XA
3            0 Dec 07 2009 19:58:44 phones
4            0 Dec 07 2009 19:58:44 phones/7975
5      2935993 Dec 07 2009 19:59:24 phones/7975/apps75.8-5-3TH1-6.sbn
6       524876 Dec 07 2009 19:59:32 phones/7975/cnu75.8-5-3TH1-6.sbn
7      2100554 Dec 07 2009 20:00:06 phones/7975/cvm75sccp.8-5-3TH1-6.sbn
8       340615 Dec 07 2009 20:00:12 phones/7975/dsp75.8-5-3TH1-6.sbn
9      1887312 Dec 07 2009 20:00:42 phones/7975/jar75sccp.8-5-3TH1-6.sbn
10         650 Dec 07 2009 20:00:44 phones/7975/SCCP75.8-5-3S.loads
11         654 Dec 07 2009 20:00:44 phones/7975/term75.default.loads
12           0 Dec 07 2009 20:00:44 phones/7970_7971
13     2933329 Dec 07 2009 20:01:30 phones/7970_7971/apps70.8-5-3TH1-6.sbn
14      500084 Dec 07 2009 20:01:38 phones/7970_7971/cnu70.8-5-3TH1-6.sbn
15     2103754 Dec 07 2009 20:02:12 phones/7970_7971/cvm70sccp.8-5-3TH1-6.sbn
16      537925 Dec 07 2009 20:02:20 phones/7970_7971/dsp70.8-5-3TH1-6.sbn
17     1828410 Dec 07 2009 20:02:46 phones/7970_7971/jar70sccp.8-5-3TH1-6.sbn
18         650 Dec 07 2009 20:02:46 phones/7970_7971/SCCP70.8-5-3S.loads
19         654 Dec 07 2009 20:02:46 phones/7970_7971/term70.default.loads
20         654 Dec 07 2009 20:02:48 phones/7970_7971/term71.default.loads
21           0 Dec 07 2009 20:02:48 phones/7945_7965
22     2935993 Dec 07 2009 20:03:28 phones/7945_7965/apps45.8-5-3TH1-6.sbn
23      524969 Dec 07 2009 20:03:36 phones/7945_7965/cnu45.8-5-3TH1-6.sbn
24     2100804 Dec 07 2009 20:04:04 phones/7945_7965/cvm45sccp.8-5-3TH1-6.sbn
25      340615 Dec 07 2009 20:04:10 phones/7945_7965/dsp45.8-5-3TH1-6.sbn
26     1882934 Dec 07 2009 20:04:36 phones/7945_7965/jar45sccp.8-5-3TH1-6.sbn
27         650 Dec 07 2009 20:04:36 phones/7945_7965/SCCP45.8-5-3S.loads
28         654 Dec 07 2009 20:04:36 phones/7945_7965/term45.default.loads
29         654 Dec 07 2009 20:04:36 phones/7945_7965/term65.default.loads
30           0 Dec 07 2009 20:04:38 phones/7942_7962
31     2935993 Dec 07 2009 20:05:24 phones/7942_7962/apps42.8-5-3TH1-6.sbn
32      524917 Dec 07 2009 20:05:32 phones/7942_7962/cnu42.8-5-3TH1-6.sbn
33     2099070 Dec 07 2009 20:06:06 phones/7942_7962/cvm42sccp.8-5-3TH1-6.sbn
34      340615 Dec 07 2009 20:06:12 phones/7942_7962/dsp42.8-5-3TH1-6.sbn
35     1756328 Dec 07 2009 20:06:40 phones/7942_7962/jar42sccp.8-5-3TH1-6.sbn
36         670 Dec 07 2009 20:06:40 phones/7942_7962/SCCP42.8-5-3S.loads
37         674 Dec 07 2009 20:06:40 phones/7942_7962/term42.default.loads
38         674 Dec 07 2009 20:06:42 phones/7942_7962/term62.default.loads
39           0 Dec 07 2009 20:06:42 phones/7941_7961
40     2933329 Dec 07 2009 20:07:28 phones/7941_7961/apps41.8-5-3TH1-6.sbn
41      499644 Dec 07 2009 20:07:36 phones/7941_7961/cnu41.8-5-3TH1-6.sbn
42       32768 Dec 07 2009 20:08:58 phones/7941_7961/cvm41sccp.8-5-3TH1-6.sbn
43       21796 Dec 07 2009 20:28:20 UC520-16U-4FXO-K9-factory-8.0.0.cfg

55447552 bytes available (72736768 bytes used)

so i'm thinking i don't need to flash after all. perhaps the config is faulty, but i'm too new to cisco to know for sure. my show run is extremely long and shows configurations different from the default config you posted. of course, i'm not sure how to edit them. total cisco noob here. this project kinda fell in my lap and i'm the last person in line. lol

John Platts Tue, 12/08/2009 - 11:35

The show flash command appears to be good on your UC520 unit.

Here is what you need to do on the UC520 unit while connected with a console cable:

UC520#conf t

UC520(config)#interface FastEthernet0/0

UC520(config-if)#no shutdown

UC520(config-if)#interface Vlan1

UC520(config-if)#no shutdown

UC520(config-if)#interface Vlan100

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/0

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/1

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/2

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/3

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/4

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/5

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/6

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/7

UC520(config-if)#no shutdown

UC520(config-if)#interface FastEthernet0/1/8

UC520(config-if)#no shutdown

UC520#wr mem

Be sure to press CTRL+C to get out of config mode before you execute the wr mem command.

You should be able to connect to your UC520, and fix everything else in CCA after you do the above.

John Platts Tue, 12/08/2009 - 11:45

I have also noticed that you have some files missing from your UC520 flash memory. You will either need to use CCA and perform the upgrade again, or you will need to connect your computer to the UC520 unit, launch a FTP server, TFTP server, or Web server on your machine, and execute the archive tar /xtract flash: command, where is replaced with the actual FTP, TFTP, HTTP, or HTTPS URL of the UC520-Support-Files-8.0.0.tar file.

mlwartman Tue, 12/08/2009 - 12:18

you are right i was about to bring that up. i noticed it complaining about the files not being there during boot.

here's what's happening:

UC520#$ /xtract tftp://192.168.10.11/UC520-Support-Files-8.0.0.tar flash:
Loading UC520-Support-Files-8.0.0.tar from 192.168.10.11 (via Vlan1): !
Desktops/ (directory) -- unable to create (Can't create a file that exists)
extracting Desktops/CampusNight.png (131470 bytes)
extracting Desktops/CiscoFountain.png (80565 bytes)
extracting Desktops/CiscoLogo.png (8156 bytes)
extracting Desktops/Fountain.png (138278 bytes)
%Error writing flash:/Desktops/Fountain.png (TF I/O failed in data-in phase)
UC520#

the cca dashboard shows 52Mb free on the flash card. possibly a bad sector on the flash card?

John Platts Tue, 12/08/2009 - 12:49

It appears that you might actually have a defective flash card. I have never seen this error whenever I extracted the UC520 Support Files  or CME Support Files TAR file.

Other reasons that you might have the error are:

  • Corrupted UC520-Support-Files or CME-Support-Files TAR file
  • Problem with your TFTP server
John Platts Tue, 12/08/2009 - 12:54

You definitely have enough flash memory to extract the UC520-Support-Files-8.0.0.tar file. That file is around 5 MB in size.

mlwartman Tue, 12/08/2009 - 14:59

john, you are awesome. i'm not sure if i have a bad CF card or a bad image. using winrar, when i try to extract the archive or even view the contents, i get an error about a corrupt image. i remembered that i had extracted the files when i first downloaded the ios file, so i shut down the UC and put the CF card in my tech stations internal card reader. i was able to view the files without problem. when i tried to copy the files onto the CF drive i got 2/3 of the way through the copy, then the drive disappeared. i put the CF card back in the UC and it sees the new files that were copied. of course, not all the files were copied so i still have more work in front of me. i'm hoping that downloading another image of the IOS i will be able to tftp. i'm thinking the tftp sessions were failing because the tarball was corrupted.

John Platts Tue, 12/08/2009 - 15:11

I have noticed that an updated version of the UC520-8.0.0.zip file was posted on December 3rd. Did you actually download that version yet?

mlwartman Tue, 12/08/2009 - 15:58

i would have to say that i did, given that i downloaded it saturday. i can't recall 100% if the version date was dec3 or not. any known issues with that file? or perhaps issues opening the files with winrar that causes them to corrupt.

another idea: i would think this possible, can i copy the uncompressed files i have on my tech station to the uc from the uc console? much like the tftp archive extraction?

John Platts Tue, 12/08/2009 - 16:34

I have extracted the UC520-8.0.0.zip file, dated December 3rd, with 7-Zip without any problem. I was also able to extract the SCUE-UC520-7.1.3.zip file, the UC520-Phone-Loads-8.0.0.tar, and UC520-Support-Files-8.0.0.tar files successfully in 7-Zip. I know that CCA and IOS should be able to handle these files if they can be successfully extracted in 7-Zip.

7-Zip can be downloaded from http://www.7-zip.org.

mlwartman Wed, 12/09/2009 - 06:24

i'm not in the office on wednesdays, but i'll let you know tomorrow. i'm going to DL the image to the laptop i have attached to the console and try to use that system as the tftp server.

mlwartman Sat, 12/12/2009 - 09:53

the archive file was indeed corrupted. i think we may also have a cabling issue as the transfer from the tech pc was slow and ended up erroring out as before. from my laptop connected via console and ethernet, it transferred quickly and completely and i can again access all the functions on both sides of the UC.

thanks for the help john!!

Actions

This Discussion