CS-MARS-100 recent upgrade problem

Answered Question
Dec 8th, 2009

Hi all!

I have experienced problem with CS-MARS-100 appliance most recent upgrades. I've successfully upgraded it from 6.0.3 to 6.0.4 using csmars-6.0.4.3229.zip package. But when I've tried to use csmars-6.0.5.3358.zip package, I've recived an error message: "Failed to pass version dependence test". I've tried to do it from web-interface and from console, from FTP-server and from DVD-ROM, but was completely unsuccessful. By the way - when I used console, error message was slightly different, there was an additional information: csmars-6.0.5.3358.zip needs an 6.0.4.322.33 to successful upgrade, but csmars-6.0.4.3229.zip is only 6.0.4.322.32.

I can not find another versions of packages on http://www.cisco.com/cgi-bin/tablebuild.pl/cs-mars, so I can not upgrade my appliance to most recent version.

Please, explain me what does this mean and what can I do?

I have this problem too.
0 votes
Correct Answer by FREDRIK HABORN about 6 years 10 months ago

Found a solution to this problem today.

I got the tip that i would have to upgrade the ips sig:s from our support provider.

That didn't help thou, i couldn't upgrade to 6.0.5 in GUI.

Logged in to cli and fired of an pnupgrade with upgrade package 6.0.4.3229 (the same version running on the Mars at the time) it started and came out as 6.0.4.3229.33 from 6.0.4.3229.32, and from there on i upgraded to 6.0.5 in the gui.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
dustinsuko Tue, 01/05/2010 - 08:37

Have you tried re-downloading the file from Cisco? It's possible for the file to become corrupt during download.

Dustin

Correct Answer
FREDRIK HABORN Wed, 01/20/2010 - 13:00

Found a solution to this problem today.

I got the tip that i would have to upgrade the ips sig:s from our support provider.

That didn't help thou, i couldn't upgrade to 6.0.5 in GUI.

Logged in to cli and fired of an pnupgrade with upgrade package 6.0.4.3229 (the same version running on the Mars at the time) it started and came out as 6.0.4.3229.33 from 6.0.4.3229.32, and from there on i upgraded to 6.0.5 in the gui.

jennyjohn Mon, 09/06/2010 - 00:53

You can also install the 6.0.3 patch file (csmars-6.0.3.3190-customer-patch.zip) before installing the 6.0.4.

Even though patch file specifies that, "This upgrade is not in the required upgrade path" for 6.0.3 patch file. This looks like the way to go.

Actions

This Discussion