VRF-Lite and tagging

Unanswered Question
Dec 8th, 2009
User Badges:

Hi,


We are using VRF-Lite and BGP on a customer router, and trunking to a customer switch internally. We are seeing a very large routing table (in excess of 200k routes).


We are seeing an error message:


TAGCON-3-LCLTAG_ALLOC : Cannot allocate local tag


Which I understand is usually only seen when running MPLS, which we are not.


Even stranger, it is resolved by the 'tag-switching tag-range downstream 16 100000 0' (now deprecated).


I notice that the output of 'show tag-switching forwarding-table ..' shows each route being allocated an internal tag.


Can anyone explain why these tags are being assigned?


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 12/08/2009 - 06:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ken,

you haven't provided much details.


What model is the customer router and what IOS is running on it?


You may have configured the device as you say for VRF lite but it may be trying to assign an MPLS label or older name tag to each prefix in the routing table


another way to solve this would be to use an ACL to decide for what prefixes a tag has to be allocated


something  like

no tag-switching advertise-tags

tag-switching advertise-tags for ACLname


the device thinks it is a full PE node.


Hope to help

Giuseppe

ken.vance Tue, 12/08/2009 - 06:58
User Badges:

Hi Guislar,


for further info:


Cisco 3845
IOS: c3845-spservicesk9-mz_124-19b

ip cef
ip vrf DIA
rd 29000:1
!
interface GigabitEthernet0/0.10
description customer Lan Office

encapsulation dot1Q 10
ip address XXXX  XXXX
no cdp enable
!
interface GigabitEthernet0/0.11
description customer LAN internet

encapsulation dot1Q 11
ip vrf forwarding DIA
ip address XXXX  XXXXX
no cdp enable
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1.38
encapsulation dot1Q 38
ip address XXXXXXX mask XXXXXXX
no cdp enable
!
interface GigabitEthernet0/1.40
encapsulation dot1Q 40
ip vrf forwarding DIA
ip address XXXXXX  mask XXXXXXXXX
no cdp enable
!
router bgp XXXXX
no synchronization
bgp log-neighbor-changes
network XXXXXXX mask XXXXXX
network XXXXXXX mask XXXXXX
network XXXXXXX mask XXXXXX
neighbor XXXXXX remote-as XXXX
neighborXXXXXX  version 4
default-information originate
no auto-summary
!
address-family ipv4 vrf DIA
  neighbor XXXX remote-as XXXX
  neighbor XXXX version 4
  neighbor XXXX activate
  no synchronization
exit-address-family
!

The 'safe' parts of the config.

Okay, its not a real fault, more interested in why the internal tags are being assigned in the first place.


Does anyone have any ideas?

Giuseppe Larosa Tue, 12/08/2009 - 10:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ken,

the explanation can be as simple as a default settings.


it  is enough  that mpls ip/tag-switching ip is enabled by default in global mode to lead the device to start allocating labels.


IOS: c3845-spservicesk9-mz_124-19bip cef


if so you just need


conf t

no mpls ip


or

no tag-switching  ip


to free resources.


see


Defaults

Label switching of IPv4 packets along normally routed paths is enabled for the platform.


http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_m1.html#wp1013428


Hope to help

Giuseppe


Actions

This Discussion