No audio - CIPC over VPN

Unanswered Question
Dec 8th, 2009
User Badges:

I'm testing with two Cisco IP Communicator clients on the same CUCM 7.1.3 server. Getting a mixed bag of results:

CIPC over VPN to external numbers - works successfully

CIPC over VPN to VM - works intermittently. I can always dial my VM pilot and initially (right after software client starts) I can call VM, hear messages, etc. Usually after one or two successful tests, I can no longer hear any audio. I just see the call being established but no audio.

CIPC over VPN to internal extensions (other on-net IP phones) - Phones ring but no audio either way

CIPC over VPN to CIPC over VPN - I can initiate calls between the two clients but there is no audio either way (same as above).

CIPC internally (on-net) to external calls and on-net IP phones - works successfully

My audio network setting are set to the VPN adapter (attached) and I'm configured to use g.729 (optimized for low bandwidth).

Any ideas or where to start?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Udit Mehrotra Tue, 12/08/2009 - 18:56
User Badges:
  • Cisco Employee,


Looks like routing issue to me.

Since you are ablle to dial out to PSTN that means that there is a route present to Gateway''sIP.

Things to check -

1. IP of CIPC behind VPN.

2. Subnet of IP Phones - Voice VLAN.

3. CM IP

4. Gateway's IP

All the above subnets or IP should be routable to each other.

Since the calls to IP Phones have one way audio, so a good point to start would be to try to ping a hard hone on the computer on which CIPC is installed.

Also, if IP routing is set up correctly, try taking a sniffer capture from the CIPC PC and see the behavior of RTP stream.

The routing paths for Call Siganling and RTP(voice) arem different, that is why you see that call gets connected but there  is no voice.


mightyking Tue, 12/08/2009 - 20:07
User Badges:

This is a VPN problem.  Make sure your VPN allows ip packets to flow between the two remote endpoints.  In order to make direct connection btw two endpoints, you need to explicitly allow this ability in your VPN.



This Discussion