LMS 3.1 supported OS

Answered Question
Dec 8th, 2009

Hi,

I have LMS 3.1 and Windows 2008 OS, I am not able to install LMS 3.1 on Windows Server 2008.

Can anyone help me what is the work around for this issue, and if Windows 2008 is not a supported OS for LMS 3.1, can we upgrade to LMS 3.1 to LMS 3.2 without any cost if LMS 3.2 supports Windows 2008 as OS.

Rgds,

Kamal Singh

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 6 years 11 months ago

This sounds like CSCtd18854.  There is a patch available from TAC which corrects this, but you must make sure TCP port 42340 is not currently used by some other process.  You can do this by running "netstat -a -n -o -b", and checking to make sure you don't see tcp/42340 with a process in the LISTENING state.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 12/08/2009 - 22:14

LMS 3.1 does not support Windows 2008.  LMS 3.2 does support Windows 2008, and you can upgrade without any cost.  You can download the LMS 3.2 eval which can be installed using the LMS 3.1 license to produce a fully-licensed LMS 3.2.  The eval can be downloaded from http://www.cisco.com/go/lms.

kamallohiaji Sat, 12/12/2009 - 23:25

HI Joe,

Thanks for your support,I have installed LMS 3.2 on Win 2008 Eneterprise Edition now but after the installation Daemon Manager Service is not starting, I am able to start other services but we I go to Common Service > Server > Process, I don see any running process there.

When I try to start the Daemon Manager Service manually, I get the following messege :

"Windows could not start the daemon service on local computer. Error 1053 : The service didn't respond to start or control request in a timely fashion."

Earlier I thought this problem could be because of SP2 on Win2008 server as I read on this forum that SP2 is not supported, than I uninstalled the SP2 and reinstall LMS 3.2 from starting but again I have having the same problem.

Pls let me know what s the workaround of this problem.

Regards,

Kamal

Joe Clarke Sun, 12/13/2009 - 11:15

SP2 is now supported.  However, you must first manually configure swap before LMS will start.  Go to the system control panel, and allocate at least 2048 MB of swap with a maximum of the required amount based on the number of devices you will be managing.  After making the required swap changes, reboot, and LMS will start up.

kamallohiaji Sun, 12/13/2009 - 21:03

Hi Joe,

I have changed the paged file size and set it to minimum 8 Gb and expandable upto 16GB. After this I rebooted the box. After reboot the service is still not starting but now it is not giving any error code. Now on starting the service the message which shows up says, " The CiscoWorks Daemon Manager Service on local computer started and then stopped. Some services stop automatically if they are not in use by other services or program".

Please suggest.

Attachment: 
Joe Clarke Mon, 12/14/2009 - 07:46

What errors do you see in the Windows Event Viewer?  What errors do you see in the NMSROOT/log/syslog.log?

kamallohiaji Mon, 12/14/2009 - 10:38

Hi Joe,

Pls find the attached syslog file. I am getting the following mssg :

Dec 14 23:45:51 127.0.0.1 dmgtd: PX_PROTOCOL in registry http
Dec 14 23:45:51 127.0.0.1 dmgtd: Apache Args in registry -d C:\PROGRA~2\CSCOpx\MDC\Apache
Dec 14 23:45:51 127.0.0.1 dmgtd: PX_PROTOCOL in md.properties file is http
Dec 14 23:45:51 127.0.0.1 dmgt[7728]: 2009(W):System Error: The Daemon Manger cannot bind to port:42340 System Error: The Daemon Manger cannot bind to port:42340 %s.  The TCP port:42340 that the Daemon manager expects to use is not available. Call your technical support representative for assistance..  The TCP port:42340 that the Daemon manager expects to use is not available. Call your technical support representative for assistance.

I am not getting the follwing messege in Windows Event Viewer:

Informational : CRMDmgtd started.

Rgds,

Kamal

Attachment: 
Correct Answer
Joe Clarke Mon, 12/14/2009 - 13:10

This sounds like CSCtd18854.  There is a patch available from TAC which corrects this, but you must make sure TCP port 42340 is not currently used by some other process.  You can do this by running "netstat -a -n -o -b", and checking to make sure you don't see tcp/42340 with a process in the LISTENING state.

Igor Ivanov Mon, 01/18/2010 - 07:50

Joe hello, can you give me this patch, please. I'm unable to find it.

Joe Clarke Mon, 01/18/2010 - 12:18

You must open a TAC service request to get the patch.  Code cannot be posted on the forum.

Actions

This Discussion