Cisco works LMS 3.0.1 does not archiever configuration for cisco 7201 router

Unanswered Question
Dec 9th, 2009
User Badges:

Hi All,


We have Cisco works LMS 3.0.1 and it does not archiever configuration for cisco 7201 router.


Any help would be appriciated.


Thanks in advance


Samir

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 12/09/2009 - 20:33
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What error do you get trying to sync the configuration from the 7201?  What version of the RME Rtr7000 package do you have loaded?

samir_1976 Thu, 12/10/2009 - 06:55
User Badges:

Hi,



*** Device Details for d0151-100 ***
Protocol ==> Unknown / Not Applicable
Selected Protocols with order ==> TFTP,SSH,HTTPS
Execution Result:
Unable to get results of job execution for device. Retry the job after increasing the job result wait time using the option:Resource Manager Essentials -> Admin -> Config Mgmt -> Archive Mgmt ->Fetch Settings



This is the error while doing syn archieve.


I am not sure about Rtr7000 version but we have latest Rtr7000.


Waiting for your kind reply.

Samir

Joe Clarke Thu, 12/10/2009 - 09:45
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This error could point to a known bug.  In order to properly troubleshoot it, a full thread dump of the ConfigMgmtServer process is required.  Contact TAC, and they will walk you through getting this thread dump.  As a workaround, try restarting the ConfigMgmtServer process, then try collecting the config for the 7201 alone.  Use the following commands to restart ConfigMgmtServer:


pdterm ConfigMgmtServer

pdexec ConfigMgmtServer


Alternatively, all known issues with config fetch causing loops within ConfigMgmtServer have been fixed in LMS 3.2.  You can try upgrading, and see if this problem goes away.

samir_1976 Thu, 12/10/2009 - 12:54
User Badges:

Hi ,


Before this works fine but we changed firewall in between our ciscoworks server and router.


So what are things we need to check on firewall.


Waiting for your kind reply.


Samir

Joe Clarke Thu, 12/10/2009 - 14:06
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The error you are showing does not point to a firewall issue, but RME will use one of either SNMP/TFTP, telnet, or SSH to fetch the config from a 7201.  It depends on the protocol order you have configured under RME > Admin > Config Mgmt > Transport Settings.


For SNMP/TFTP, you need to make sure that udp/161 is open between device and server as well as udp/69, and all ephemeral UDP ports.


For telnet, you need tcp/23 open between device and server.


For SSH, you need tcp/22 open between device and server.

rana.samir Tue, 03/09/2010 - 10:21
User Badges:

Hi,


Right now we are allowing all mentioned port from our ciscoworks server to cisco router.


Nothing is blocked.


Waiting for your kind reply.


Samir

Joe Clarke Wed, 03/10/2010 - 10:01
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I have nothing new to add.  If you've ruled out a problem in the firewall, then my previous post about restarting ConfigMgmtServer, or upgrading to LMS 3.2 still stand.

rana.samir Thu, 03/18/2010 - 12:28
User Badges:

Hi,


Thanks for your reply.


But I have one question for you.


We are using TACAS and securid ( which change every minute ) authentication to login to this router.


Does this affect to fetch config through SNMP/TFTP, telnet or ssh ?


Waiting for your kind reply.


Thanks,


Samir

Joe Clarke Fri, 03/19/2010 - 11:18
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This would not affect config archive if it is done via SNMP/TFTP.  However, it will break config archive if done via telnet or SSH.  You will get errors about not being able to authenticate with the device (because the credentials are constantly changing).

Actions

This Discussion