Serial connection refuses to work

Unanswered Question

Hi everyone

I have a 2514 router attached to a cable modem and a serial connection over optic fiber

I´m trying to connect both the cable and the serial to the internet

The cable modem is connected ok, but the serial refuses to work (it did before)

This is the tech specs of the router:

Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-IS-L), Version 12.0(28c), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 30-Mar-05 16:33 by pwade
Image text-base: 0x0303E2D4, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (fc1)

189-57-241-178 uptime is 19 hours, 52 minutes
System restarted by reload
System image file is "flash:c2500-is-l.120-28c.bin"

cisco 2500 (68030) processor (revision L) with 6144K/2048K bytes of memory.
Processor board ID 05689092, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
2 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

This is the running config:

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable password abc123ab
!
ip subnet-zero
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface Ethernet1
ip address 201.17.6.16 255.255.255.0
no ip directed-broadcast
ip nat outside
!
interface Serial0
ip address 189.57.241.178 255.255.255.252
no ip directed-broadcast
ip nat outside
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
ip nat inside source list 101 interface Ethernet1 overload
ip nat inside source list 102 interface Serial0 overload
ip nat inside source static tcp 192.168.1.21 65000 201.17.6.16 65000 extendable
ip nat inside source static tcp 192.168.1.21 5060 201.17.6.16 5060 extendable
ip nat inside source static tcp 192.168.1.21 110 201.17.6.16 110 extendable
ip nat inside source static tcp 192.168.1.21 25 201.17.6.16 25 extendable
ip nat inside source static tcp 192.168.1.21 21 201.17.6.16 21 extendable
ip nat inside source static tcp 192.168.1.21 80 201.17.6.16 80 extendable
ip nat inside source static tcp 192.168.1.21 65003 201.17.6.16 65003 extendable
ip nat inside source static tcp 192.168.1.199 65000 201.17.6.16 65000 extendable

ip nat inside source static tcp 192.168.1.21 8080 201.17.6.16 8080 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 201.17.6.1
ip route 0.0.0.0 0.0.0.0 189.57.241.177
!
!
ip access-list extended WebServer
permit tcp any host 201.17.6.16 eq www
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
!
line con 0
login
transport input none
line aux 0
line vty 0 4
login

The IPs  201.17.6.16 and 189.57.241.178 are fixed and belong to me.

The lan computers are like this: IP 192.168.1.199 mask 255.255.255.255 gateway 192.168.1.1

If I unplug the cable modem I can still ping whatever I want in the router, but not in the lan computers.

Anything you see wrong in the configuration? Thanks! 

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Wed, 12/09/2009 - 20:07

Are you trying to make serial connection to the cable mode?  If you want to make a back-to-back serial connection, you will need a DTE/DCE cable to do that. Then you have to clock the DCE site of the connection.  Are you sure that the cable modem has a serial port on it?

BTW, the Ethernet ports on the 2500 series router are only 10M.

HTH

Reza

ohassairi Wed, 12/09/2009 - 21:01

when you make show interface serial 0, is it up / up?

what is the test that you r making and that gives s0 refuses to work?

Giuseppe Larosa Thu, 12/10/2009 - 12:35

Hello Galonga,

regardless of how old is your router I think the problem is in your NAT configuration.

What about dividing the internal private network in two halfs having one natted over the serial and one natted over the ethernet connected to the cable modem?

I think that if you help the router to solve this NAT dilemma you will be able to have some users going to internet using  one link and other ones using the other link.

Hope to help

Giuseppe

Paolo Bevilacqua Thu, 12/10/2009 - 10:24

multiple as in cable, fiber, and internal LAN with a 12+ years old router.

You are not being very realistic. Honest.

Actions

This Discussion