PXE Issues - HELP please

Unanswered Question
Dec 9th, 2009

We are having some difficulties using PXE in our Cisco environment.  Currently, we are in the process of setting up Micorsoft Comfig Manager to deploy images.   All devices are connected via Catalyst 6509E with multicast routing enabled. We have our DHCP server setup up in vlan 100.  Our PXE server and workstations to be imaged are setup in VLAN 180.  Portfast is configured on all ports connecting to machines.  IP helper adress is configured on vlan 180 to point to our dhcp server.  When PXE boot is initiated on workstation in vlan 180, network boot immediately fails with "media dsconnected" error message.  However, when booting to removable media, workstation pulls dhcp address and finds PXE server to image workstations.

Is there anything on the switch that needs to be configured for network boot to work?  I do not know much about configuration of PXE on switches.  Can someone point me in the right direction?  Thanks in advance.

Drawing1.jpg

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Wed, 12/09/2009 - 15:27

Hi,

In the BIOS of your PC have you enabled boot to network?

Have you configured your NIC to be the first in boot sequence?

Does you PC support PIX booting?

Can you post sh run from the 6500 switch?

HTH

Reza

bwilloby46 Wed, 12/09/2009 - 16:24

Yes, network boot is configured and set in Bios as #1.

I will give you the configs for my vlans & ints but the config for our 6509 is rather large.

(IP ADDRESS ARE FOR EXAMPLE ONLY)

ip multicast-routing

int vlan 100

description << DNS & DHCP SERVERS >>

ip address 192.168.100.1 255.255.255.0

ip flow ingress

int vlan 180

description << SYSTEMS MANAGER >>

ip address 192.168.180.1 255.255.255.0

ip helper-address 192.168.100.25 (DHCP Server Address)

ip flow ingress

interface fa X/X (interface connected to desktop to be imaged)

switchport

switchport mode access

switchport access vlan 180

spanning-tree portfast

interface g X/X (interface connected to Microsoft Configuration Manager containing PXE Boot manager - IP 192.168.180.30)

switchport

switchport mode access

switchport access vlan 180

speed 1000

duplex full

spanning-tree portfast

interface g X/X (interface connected to Microsoft DHCP Server - IP 192.168.100.25)

switchport

switchport mode access

switchport access vlan 100

speed 1000

duplex full

spanning-tree portfast

What am I missing for PXE?   Thanks.

Reza Sharifi Wed, 12/09/2009 - 18:12

By default PXE boots from native vlan (vlan 1) since you assign vlan 180 on the switch site, Is there any way to set the config manger server to vlan 180 on the server itself, or change vlan 180 on the switch to VLAN 1 to see if you can boot?

Reza

bwilloby46 Thu, 12/10/2009 - 06:45

If you read above, the config manager is in the 180 vlan.  No, i am not moving anything into vlan 1 in a production environment.  Vlan 1 is shutdown anyway in our infrastructure.  Best practice.

Reza Sharifi Thu, 12/10/2009 - 06:54

I am not suggesting that you should use vlan 1 in production. (I know that is bad practice) I was under the impression that you are testing this in lab environment.

I know you have configured vlan 180 on the switch, but is there a way to assign vlan 180 to the server too and test?

Bradley Edgeworth Thu, 12/10/2009 - 08:31

Comparing the SCCM bootable media to PXE boot is not fair.   The bootable media boots WinPE (Vista-mini) and then uses normal process to connect to your SCCM server. 

The problem is not on your Cisco config.    When your SCCM server is not your DHCP server, or it is on a different subnet, you need to an option 66 with your SCCM server's IP.

The other way that might work, is if you pointed your helper-address to a broadcast address:

ip address 192.168.180.255

But I haven't tested and would not recommend it.

bwilloby46 Thu, 12/10/2009 - 12:25

Comparing them helps to rule out the issues of whether dhcp and/or PXE is causing the issue.  I have resolved the issue.  The configuration of PXE and WDS on Config Manger server were interferring with each other.  Just reinstalled the roles.  Thanks for the recommendations.

lveraza2010 Fri, 02/12/2010 - 10:52

Hi !, what did you do exactly for fixing ?, who is your DHCP server ?. What configuration the DHCP server is using ?.

Actions

This Discussion