High CPU on Catalyst 6500

Unanswered Question
Dec 9th, 2009

About 1 to 2 hours ago my core switch CPU shot up to 100%. No config changes were made. Attached are the processes that are taking up the CPU, it is not just the iso-base like the other posts about High CPU. What does name_svr, inetd, and the tcp.proc do? What steps other than rebooting can I do to track this down? I have already opened a TAC case but I was hoping to see if someone here could shed some light.

Thanks,

Mike

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Reza Sharifi Wed, 12/09/2009 - 15:53

Hi Mike,

What version of IOS are you using?

Have you performed any IOS upgrade lately?

can you post the entire show proc cpu instead of a subset?

Reza

husamaga1 Mon, 05/18/2015 - 02:02

Well i had this issue fixed by changing the setup! it was wrong setup, so it's not just turn on the multicast routing and it will work..  IOS upgrade will not help with this issue.. already try it..

you need to make a new setup..

Regards

 

burleyman Wed, 12/09/2009 - 16:43

I found the issue. I ran a show tcp brief and found some hung sessions. I cleared them and the CPU is back to normal. Thank you for you help.

Mike

Reza Sharifi Wed, 12/09/2009 - 17:17

Glad you got it fixed

I see these two processes eating up about 60% of the CPU

16427    27.9%   25.8%    26.0% inetd.proc                   
16428    36.0%   32.9%    33.2% tcp.proc

Reza

Giuseppe Larosa Wed, 12/09/2009 - 22:43

Hello Mike,

thanks for your feedaback it can help somebody else with same issue

As a comment it looks like that modular IOS on 6500 is more exposed to high cpu events taking in account the threads in the forums.

Best Regards

Giuseppe

burleyman Thu, 12/10/2009 - 05:25

I did notice a lot of issues posted with the ISO-BASE process using up all the CPU but this was not the case this time. As a side note this could be a new bug because while I was working with Cisco TAC he said this is the second case he a worked recently with the same exact issue where the sessions were hanging and not clearing like they should, and he thinks there may have been other but he was not sure. He is escalating it and I will try and remember to post what I find out for others. If anyone reading this has seen the same issue please report it to Cisco TAC so they can add that to the list.

Thanks for everyones help.

Mike

thegrave2000 Wed, 12/23/2009 - 23:52

Same story on 12.2(33)SXH3a here. If it's not that it's the ios-base process that eats up my cpu. I cleaned a thousand of L2 and L3 loops already but I'm pretty sure there are other reasons behind this behaviour as well. Please update us if TAC confirms it's a bug.

P.S. Got no Partner access at the moment so I can't report them my case.

burleyman Fri, 02/12/2010 - 07:22

Nothing on the bug issue. I still continue to have issues. Here is what I have going on maybe you can check yours as well on this. The switch runs fine until I telnet into the switch, any program. As soon as I telnet in the CPU starts on its way up to 100% and stays there. I have to then console into the switch and clear tcp tcb sessions and then it goes back down to normal. This all of a sudden started out of nowhere and I am not sure why. I have opened a TAC case a few weeks back but they recommend updating the IOS but I can't do that for sometime. Does anyone out ther know what the name_srv.proc is and what it does?

Thanks,

Mike

Giuseppe Larosa Fri, 02/12/2010 - 08:26

Hello Mike,

only IOS developers can provide a definitive answer.

However, given the name name_srv.proc we can guess it might be related to DNS.

if so disabling name lookup could be of help

conf t

no ip domain-lookup

Take it as just a guess

Hope to help

Giuseppe

burleyman Fri, 02/12/2010 - 13:20

That is what I thoguht it might be based on the name. I am going to see if your suggestion helps.

Thanks,

Mike

Marcellopisano23 Mon, 05/18/2015 - 01:49

Good morning burleyman, 

I noted that this is an old post, but I have the same problem.

Did you fix this issue with upgrade ? or did you find another method to solve ? 

Now on my device CPU is low but I can't access to it... 

Thank you!
 

Actions

This Discussion