Problem setting up l2tp/ipsec vpn

Answered Question
Dec 9th, 2009

I've been trying to setup an ASA5505 with an l2tp/ipsec vpn that I can connect to with the Windows Vista vpn client. I've been having problems connecting. When I attempt to connect, the windows vpn client shows an error message saying "Error 789: The L2TP connection attempt failed because the security layer encountered a processing error during initial negotiations with the remote computer." The log on the ASA shows errors saying "Phase 1 failure: Mismatched attribute types for class Group Description: Rcv'd: Unknown Cfg'd: Group 2"

It appears that the ASA does not like the IKE proposal from the windows vpn client but i'm not sure if I'm interpreting that error message correctly.

Wondering if anyone has seen this issue or had success with this kind of setup. I have the device setup OK so that I can connect with the Cisco VPN client but getting the l2tp/ipsec setup to work with the windows vpn client is proving to be problematic.

I have this problem too.
0 votes
Correct Answer by ankaushi about 6 years 10 months ago

Can you post the Config of your ASA. Have you checked the following link:

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
mathew_tyler Thu, 12/10/2009 - 12:53

Thanks for the reply. I hadn't seen that page. I was working off of this one,

I finally got it working today. I had to modify the isakmp policy and the transform sets on the ASA to match one of the proposals that was sent by the Windows vpn client. After making those changes and working through a couple other issues that came up everything is working as expected now.

muranskycotech Thu, 12/10/2009 - 16:04

Which ISAKMP policy and transform sets did you end up using? I've been fussing with this for a couple weeks now and haven't been able to find a winning combination. Do you mind posting your config?

mathew_tyler Thu, 12/10/2009 - 16:29

No problem, here is the config,

hostname asa5505

interface Vlan1
nameif inside
security-level 100
ip address
interface Vlan2
nameif outside
security-level 0
ip address ***.***.***.***
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
boot system disk0:/asa821-k8.bin
ftp mode passive
dns server-group DefaultDNS

access-list incoming extended permit icmp any any
access-list nonat extended permit ip any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool vpnpool
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-623.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1
access-group incoming in interface outside
route outside ***.***.***.*** 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set l2tp-transform esp-3des esp-sha-hmac
crypto ipsec transform-set l2tp-transform mode transport
crypto ipsec transform-set vpn-transform esp-aes-256 esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map dyn-map 10 set transform-set l2tp-transform vpn-transform
crypto dynamic-map dyn-map 10 set reverse-route
crypto map vpn-map 10 ipsec-isakmp dynamic dyn-map
crypto map vpn-map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 28800
crypto isakmp policy 15
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh inside
ssh timeout 20
console timeout 0
l2tp tunnel hello 100
dhcpd auto_config outside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol l2tp-ipsec
group-policy vpn-policy internal
group-policy vpn-policy attributes
vpn-tunnel-protocol IPSec
username radmin password ***************** nt-encrypted privilege 0
username admin password ***************** encrypted privilege 15
username admin attributes
vpn-group-policy vpn-policy
tunnel-group DefaultL2LGroup ipsec-attributes
isakmp keepalive threshold 15 retry 2
tunnel-group DefaultRAGroup general-attributes
address-pool vpnpool
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key **************
isakmp keepalive disable
tunnel-group DefaultRAGroup ppp-attributes
authentication pap
no authentication chap
authentication ms-chap-v2
tunnel-group DefaultWEBVPNGroup ipsec-attributes
isakmp keepalive threshold 15 retry 2
tunnel-group vpntunnel type remote-access
tunnel-group vpntunnel general-attributes
address-pool vpnpool
tunnel-group vpntunnel ipsec-attributes
pre-shared-key ************
isakmp keepalive threshold 15 retry 2
class-map inspection_default
match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
service-policy global_policy global
prompt hostname context


This Discussion