IP Phone Proxy strange audio issue

Unanswered Question
Dec 10th, 2009

We have setup the IP phone proxy on our ASA-5520, we had a couple of issues with the initial setup, but nothing major. It has been up and running for a few weeks and basically everything works perfectly just like we designed it except for 1 strange audio issue on outbound calls. We can make a call to anywhere, no problem, if the call is answered, no problem, perfect call setup and good quality 2 way audio. But if the person we called doesn't answer the call and that call goes to their voicemail we loose all audio from that point forward, we do not hear their outgoing message or get any prompts just dead air. The same situation appears to be true for any "recorded" service on the other end of the call.

If anyone has heard of this issue or can offer some troubleshooting guidance, it would be greatly appreciated.      

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Panos Kampanakis Mon, 12/14/2009 - 06:49

If the VM or recorded audio is not coming from the inside phone that is ringing the phone proxy does not have a session

established for it so it will not allow it through.


I do not know your exact setup.

Please do a packet capture to catch the RTP stream and see where it is coming from. The capture should be from anything to the inside MTA and done on the ASA inside interafce. How to do the capture is also explained here supportforums.cisco.com/docs/DOC-1222. Syslogs would help too.

I hope it helps.

PK

tostevens Thu, 01/07/2010 - 10:57

I either don't understand your response exactly or perhaps I didn't explain the issue well enough

From the Cisco phone that is connected via the proxy sessions, we pick up hear dialtone, dial 9 and make a call to an outside 3rd party using the area code and phone number via PSTN (PRI). The call sets up and goes through normally just like any other call, we hear the phone ringing on the other end through the ear piece, after 4-5 rings the person doesn't answer and the call goes to their voice mail. It's at that point we get dead air, we dont hear their outgoing message, etc.   

Kureli Sankar Thu, 01/07/2010 - 16:38

So, if the same person answers then, you hear audio both ways? But, when the person does not answer then, you don't hear the greetings for you to leave a message?

Could you pls. do a quick test and tell me if you dial an incorrect extenstion from a proxy phone do you hear the

"Your call cannot be completed " message?

-KS
jordan.bean Thu, 01/28/2010 - 09:34

We are having a strange problem as well.  We have:

Phone <- Internet -> ASA <-> Internal network w/CUCM, gateways, etc.

In doing our testing, some of the phones registered via Phone Proxy work fine.  Some phones have a no audio issue that can be reproduced every time.  i.e. one phone cannot check voicemail, another phone gets no audio when calling certain phone numbers but not others, etc.  The only thing that I have been able to see is that on a call with no audio, a "show phone-proxy media-sessions" shows only RTP sessions established when there should be a SRTP between the phone and the ASA.

I really think we're dealing with a bug here, but we don't SmartNet on our ASA's so I've had trouble getting a hold of someone that would take the time to really tell us if this is a bug or not.  We've made a significant investment in this feature.  If a TAC engineer is willing to take 10 minutes to look, we'd be extremely interested in some feedback regarding this issue.

jimmy-mcintyre Wed, 02/17/2010 - 04:46

I am seeing the same issue.  I have one interface or site with Cisco phones that can access voicemail and get 2 way audio and another that can access but only gets one way audio?

jordan.bean Wed, 02/17/2010 - 05:47

Our problem ended up being call recording related.  If call recording was enabled on a line on a proxy phone, the phone would experience no-way audio in certain situations and work find in other situation.  Disabling call recording fixed the problem.

lusandi Fri, 04/08/2011 - 10:15

Hello my name is Luis from TAC security team,

Can you post the following information.

Complete network topology.

Unity version:

Call manager version:

Screenshot of the configuration of the IP phone:

Debug phone-proxy media

debug phone-proxy signaling.

How many call manager servers do you have?

show run of the ASA and show route.

Regards,

Luis Sandi

Actions

This Discussion

Related Content