HSRP error message .

Unanswered Question
Dec 10th, 2009
User Badges:

HI All ,


We are  facing  the below error message in two num of  HSRP configured switches ( 7606 - c7600s7203 adventerprise k9 -mz- 122-33 SRB4.bin )



Error message :-


Dec 11 02:45:06: %HSRP-4-DIFFVIP1: Vlan304 Grp 100 active routers virtual IP address 10.66.244.1 is different to the locally configured address


10.66.8.1 Dec 11 02:45:06: %HSRP-5-STATECHANGE: Vlan304 Grp 100 state Standby -> Listen Dec 11 02:45:06: %HSRP-5-STATECHANGE: Vlan308


Grp 100 state Standby -> Listen Dec 11 02:45:26: %HSRP-5-STATECHANGE: Vlan308 Grp 100 state Speak -> Standby Dec 11 02:45:45: %HSRP-5-


STATECHANGE: Vlan304 Grp 100 state Speak -> Standby



1)   We have   confirmed there  is no  VIP  defference in between these two switch configurations (same standby ip ).


interface Vlan302

ip vrf forwarding 320 .

ip address 10.66.4.2 255.255.254.0

ip helper-address  x.x.x.x

ip helper-address  x.x.x.x

ip helper-address  x.x.x.x

standby 100 ip 10.66.4.1

standby 100 priority 254

standby 100 preempt


2) We also  ensured  local and  peer  status  are not the same ( in Active and standby mode)




#sh standby brief   


     P indicates configured to preempt.               


    Interface Grp  Pri P  State  Active               Standby        Virtual IP


Vl302    100  254 P        Standby 10.66.4.3      local          10.66.4.1



3) There are  multiple VLANs and HSRP   with same configuration but the error  message is  for the  three VLANS .


  Because  of this issue connected  LAN is getting disconnected  frequentely .  So please sugest how  can us  sort out this issue .


Regards,

Sinjish.K

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Fri, 12/11/2009 - 00:00
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

k_sinjish wrote:


HI All ,


We are  facing  the below error message in two num of  HSRP configured switches ( 7606 - c7600s7203 adventerprise k9 -mz- 122-33 SRB4.bin )



Error message :-


Dec 11 02:45:06: %HSRP-4-DIFFVIP1: Vlan304 Grp 100 active routers virtual IP address 10.66.244.1 is different to the locally configured address


10.66.8.1 Dec 11 02:45:06: %HSRP-5-STATECHANGE: Vlan304 Grp 100 state Standby -> Listen Dec 11 02:45:06: %HSRP-5-STATECHANGE: Vlan308


Grp 100 state Standby -> Listen Dec 11 02:45:26: %HSRP-5-STATECHANGE: Vlan308 Grp 100 state Speak -> Standby Dec 11 02:45:45: %HSRP-5-


STATECHANGE: Vlan304 Grp 100 state Speak -> Standby



1)   We have   confirmed there  is no  VIP  defference in between these two switch configurations (same standby ip ).


interface Vlan302

ip vrf forwarding 320 .

ip address 10.66.4.2 255.255.254.0

ip helper-address  x.x.x.x

ip helper-address  x.x.x.x

ip helper-address  x.x.x.x

standby 100 ip 10.66.4.1

standby 100 priority 254

standby 100 preempt


2) We also  ensured  local and  peer  status  are not the same ( in Active and standby mode)




#sh standby brief   


     P indicates configured to preempt.               


    Interface Grp  Pri P  State  Active               Standby        Virtual IP


Vl302    100  254 P        Standby 10.66.4.3      local          10.66.4.1



3) There are  multiple VLANs and HSRP   with same configuration but the error  message is  for the  three VLANS .


  Because  of this issue connected  LAN is getting disconnected  frequentely .  So please sugest how  can us  sort out this issue .


Regards,

Sinjish.K


Sinjish


Is there a typo in the above because the error messages i referring to VIP 10.66.244.1 but you have configured 10.66.4.1  ie. the 3rd octet is different.


Also the error message is about vlan 304 but you have posted config for vlan 302 ?


Jon

Giuseppe Larosa Fri, 12/11/2009 - 01:07
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sinjish,


all HSRP groups share the same group id. HSRP messages are sent with a multicast destination of all routers in subnet 224.0.0.2 that cannot be routed (link local multicast)


You probably receive in vlan 304 HSRP messages sourced in vlan 308.


This happens because for example someone connected one port in vlan 304 to one in vlan 308 somewhere in your campus.


The device receiving the mismatching HSRP message signals the problem.


I recommend to add HSRP passwords and to use different passwords for each vlan.

This helps because for example we have seen in case like this that cpu of switches including C6500 can go very high causing problems.


But you need to fix the unwanted joining of different vlans.


Hope to help

Giuseppe

Actions

This Discussion