fax to email problem

Unanswered Question

I have recently upgraded to software pack 8.0.0 on my uc520 and now I cannot get fax to email working. I have uploaded app_faxmail_onramp. file to the flash card, i have put in the following config:


service onramp flash:app_faxmail_onramp.

fax receive called-subscriber 81234567
fax interface-type fax-mail
mta send server port 25
mta send subject Faxmail message
mta send mail-from hostname abc.com
mta send mail-from username $s$
dial-peer voice 2500 mmoip
description FAX to EMAIL
service fax_on_vfc_onramp_app out-bound
destination-pattern 123AAAA123
information-type fax
dial-peer voice 3021 pots
description Incoming Fax
translation-profile incoming INCOMING-FAX
service onramp
incoming called-number 81234567
port 0/2/0:15
voice translation-rule 27
rule 1 /81234567/ /123AAAA123/
voice translation-profile INCOMING-FAX
translate called 27

running a 'debug voip dialpeer' I can see that the incoming call is being translated to 123AAAA123 with type DIALPEER_INFO_FAX but the caller hears an engaged tone after dialling the fax number.

if anyone could provide any help that would be good. I'm assuming this is something simple I have mistyped. I know this works as I have set it up many times before on different uc520 devices. it feels like the script is not running properly on the flash, but i have verified that the file does exist on the flash card and that the service onramp is loaded in application.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Marcos Hernandez Fri, 12/11/2009 - 06:36
User Badges:
  • Blue, 1500 points or more

Forgive my ignorance, but what do you mean by "engaged tone"?



Ben Skinner Tue, 12/22/2009 - 04:56
User Badges:

Care to share the soloution?

Will be upgrading to v8 shortly.


JOHN NIKOLATOS Sun, 12/27/2009 - 13:20
User Badges:
  • Bronze, 100 points or more

When you enable fax using the "fax interface-type fax-mail" the router needs a reload..  I have setup so many of these and ran into the same issue .. I just forgot to reload the router.... and the command after applying it, says "You must reboot the router.."  but  I get so caught up in other configurations I forgot


This Discussion