Routing between same subnet...

Answered Question
Dec 11th, 2009
User Badges:

Hi from Australia y'all,


I have a W2K server with 2 NIC:


192.168.0.1 -> Ethernet connection to internal workstations, DHCP service enabled;


10.0.0.2 -> Ethernet connection to Linksys AM-300 ADSL Modem (RRAS demand dial PPPoE).


This works fine. Clients on 192.168.0.x can obtain DHCP lease, browse, etc without incident.

I have an SPA3102 which is on 192.168.1.1. Plugged into that is another Wireless VoIP WRT54GP2 router (192.168.1.2). This, of course, has DHCP disabled. (All devices on both networks are connected to the same switch.)


My clients (192.168.0.x) cannot even ping the SPA3102 (located at 192.168.1.1)


When wireless clients connect to the access point, I want it to fetch DHCP addresses from the 192.168.0.x pool. At the moment no addresses are being handed out whatsoever.


Any ideas = greatly appreciated.

P.S: Due to the complexity of the VoIP/PBX system, I cannot simply put the VoIP devices on the 192.168.0.x network.

1. Make the W2K server's DHCP service authoritative for the scope 192.168.0.1 - 192.168.1.254 - Yes just create another scope if you need to


2. Change the DHCP subnet leasing to 255.255.0.0 - Yes this extends the "collision domain" to both subnets


3. Change the subnet of the server (192.168.0.1) from the default of 255.255.255.0 to 255.255.0.0 - ALL device masks must change to 255.255.0.0


4. Change (or leave) the default gateway as 192.168.0.1 - Yes ALL devices EXCEPT the ADSL Router


5. Leave the Routing and remote access demand-dial interface as is - Yes this does not need to change


6. Connect a Wireless client to the router at 192.168.1.2 and get an IP address - yes.


7. Leave all current config as is for the 10.x.x.x devices.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
adrianoday Fri, 12/11/2009 - 14:45
User Badges:

Where does the 192.168.1.0/24 decvice connect to?  At the most this is just a routing issue.


There are 2 devices on 192.168.1.x,


192.168.1.1 -> SPA3102 VoIP/PSTN Gateway (connected to switch)


192.168.1.2 -> WRT54GP2 VoIP Gateway (connected to SPA3102, which, in turn, connects to switch).


I need to be able to access these devices from 192.168.0.x.


At the moment, I can't.

As from my other post - you have 2 subnets 192.168.0.0/24 and 192.168.1.0/24, without a layer 3 routing device, they will not talk.


You either change the subnet mask in both 192.168.0.0 & 192.168.1.0 from 255.255.255.0 to 255.255.0 or you change the topology and or get a router and or a layer 3 switch.


The design is flawed.

Ganesh Hariharan Fri, 12/11/2009 - 10:05
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi,


You have made proxy server for internet one side connected to adsl modem and other nic is shared for clients which gets an ip address in the range of 192.168.0.x rite !!


Is 192.168.1.x subnet is also connected to same switch and you want 192.168.0.x subnet should talk to 192.168.1.x subnet ?



Regards

Ganesh.H

quick & nasty solution:-


Change the subnet mask for 192.168.0.0 & 192.168.1.0 from 255.255.255.0 to 255.255.0.0


Make sure all devices except ADSL modem connected to the LAN switch.


Have the default gateway for all devices in the LAN point to the W2K.


The W2K server has a default GW of the ADSL modem - problems solved.  The above makes the W2K server the "router" for the LAN.

adrianoday Fri, 12/11/2009 - 23:02
User Badges:

Thanks to all for all your help to date!


This kind of service is absolutley extinct in Australia!


So please advise me if this will work (I'm totally new to advanced routing etc...)


1. Make the W2K server's DHCP service authoritative for the scope 192.168.0.1 - 192.168.1.254;


2. Change the DHCP subnet leasing to 255.255.0.0;


3. Change the subnet of the server (192.168.0.1) from the default of 255.255.255.0 to 255.255.0.0;


4. Change (or leave) the default gateway as 192.168.0.1;


5. Leave the Routing and remote access demand-dial interface as is;


6. Connect a Wireless client to the router at 192.168.1.2 and get an IP address!!!!

Correct Answer

1. Make the W2K server's DHCP service authoritative for the scope 192.168.0.1 - 192.168.1.254 - Yes just create another scope if you need to


2. Change the DHCP subnet leasing to 255.255.0.0 - Yes this extends the "collision domain" to both subnets


3. Change the subnet of the server (192.168.0.1) from the default of 255.255.255.0 to 255.255.0.0 - ALL device masks must change to 255.255.0.0


4. Change (or leave) the default gateway as 192.168.0.1 - Yes ALL devices EXCEPT the ADSL Router


5. Leave the Routing and remote access demand-dial interface as is - Yes this does not need to change


6. Connect a Wireless client to the router at 192.168.1.2 and get an IP address - yes.


7. Leave all current config as is for the 10.x.x.x devices.

adrianoday Sat, 12/12/2009 - 07:54
User Badges:

Hi guys,


The subnet 255.255.0.0 is working on my server and clients, however, the VoIP devices are not so friendly!


(No option for 255.255.0.0)


I have the following Class C subnets to choose from in a drop down list (in the router config pages):


255.255.255.0

255.255.255.128

255.255.255.192

255.255.255.224

255.255.255.240

255.255.255.248

255.255.255.252


Which one includes the range for 192.168.0.x - 192.168.1.x and the 255.255.0.0 subnet?


Thanks again guys!


- Adrian

adrianoday Mon, 12/14/2009 - 04:13
User Badges:

Ok...


I have a Cisco 877 on the way!


The Linksys devices have a silly drop down menu with limited subnet masks:


255.255.255.0
255.255.255.128
255.255.255.192
255.255.255.224
255.255.255.240
255.255.255.248
255.255.255.252


I wanted to avoid at all costs, putting all devices on the 255.255.0.0 subnet, couldn't do that anyway with the above limitation.


I will put all 192.168.0.x devices on ETH0 and all 192.168.1.x on ETH1.

The layer 3 routing auto bridges the networks.

$1287.80 gone, but so is my headache!


Thanks for all your suggestions.

Actions

This Discussion