(RESOLVED) Modem Passthrough Configured on MGCP Registered 3845 GW in CUCM 7.X but showing Disabled running "sh mgcp" on Gateway?

Unanswered Question
Dec 10th, 2009
User Badges:

Hi All

         We migrated from Avaya G3r to CUCM 7.X in our new office and currently have two issues related to Modem Passthrough.


  If we initiate an Modem > V 224 (MGCP) > outward > 3845 (MGCP) > E1 Controller PRI > PSTN Modem Dail-up this works fine!


  However


  If we receive a PSTN > E1 Controller PRI > 3845 (MGCP) > inward > VG 224 (MGCP) > Modem


  The Modem answers but calling party can hear the tones cutting in and out (like it does on Fax calls which work, is this a polling or listening action to determine the data type?) but the modems fail to handshake and negate a connection.


Also if we try placing an internal call modem call on the same VG 224 from Port 1 to 2 the Dial Up also fails with the same strange tones being heard.



With regards to the Inward PSTN issue I have investigated the 3845 GW2 and found that if I run a "sh mgcp" Modem Passthrough is showing as disabled, however when i look at the Gateway in CUCM 7.X it shows as enabled?


SMFRA0PAR07VGW01#sh mgcp


MGCP voip modem passthrough mode: NSE, codec: g711alaw, redundancy: ENABLED,

MGCP voaal2 modem passthrough disabled

MGCP voip modem relay: Disabled


Screen shot of CUCM 7.X showing Modem Passthrough Enabled.


gw.JPG




sh run
Building configuration...



Current configuration : 6212 bytes
!
! Last configuration change at 13:50:31 GMT Thu Dec 10 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime localtime
no service password-encryption
!
hostname GW02 (edited))
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 xxxxx.
!
no aaa new-model
clock timezone GMT 1
clock summer-time Paris recurring last Sun Mar 2:00 last Sun Oct 3:00
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
network-clock-select 2 E1 0/1/1
network-clock-select 3 E1 0/0/1
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
ip domain name france.sun.com
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
voice-card 0
dsp services dspfarm
!
!
!
voice service pots
!
voice service voip
fax protocol cisco
!
!
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
!
!
!
!
voice class h323 1
h225 timeout tcp establish 3
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-1950490180
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1950490180
revocation-check none
rsakeypair TP-self-signed-1950490180
!
!
crypto pki certificate chain TP-self-signed-1950490180
certificate self-signed 01
bla bla

   quit
!
!
!
!
!
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31 service mgcp
!
controller E1 0/0/1
framing NO-CRC4
pri-group timeslots 1-31 service mgcp
!
controller E1 0/1/0
framing NO-CRC4
pri-group timeslots 1-31 service mgcp
!
controller E1 0/1/1
framing NO-CRC4
pri-group timeslots 1-31 service mgcp
!
!
!
interface Loopback0
ip address xxx.xxx.xxx.xxx 255.255.255.255
!
interface GigabitEthernet0/0
ip address xxx.xxx.xxx.xxx 255.255.255.224
ip ospf message-digest-key 1 md5 xxxxxx
ip ospf cost 2
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address xxx.xxx.xxx.xxx 255.255.255.224
ip ospf message-digest-key 1 md5 xxxxx

duplex auto
speed auto
media-type rj45
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/0/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
interface Serial0/1/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
router ospf 1
router-id 129.157.57.253
log-adjacency-changes
area 65509 authentication message-digest
network xxx.xxx.xxx.xxx 0.0.0.63 area

xxx network xxx.xxx.xxx.xxx 0.0.0.0 area xxx

!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx

ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
--More--                           !
!
!
kron occurrence write-memory at 22:00 recurring
policy-list write-memory
!
kron policy-list write-memory
cli write memory
cli write memory
!
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/1/0:15
!
voice-port 0/0/0:15
echo-cancel coverage 64
cptone FR
bearer-cap Speech
!
voice-port 0/0/1:15
echo-cancel coverage 64
cptone FR
bearer-cap Speech
!
voice-port 0/1/1:15
echo-cancel coverage 64
cptone FR
bearer-cap Speech
!
ccm-manager fallback-mgcp
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 129.157.28.11 
ccm-manager config
!
mgcp
mgcp call-agent 129.157.28.11 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode cisco
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0
!
mgcp profile default
!
!
!
!
!
!
line con 0
password xxxxxx
login local
line aux 0
line vty 0 4
session-timeout 60
privilege level 15
password attrul35
login
transport input telnet ssh
line vty 5 15
session-timeout 60
privilege level 15
password attrul35
login
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server xxx.xxxx.xxx.xxx

ntp server xxx.xxx.xxx.xxx

end

GW02#



Here is a VTSP debug for an PSTN > E1 Controller PRI > 3845 (MGCP) > inward > VG 224 (MGCP) > Modem


  Question, Ive never read any of these debugs before but is this showing that it thinks the modem call is a Fax call?




show debug
VTSP:
  debug voip vtsp event is ON (filter is OFF)
  debug voip vtsp error software is ON
  debug voip vtsp error call is ON (filter is OFF)
  debug voip vtsp inout is ON (filter is OFF)



SMFRA0PAR07VGW03#
Dec  9 10:16:33.950: //-1/xxxxxxxxxxxx/VTSP:(2/12):-1:-1:-1/vtsp_allocate_cdb:


   CDB=0x64C70608
Dec  9 10:16:33.950: //-1/xxxxxxxxxxxx/VTSP:(2/12):-1:-1:-1/vtsp_insert_cdb:
Dec  9 10:16:33.954: //-1/xxxxxxxxxxxx/VTSP:(2/12):-1:-1:-1/vtsp_process_event:


   [state:INVALID STATE MACHINE, event:E_CC_SETUP_REQ]
Dec  9 10:16:33.954: //18/C2E38E9A8007/VTSP:(2/12):-1:-1:-1/vtsp_og_call_req:
   Echo Cancel=TRUE, Gain Control=0
   Auto Gain Control=FALSE, Dual Tone Detect Mask=0x0, Seq Tone Detect=FALSE
Dec  9 10:16:33.958: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_SETUP_REQ_PEND, event:E_VTSP_DSM_OPEN_SUCCESS]
Dec  9 10:16:33.958: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_setup_req_pend_suc
c:
Dec  9 10:16:33.958: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_request_call:
   Mode=9, Peer=0
Dec  9 10:16:33.958: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_request_call:
   Progress Indication=0, Info Trans Capability=0
   Calling Number=, TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentati
on=Allowed
   Called Number=, TON=Unknown, NPI=Unknown
Dec  9 10:16:33.962: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_SETUP_REQUEST, event:E_TSP_PROCEEDING]
Dec  9 10:16:33.962: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_setup_pend_proceed
ing:
Dec  9 10:16:33.962: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_timer:
   Timer Start Time=146185, Timer Value=25000(ms)
Dec  9 10:16:33.962: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_setup_pend_proceed
ing:
   Peer=0, Progress Indication=0, Return Code=2
Dec  9 10:16:33.962: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_NULL, event:E_VTSP_DSM_OPEN_SUCCESS]
Dec  9 10:16:33.966: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_setup_req_wait_pen
d_success:
   Event=73
Dec  9 10:16:33.966: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_timer_stop:
   Timer Stop Time=146185
Dec  9 10:16:33.966: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_report_digit_cont
rol:
Dec  9 10:16:33.966: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_report_digit_cont
rol:
   Digit Reporting=TRUE
Dec  9 10:16:33.970: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_save_fax_conf
ig:
   Fax Relay=DISABLED - MGCP Application
   Primary Fax Protocol=IGNORE_FAX_RELAY, Fallback Fax Protocol=IGNORE_FAX_RELAY


   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type
Dec  9 10:16:33.970: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_SETUP_REQ_PROC, event:E_CC_DO_CAPS_IND]
Dec  9 10:16:33.970: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_peer_event_cb
:
   Event=E_DSM_CC_CAPS_ACK
Dec  9 10:16:33.970: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_SETUP_REQ_PROC, event:E_CC_CAPS_IND]
Dec  9 10:16:33.970: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_peer_event_cb
:
   Event=E_DSM_CC_CALL_MODIFY
Dec  9 10:16:33.974: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_save_fax_conf
ig:
   Fax Relay=DISABLED - MGCP Application
   Primary Fax Protocol=IGNORE_FAX_RELAY, Fallback Fax Protocol=IGNORE_FAX_RELAY


   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type
Dec  9 10:16:33.978: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_feature_notif
y_cb:
   Feature ID=0, Feature Status=1
Dec  9 10:16:33.982: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_SETUP_REQ_PROC, event:E_CC_FEATURE]
Dec  9 10:16:33.982: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_call_feature:
   Feature Type=24, Ring Cycle=0
Dec  9 10:16:33.982: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_SETUP_REQ_PROC, event:E_TSP_ALERT]
Dec  9 10:16:33.982: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_setup_pend_alert_n
o_timeout:
   Progress Indication=8
Dec  9 10:16:33.986: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_setup_pend_alert_n
o_timeout:
   Ringback Indication=TRUE
Dec  9 10:16:36.558: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_feature_notif
y_cb:
   Feature ID=6, Feature Status=2
Dec  9 10:16:36.562: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_feature_notif
y_cb:
   Feature ID=0, Feature Status=1
Dec  9 10:16:36.758: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_SETUP_REQ_PROC, event:E_TSP_CONNECT]
Dec  9 10:16:36.758: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_ring_noan_timer_s
top:
   Timer Stop Time=146464
Dec  9 10:16:36.762: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_CONNECT, event:E_CC_FEATURE]
Dec  9 10:16:36.762: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_call_feature:
   Feature Type=34
Dec  9 10:16:36.770: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_report_digit_cont
rol:
Dec  9 10:16:36.770: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_report_digit_cont
rol:
   Digit Reporting=TRUE
Dec  9 10:16:36.774: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_save_fax_conf
ig:
   Fax Relay=ENABLED
   Primary Fax Protocol=CISCO_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type
Dec  9 10:16:39.754: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_media_event_c
b:
   Event=E_DSMP_DSP_MODEM_TONE
Dec  9 10:16:39.794: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_peer_event_cb
:
   Event=E_DSM_CC_MODIFY_MEDIA_ACK
Dec  9 10:16:39.794: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_save_fax_conf
ig:
   Fax Relay=ENABLED
   Primary Fax Protocol=CISCO_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type
Dec  9 10:16:53.394: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_report_digit_cont
rol:
Dec  9 10:16:53.394: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_report_digit_cont
rol:
   Digit Reporting=FALSE
Dec  9 10:16:53.398: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_save_fax_conf
ig:
   Fax Relay=ENABLED
   Primary Fax Protocol=CISCO_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type
Dec  9 10:16:53.410: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_CONNECT, event:E_CC_FEATURE]
Dec  9 10:16:53.410: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_call_feature:
   Feature Type=6
Dec  9 10:16:53.414: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_save_fax_conf
ig:
   Fax Relay=ENABLED
   Primary Fax Protocol=CISCO_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type
Dec  9 10:16:55.634: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_CONNECT, event:E_TSP_DISCONNECT_IND]
Dec  9 10:16:55.634: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_generate_disc:
   Cause Value=16
Dec  9 10:16:55.634: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_timer_stop:
   Timer Stop Time=148352
Dec  9 10:16:55.634: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_ring_noan_timer_s
top:
   Timer Stop Time=148352
Dec  9 10:16:55.634: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_set_release_sourc
e:
   Release Direction=PSTN, Release Source=Called Party-PSTN
Dec  9 10:16:55.634: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_timer:
   Timer Start Time=148352, Timer Value=15000(ms)
Dec  9 10:16:55.634: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_generate_disc:
   Return Code=0
Dec  9 10:16:55.638: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_CONNECT, event:E_CC_DISCONNECT]
Dec  9 10:16:55.638: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_disconnect:
   Cause Value=16, Previous Cause Value=16
Dec  9 10:16:55.638: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_ring_noan_timer_s
top:
   Timer Stop Time=148352
Dec  9 10:16:55.638: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_dsm_save_fax_conf
ig:
   Call Entry=NULL, Call Id=19
Dec  9 10:16:55.654: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_WAIT_STATS, event:E_VTSP_DSM_STATS_COMPLETE]
Dec  9 10:16:55.654: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_dsm_dsp_stats_comp
lete:
Dec  9 10:16:55.654: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_timer:
   Timer Start Time=148354, Timer Value=60000(ms)
Dec  9 10:16:55.654: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_process_event:
   [state:S_WAIT_RELEASE, event:E_TSP_DISCONNECT_CONF]
Dec  9 10:16:55.658: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/act_wrelease_release:


Dec  9 10:16:55.658: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_play_busy_timer_s
top:
   Timer Stop Time=148354
Dec  9 10:16:55.658: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_timer_stop:
   Timer Stop Time=148354
Dec  9 10:16:55.658: //18/C2E38E9A8007/VTSP:(2/12):-1:1:2/vtsp_is_valid_dsm_hand
le:
   DMGR=0x64B4C75C, VTSP CDB=0x64C70608
Dec  9 10:16:55.662: //18/C2E38E9A8007/VTSP:(2/12):-1:-1:-1/vtsp_process_event:


   [state:S_CLOSE_DSPRM, event:E_VTSP_DSM_CLOSE_COMPLETE]
Dec  9 10:16:55.662: //18/C2E38E9A8007/VTSP:(2/12):-1:-1:-1/act_terminate:
Dec  9 10:16:55.662: //18/C2E38E9A8007/VTSP:(2/12):-1:-1:-1/vtsp_timer_stop:
   Timer Stop Time=148355
Dec  9 10:16:55.662: //-1/C2E38E9A8007/VTSP:(2/12):-1:-1:-1/vtsp_free_cdb:
   CDB=0x64C70608no debug all
All possible debugging has been turned off
SMFRA0PAR07VGW03#



SMFRA0PAR07VGW03#show call active voice brief


<ID>: <CallID> <start>ms.<index> +<connect> pid:<peer_id> <dir> <addr> <state>
  dur hh:mm:ss tx:<packets>/<bytes> rx:<packets>/<bytes>
IP <ip>:<udp> rtt:<time>ms pl:<play>/<gap>ms lost:<lost>/<early>/<late>
  delay:<last>/<min>/<max>ms <codec>


media inactive detected:<y/n> media cntrl rcvd:<y/n> timestamp:<time>


long duration call detected:<y/n> long duration call duration :<sec> timestamp:
<time>
  MODEMPASS <method> buf:<fills>/<drains> loss <overall%> <multipkt>/<corrected>


   last <buf event time>s dur:<Min>/<Max>s
FR <protocol> [int dlci cid] vad:<y/n> dtmf:<y/n> seq:<y/n>
  <codec> (payload size)
ATM <protocol> [int vpi/vci cid] vad:<y/n> dtmf:<y/n> seq:<y/n>
  <codec> (payload size)
Tele <int> (callID) [channel_id] tx:<tot>/<v>/<fax>ms <codec> noise:<l> acom:<l
> i/o:<l>/<l> dBm
  MODEMRELAY info:<rcvd>/<sent>/<resent> xid:<rcvd>/<sent> total:<rcvd>/<sent>/<
drops>
         speeds(bps): local <rx>/<tx> remote <rx>/<tx>
Proxy <ip>:<audio udp>,<video udp>,<tcp0>,<tcp1>,<tcp2>,<tcp3> endpt: <type>/<m
anf>
bw: <req>/<act> codec: <audio>/<video>
  tx: <audio pkts>/<audio bytes>,<video pkts>/<video bytes>,<t120 pkts>/<t120 by
tes>
rx: <audio pkts>/<audio bytes>,<video pkts>/<video bytes>,<t120 pkts>/<t120 byt
es>



Telephony call-legs: 1
SIP call-legs: 0
H323 call-legs: 0
Call agent controlled call-legs: 1
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2
11E9 : 35 3608470ms.1 +0 pid:0 Originate  connecting
dur 00:00:13 tx:559/122674 rx:560/88664
IP 129.157.57.253:18318 SRTP: off rtt:4ms pl:2800/0ms lost:0/0/0 delay:65/65/65
ms g711alaw TextRelay: off
media inactive detected:n media contrl rcvd:n/a timestamp:n/a
long duration call detected:n long duration call duration:n/a timestamp:n/a
  MODEMPASS nse buf:0/0 loss 0% 0/0  last 2800s dur:0/0s


11E9 : 34 3608470ms.2 +2790 pid:0 Originate  active
dur 00:00:11 tx:561/93312 rx:569/124359
Tele 2/12 (34) [2/12] tx:8050/8050/0ms g711alaw noise:-30 acom:6  i/0:-15/-65 d
Bm



Telephony call-legs: 1
SIP call-legs: 0
H323 call-legs: 0
Call agent controlled call-legs: 1
SCCP call-legs: 0
Multicast call-legs: 0
Total call-legs: 2


Any assistance would be much appreciated.


Regards Greg

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Greg Cording Thu, 12/10/2009 - 14:14
User Badges:

Hi Again


  Following on from the thought that the 3845 is miss categorizing the Modem V.92 Call as a Fax call I completed two test calls.


  One V.92 Call to the Modem Pool and another Fax call to a Fax Machine on the same VG 224 Gateway.


  I ran two "debug voice vtsp", one the V.92 and the other for the Fax call and placed them side by side for comparison.


  Now I am no expert on reading these debugs but to me it looks like the V.92 Modem Call is being treated as if it were a Fax call with the exception of a couple of lines that done seem to be anything to do with Modem Passthrough?


  If anyone has any experience of looking at these traces I would really appreciate an expert option my theory?


  Thanks Greg


(Left and Righ Scoll Bar at the bottom of the page)


Data Call to Modem Pool Hunt PilotFax call
SMFRA0PAR07VGW02#SMFRA0PAR07VGW02#
Dec 10 21:27:37.379: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:36:39.173: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   Fax Relay=DISABLED - MGCP Application   Fax Relay=DISABLED - MGCP Application
   Primary Fax Protocol=IGNORE_FAX_RELAY, Fallback Fax Protocol=IGNORE_FAX_RELAY   Primary Fax Protocol=IGNORE_FAX_RELAY, Fallback Fax Protocol=IGNORE_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type   Fax Parameters Set By=MGCP Call Type
Dec 10 21:27:37.383: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:36:51.353: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   Fax Relay=ENABLED   Fax Relay=ENABLED
   Primary Fax Protocol=T38_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY   Primary Fax Protocol=T38_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type   Fax Parameters Set By=MGCP Call Type
Dec 10 21:27:37.383: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:36:51.353: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   LS Red=0, HS Red=0   LS Red=0, HS Red=0
Dec 10 21:27:39.487: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_media_event_cb:Dec 10 21:36:53.449: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_media_event_cb:
   Event=E_DSMP_DSP_REPORT_PEER_TO_PEER_MSG   Event=E_DSMP_DSP_REPORT_PEER_TO_PEER_MSG
Dec 10 21:27:39.487: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_handle_rtp_p2p_msg: P2P event 192 received.Dec 10 21:36:53.449: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_handle_rtp_p2p_msg: P2P event 192 received.
Dec 10 21:27:39.567: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_peer_event_cb:Dec 10 21:36:53.533: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_peer_event_cb:
   Event=E_DSM_CC_MODIFY_MEDIA_ACK   Event=E_DSM_CC_MODIFY_MEDIA_ACK
Dec 10 21:27:39.567: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:36:53.533: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   Fax Relay=ENABLED   Fax Relay=ENABLED
   Primary Fax Protocol=T38_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY   Primary Fax Protocol=T38_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type   Fax Parameters Set By=MGCP Call Type
Dec 10 21:27:39.567: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:36:53.533: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   LS Red=0, HS Red=0   LS Red=0, HS Red=0
Dec 10 21:36:57.369: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_peer_event_cb:
   Event=E_DSM_CC_MR_START
Dec 10 21:27:54.403: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:37:26.370: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   Fax Relay=ENABLED   Fax Relay=ENABLED
   Primary Fax Protocol=T38_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY   Primary Fax Protocol=T38_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type   Fax Parameters Set By=MGCP Call Type
Dec 10 21:27:54.403: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:37:26.370: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   LS Red=0, HS Red=0   LS Red=0, HS Red=0
Dec 10 21:27:54.415: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_report_digit_control:Dec 10 21:37:26.378: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_report_digit_control:
Dec 10 21:27:54.415: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_report_digit_control:Dec 10 21:37:26.378: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_report_digit_control:
   Digit Reporting=FALSE   Digit Reporting=FALSE
Dec 10 21:27:54.415: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_process_event:Dec 10 21:37:26.378: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_process_event:
   [state:S_CONNECT, event:E_CC_DISCONNECT]   [state:S_CONNECT, event:E_CC_DISCONNECT]
Dec 10 21:27:54.415: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/act_disconnect:Dec 10 21:37:26.378: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/act_disconnect:
   Cause Value=16   Cause Value=16
Dec 10 21:27:54.415: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_ring_noan_timer_stop:Dec 10 21:37:26.378: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_ring_noan_timer_stop:
   Timer Stop Time=3438243   Timer Stop Time=3495438
Dec 10 21:27:54.415: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:37:26.378: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   Fax Relay=ENABLED   Fax Relay=ENABLED
   Primary Fax Protocol=T38_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY   Primary Fax Protocol=T38_FAX_RELAY, Fallback Fax Protocol=CISCO_FAX_RELAY
   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED   Fax Relay CM Suppression :=ENABLED, Fax Relay ANS Suppression :=DISABLED
   Fax Parameters Set By=MGCP Call Type   Fax Parameters Set By=MGCP Call Type
Dec 10 21:27:54.415: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:Dec 10 21:37:26.378: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_dsm_save_fax_config:
   LS Red=0, HS Red=0   LS Red=0, HS Red=0
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_process_event:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_process_event:
   [state:S_WAIT_STATS, event:E_VTSP_DSM_STATS_COMPLETE]   [state:S_WAIT_STATS, event:E_VTSP_DSM_STATS_COMPLETE]
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/act_dsm_dsp_stats_complete:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/act_dsm_dsp_stats_complete:
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_timer:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_timer:
   Timer Start Time=3438244, Timer Value=60000(ms)   Timer Start Time=3495440, Timer Value=60000(ms)
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_process_event:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_process_event:
   [state:S_WAIT_RELEASE, event:E_TSP_DISCONNECT_CONF]   [state:S_WAIT_RELEASE, event:E_TSP_DISCONNECT_CONF]
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/act_wrelease_release:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/act_wrelease_release:
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_play_busy_timer_stop:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_play_busy_timer_stop:
   Timer Stop Time=3438244   Timer Stop Time=3495440
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_timer_stop:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_timer_stop:
   Timer Stop Time=3438244   Timer Stop Time=3495440
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:1:1/vtsp_is_valid_dsm_handle:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:1:1/vtsp_is_valid_dsm_handle:
   DMGR=0x68D65124, VTSP CDB=0x7123C2E0   DMGR=0x68D65124, VTSP CDB=0x7123B7C0
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:-1:-1/vtsp_process_event:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:-1:-1/vtsp_process_event:
   [state:S_CLOSE_DSPRM, event:E_VTSP_DSM_CLOSE_COMPLETE]   [state:S_CLOSE_DSPRM, event:E_VTSP_DSM_STATS_COMPLETE]
Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:-1:-1/vtsp_process_event:
   Unexpected EVENT [E_VTSP_DSM_STATS_COMPLETE] Received For STATE [S_CLOSE_DSPRM];
   Previous STATE [0.17 ]
Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:-1:-1/vtsp_process_event:
   [state:S_CLOSE_DSPRM, event:E_VTSP_DSM_CLOSE_COMPLETE]
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:-1:-1/act_terminate:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:-1:-1/act_terminate:
Dec 10 21:27:54.427: //1445/81061D8682D4/VTSP:(0/1/1:15):-1:-1:-1/vtsp_timer_stop:Dec 10 21:37:26.394: //1449/EF17FD8782D6/VTSP:(0/1/1:15):-1:-1:-1/vtsp_timer_stop:
   Timer Stop Time=3438244   Timer Stop Time=3495440
Dec 10 21:27:54.427: //-1/81061D8682D4/VTSP:(0/1/1:15):-1:-1:-1/vtsp_free_cdb:Dec 10 21:37:26.394: //-1/EF17FD8782D6/VTSP:(0/1/1:15):-1:-1:-1/vtsp_free_cdb:
   CDB=0x7123C2E0   CDB=0x7123B7C0
SMFRA0PAR07VGW02#SMFRA0PAR07VGW02#

Greg Cording Sun, 12/13/2009 - 08:57
User Badges:

We have resolved this issue..


We found the VG 224 on IOS Version 12.4(24)T2 and having the entry "mgcp modem passthrough voip redundancy" brakes the ability of the DSP Codec to determine the difference between and incoming Fax call and an incoming Modem Data Call.


  By removing "mgcp modem passthrough voip redundancy" we were able to get Modem Passthrough successfully running.


  Hope this helps someome else.


  Copy of our config:


ccm-manager fallback-mgcp
ccm-manager redundant-host xxx.xxx.xxx.xxx

ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server xxx.xxx.xxx.xxx
ccm-manager config


mgcp
mgcp call-agent xxx.xxx.xxx.xxx 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode cisco
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp modem passthrough voip codec g711alaw
mgcp codec g711alaw packetization-period 20
mgcp package-capability rtp-package
mgcp package-capability sst-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0



  Regards Greg

paolo bevilacqua Sun, 12/13/2009 - 13:13
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Thank you for sharing the solution for the problem you had.


In a way, I'd like the ones that recommend MGCP as a more "simpler and realiable protocol" than H.323 or SIP, to look at you config and the amount of work you had to do to have it resolved.

Wilson Samuel Sun, 07/12/2015 - 22:55
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Mobile User, July 2015

Yes, People usually say that MGCP is very "easy" protocol to config, however they ignore the fact that Cisco uses the MGCP ver 0.1 :-)

andyap Tue, 09/21/2010 - 03:01
User Badges:

Hi Greg,


I have a similar problem but i am not running on vg. I have a back to back to a pabx and the modem call just not going through.


pstn->(e1 mgcp->ccm->e1 mgcp)->pabx->modem


Anyone can shed some light?


Regards,


Andy

Henrique Ferreira Tue, 10/02/2012 - 13:47
User Badges:

I know it is an old post, but this month I had a similar issue when transmitting FAX over the WAN. Sound was choppy (tones cutting). I just removed "modem passthrough nse codec g711ulaw" and got it working with Cisco fax relay.

IOS: 12.4(24)T2.


Site 1                                                                               Site 2

FAX---FXS---SCCP---GATEWAY---WAN---GATEWAY---SCCP---FXS---FAX

Callmanager is in a different site.


Both Gateways have h323 and SCCP configuration. SCCP is only used to register the FXS (fax line) to callmanager.


Callmanager config for both gateways:

T.38 Fax Relay: Disabled

Cisco Fax Relay: enabled

Modem Passthrough: enabled


Gateway config:


voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol cisco

h323



Regards,


Henrique

Actions

This Discussion

Related Content