UC500 phone firmware upgrade "auth fail"

Answered Question
Dec 13th, 2009

Hi all,

I have a UC520 with 8.0 version installed, after de upgrade to 8.0 the phones don't upgrade the firmware, it starts the upgrade but immediately gives a "Auth Fail" in the screen, proceeding with the boot.

I haven't configured anything on phone security...

I welcome any help.

Regards

I have this problem too.
0 votes
Correct Answer by Hafthor Hilmarsson about 6 years 8 months ago

You will need to go under your flash and install the 8.5.2 firmware for that type of phone

So take backup of the 8.5.3 firmware and the lines in your config for 8.5.3

Then you will need to issue

For example

tftp-server flash:/phones/7941_7961/apps41.8-5-2TH1-9.sbn alias apps41.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/cnu41.8-5-2TH1-9.sbn alias cnu41.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/cvm41sccp.8-5-2TH1-9.sbn alias cvm41sccp.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/dsp41.8-5-2TH1-9.sbn alias dsp41.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/jar41sccp.8-5-2TH1-9.sbn alias jar41sccp.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/SCCP41.8-5-2S.loads alias SCCP41.8-5-2S.loads
tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads

ofcource have to no the old lines out which point towards the newer 8.5.3 firmware.

then you need to go to telephony-services

and do the loads

load 7960-7940 P00308010200
load 7941 SCCP41.8-5-2S
load 7941GE SCCP41.8-5-2S
load 7961 SCCP41.8-5-2S
load 7961GE SCCP41.8-5-2S
load 7970 SCCP70.8-5-2S
load 7971 SCCP70.8-5-2S
load 521G-524G cp524g-8-1-17

Reset the phone and they should program to 8.5.2

then move the old files back and restore the old config.

That will flash the phone to the 8.5.3 version which comes with 8.0

Hope this help

Regards

Hafthor Hilmarsson CCIE - Voice #24527

Correct Answer by Brandon Svec about 6 years 11 months ago

What kind of phones?  What firmware version are you upgrading them from and to?

If you are trying to go to SCCP 8.5.3 I think you need to be at 8.5.1 or 8.5.2 first or you will get this error because of new signed firmware versions.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Correct Answer
Brandon Svec Sun, 12/13/2009 - 15:04

What kind of phones?  What firmware version are you upgrading them from and to?

If you are trying to go to SCCP 8.5.3 I think you need to be at 8.5.1 or 8.5.2 first or you will get this error because of new signed firmware versions.

Correct Answer
Hafthor Hilmarsson Thu, 04/08/2010 - 11:14

You will need to go under your flash and install the 8.5.2 firmware for that type of phone

So take backup of the 8.5.3 firmware and the lines in your config for 8.5.3

Then you will need to issue

For example

tftp-server flash:/phones/7941_7961/apps41.8-5-2TH1-9.sbn alias apps41.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/cnu41.8-5-2TH1-9.sbn alias cnu41.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/cvm41sccp.8-5-2TH1-9.sbn alias cvm41sccp.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/dsp41.8-5-2TH1-9.sbn alias dsp41.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/jar41sccp.8-5-2TH1-9.sbn alias jar41sccp.8-5-2TH1-9.sbn
tftp-server flash:/phones/7941_7961/SCCP41.8-5-2S.loads alias SCCP41.8-5-2S.loads
tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads

ofcource have to no the old lines out which point towards the newer 8.5.3 firmware.

then you need to go to telephony-services

and do the loads

load 7960-7940 P00308010200
load 7941 SCCP41.8-5-2S
load 7941GE SCCP41.8-5-2S
load 7961 SCCP41.8-5-2S
load 7961GE SCCP41.8-5-2S
load 7970 SCCP70.8-5-2S
load 7971 SCCP70.8-5-2S
load 521G-524G cp524g-8-1-17

Reset the phone and they should program to 8.5.2

then move the old files back and restore the old config.

That will flash the phone to the 8.5.3 version which comes with 8.0

Hope this help

Regards

Hafthor Hilmarsson CCIE - Voice #24527

DIEGO ALONSO Fri, 07/09/2010 - 09:35

Hello double H,

I had the same "auth fail" problem after upgrading my UC520 from V4.2 to V8.0.4.  Reading thru your post I downloaded 8.5.2(SR1) thinking it was close enough and still have the error.  Should I go back and try 8.5.2 or is my problem maybe different?  Also, I see they have a .sgn file for download which I ignored.  What, if anything needs to be done with that file?

Thanks in advance.

Diego

rcordeiro Fri, 07/09/2010 - 09:45

Hi,

I just solved this by updating the phones firmware to release 9.

I tried several 8.x versions like someone stated by all of them gave the

"auth failed", but with the 9 release it upgraded well.

Regards,

Rui Cordeiro

Hafthor Hilmarsson Fri, 07/09/2010 - 09:48

Yes you have to upgrade to 8.5.2 the SR1 has the same "bug" issues.

You can also read about this in this case notes

https://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/firmware/8_5_2/english/release/notes/7900_852SR1.html

For all SCCP firmware upgrades from firmware  release versions earlier than 8.3(3) to version 8.5(2)SR1 or greater,  you must first upgrade your firmware to version 8.5(2). Once you have  upgraded to version 8.5(2), you can upgrade your IP Phone to version  8.5(2)SR1 or later.

DIEGO ALONSO Fri, 07/09/2010 - 10:05

I didn't want to go to 9 because I am not sure if it will work with V8 of CME on UC520.  Other than fixing the auth fail issue is there anything significant about the V9 loads?

Thanks,

Diego

rcordeiro Fri, 07/09/2010 - 10:39

Hi,

For me worked fine, nothing relevant to say about it. It works with

version 8 because I also have version 8 installed.

Regards,

Rui Cordeiro

Actions

This Discussion