How to avoid "garbage" characters when saving running config into editor such as putty, hyperterm?

Answered Question
Dec 13th, 2009

Hi folks, sometimes I use putty.exe or MS hyperterminal to save running config and I get some control characters like the ones below. What is the best way to avoid this? It is annoying and counter productive to edit this manually in case I have to roll back the config quickly. Thanks.

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2009.12.12 18:02:03 =~=~=~=~=~=~=~=~=~=~=~=

switch#
show       run
Building configuration...

Note:I noted that when I posted the symbols I referred to as 'garbage' into this thread, they remained unvisible. :-)

I have this problem too.
0 votes
Correct Answer by Jerry Ye about 6 years 12 months ago

Do you mean the character when you hit SPACE to advanced to the next part of the config while you are logging everything to a text file? If yes, you can do following in enable mode

term len 0

sh run

term len 24

Regards,

jerry

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jerry Ye Sun, 12/13/2009 - 19:12

Do you mean the character when you hit SPACE to advanced to the next part of the config while you are logging everything to a text file? If yes, you can do following in enable mode

term len 0

sh run

term len 24

Regards,

jerry

Ganesh Hariharan Mon, 12/14/2009 - 00:16

Try configure printable output option while saving some logs via putty.

Banner will come when ever you save any output but the garbage symbols will get off with this option !!

Hope this helps to some extent for your query !!

Regards

Ganesh.H

Actions

This Discussion